aboutsummaryrefslogtreecommitdiff
path: root/games/tads
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2003-01-17 08:50:23 +0000
committerKris Kennaway <kris@FreeBSD.org>2003-01-17 08:50:23 +0000
commitfd6cc2b7ee690056994f97496c8ac3e7afe0a6d5 (patch)
tree426c12a70bee467178472e9623c73137136629ae /games/tads
parent0bac00d4a5e43ef8b2250afb130e34776afdbb53 (diff)
downloadports-fd6cc2b7ee690056994f97496c8ac3e7afe0a6d5.tar.gz
ports-fd6cc2b7ee690056994f97496c8ac3e7afe0a6d5.zip
Add tads 2.5.7, a compiler, debugger and runtime interpreter of
adventure games/interactive fiction. See http://www.igs.net/~tril/if/best/ for sample game files.
Notes
Notes: svn path=/head/; revision=73320
Diffstat (limited to 'games/tads')
-rw-r--r--games/tads/Makefile19
-rw-r--r--games/tads/distinfo1
-rw-r--r--games/tads/files/patch-makefile29
-rw-r--r--games/tads/pkg-comment1
-rw-r--r--games/tads/pkg-descr17
-rw-r--r--games/tads/pkg-plist3
6 files changed, 70 insertions, 0 deletions
diff --git a/games/tads/Makefile b/games/tads/Makefile
new file mode 100644
index 000000000000..a384288c6de3
--- /dev/null
+++ b/games/tads/Makefile
@@ -0,0 +1,19 @@
+# New ports collection makefile for: tds
+# Date created: 17 Jan 2003
+# Whom: kris@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= tads
+PORTVERSION= 2.5.7
+CATEGORIES= games
+MASTER_SITES= http://www.ifarchive.org/if-archive/programming/tads2/source/
+DISTNAME= tads23-unix
+
+MAINTAINER= kris@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/tads/tads2
+MAKEFILE= makefile
+
+.include <bsd.port.mk>
diff --git a/games/tads/distinfo b/games/tads/distinfo
new file mode 100644
index 000000000000..d847fa2f8a0e
--- /dev/null
+++ b/games/tads/distinfo
@@ -0,0 +1 @@
+MD5 (tads23-unix.tar.gz) = 33a54946f42f2a8cf5d5189794351e6c
diff --git a/games/tads/files/patch-makefile b/games/tads/files/patch-makefile
new file mode 100644
index 000000000000..75dd25db794e
--- /dev/null
+++ b/games/tads/files/patch-makefile
@@ -0,0 +1,29 @@
+--- makefile.orig Fri Jan 17 00:30:32 2003
++++ makefile Fri Jan 17 00:30:49 2003
+@@ -238,16 +238,16 @@
+ # compatibility libraries installed. It has not been tested with a bare
+ # FreeBSD system without the Linux libraries.
+ #
+-#CC=gcc
+-#OPTIMIZE=
+-#UNIXFLAGS=-g -DOSANSI -DUNIX -DHAVE_STRCASECMP
+-#SYSFLAGS= -DOS_SYSTEM_NAME=\""FREEBSD_386"\" -DSYSNAME=\""i386+ running FreeBSD"\" -DSYSPL=\"1\" -DPORTER=\""$(DAVE)"\" -DSYSMAINTAINER=\""FreeBSD port maintained by $(DAVE)\n"\"
+-#CFLAGS= $(UNIXFLAGS) $(SYSFLAGS) -DFREEBSD_386
+-#AFLAGS=
+-#OVLFLG=
+-#MACHDEP=
+-#LIBS=-ltermcap
+-#MAKEXEC=touch
++CC?=cc
++OPTIMIZE=
++UNIXFLAGS=-g -DOSANSI -DUNIX -DHAVE_STRCASECMP
++SYSFLAGS= -DOS_SYSTEM_NAME=\""FREEBSD_386"\" -DSYSNAME=\""i386+ running FreeBSD"\" -DSYSPL=\"1\" -DPORTER=\""$(DAVE)"\" -DSYSMAINTAINER=\""FreeBSD port maintained by $(DAVE)\n"\"
++CFLAGS+= $(UNIXFLAGS) $(SYSFLAGS) -DFREEBSD_386
++AFLAGS=
++OVLFLG=
++MACHDEP=
++LIBS=-ltermcap
++MAKEXEC=touch
+
+ # OpenBSD 3.0 with gcc 2.95.3
+ # This has been compiled on an i386 system running OPENBSD 3.0
diff --git a/games/tads/pkg-comment b/games/tads/pkg-comment
new file mode 100644
index 000000000000..4993fa5c940d
--- /dev/null
+++ b/games/tads/pkg-comment
@@ -0,0 +1 @@
+TADS compiler/interpreter for interactive fiction
diff --git a/games/tads/pkg-descr b/games/tads/pkg-descr
new file mode 100644
index 000000000000..b8c39bc28521
--- /dev/null
+++ b/games/tads/pkg-descr
@@ -0,0 +1,17 @@
+TADS is a set of programming tools specially designed for writing
+adventure games. TADS consists of:
+ * A programming language, which resembles C and Java.
+ * A compiler, which reads a set of source files written in the
+TADS programming language and produces a portable binary game
+file.
+ * A library, which provides a set of generic adventure game
+definitions.
+ * An interactive debugger, which lets you examine
+your program's execution in order to find and fix programming
+errors.
+ * An interpreter, which a player uses to run your game.
+
+See http://www.plover.net/~textfire/raiffaq/ifaq/ for more
+information about obtaining game files.
+
+WWW: http://www.tads.org/
diff --git a/games/tads/pkg-plist b/games/tads/pkg-plist
new file mode 100644
index 000000000000..a958764b31c9
--- /dev/null
+++ b/games/tads/pkg-plist
@@ -0,0 +1,3 @@
+bin/tadsc
+bin/tadsr
+bin/tdb