aboutsummaryrefslogtreecommitdiff
path: root/games/taisei
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2019-11-17 14:50:03 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2019-11-17 14:50:03 +0000
commit170b16802f2ffcfc0e64bf45987004120edde142 (patch)
tree14d1b9a1d20ec768bb107a7c9e9c2f29aa50da7f /games/taisei
parent44fe96e43bf57785a9eb1eddbca7a30d2aa67086 (diff)
downloadports-170b16802f2ffcfc0e64bf45987004120edde142.tar.gz
ports-170b16802f2ffcfc0e64bf45987004120edde142.zip
Notes
Diffstat (limited to 'games/taisei')
-rw-r--r--games/taisei/Makefile11
-rw-r--r--games/taisei/distinfo6
-rw-r--r--games/taisei/files/patch-doc_meson.build24
-rw-r--r--games/taisei/files/patch-src_CMakeLists.txt28
-rw-r--r--games/taisei/pkg-plist3
5 files changed, 37 insertions, 35 deletions
diff --git a/games/taisei/Makefile b/games/taisei/Makefile
index 4256a57e3f64..f48b53e6edd3 100644
--- a/games/taisei/Makefile
+++ b/games/taisei/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= taisei
-PORTVERSION= 1.1.2
-PORTREVISION= 2
+PORTVERSION= 1.2
DISTVERSIONPREFIX= v
CATEGORIES= games
@@ -20,8 +19,9 @@ LIB_DEPENDS= libpng.so:graphics/png \
USE_GITHUB= yes
GH_ACCOUNT= ${PORTNAME}-project
-USES= cmake compiler:c11 pkgconfig sdl
-CMAKE_ARGS= -DTAISEI_VERSION_OVERRIDE=${PORTVERSION}
+USES= compiler:c11 desktop-file-utils meson pkgconfig python:3.6+,build sdl shebangfix shared-mime-info
+SHEBANG_FILES= scripts/*.py
+MESON_ARGS= -Dversion_fallback=${PORTVERSION} -Db_lto=false
USE_SDL= sdl2 ttf2 mixer2
PORTDOCS= *
@@ -29,6 +29,9 @@ PORTDATA= *
OPTIONS_DEFINE= DOCS
+DOCS_BUILD_DEPENDS=rst2html5.py:textproc/py-docutils
+DOCS_MESON_TRUE=docs
+
post-install:
@${RM} ${STAGEDIR}${DOCSDIR}/COPYING.txt
diff --git a/games/taisei/distinfo b/games/taisei/distinfo
index d7de31eaf76e..6efbbfc8ae32 100644
--- a/games/taisei/distinfo
+++ b/games/taisei/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1511265010
-SHA256 (taisei-project-taisei-v1.1.2_GH0.tar.gz) = 9b9ce2828a9c1fcc1de148e927c00b8bd541f891cae2df50552b9bba8f34122f
-SIZE (taisei-project-taisei-v1.1.2_GH0.tar.gz) = 36400214
+TIMESTAMP = 1517333579
+SHA256 (taisei-project-taisei-v1.2_GH0.tar.gz) = 8d2d682eeeb6284bc726b8ae52c355848b007957d2dc6bdd973f6384ae075ea3
+SIZE (taisei-project-taisei-v1.2_GH0.tar.gz) = 85562896
diff --git a/games/taisei/files/patch-doc_meson.build b/games/taisei/files/patch-doc_meson.build
new file mode 100644
index 000000000000..25316cb77390
--- /dev/null
+++ b/games/taisei/files/patch-doc_meson.build
@@ -0,0 +1,24 @@
+--- doc/meson.build.orig 2018-01-26 17:39:17 UTC
++++ doc/meson.build
+@@ -1,21 +1,7 @@
+
+ if get_option('docs')
+ rst2html5 = find_program(
+- 'rst2html5',
+ 'rst2html5.py',
+- 'rst2html5-docutils',
+- 'rst2html5-3',
+- 'rst2html5-3.py',
+- 'rst2html4',
+- 'rst2html4.py',
+- 'rst2html4-3',
+- 'rst2html4-3.py',
+- 'rst2html4-docutils',
+- 'rst2html',
+- 'rst2html.py',
+- 'rst2html-3',
+- 'rst2html-3.py',
+- 'rst2html-docutils',
+ required : false
+ )
+
diff --git a/games/taisei/files/patch-src_CMakeLists.txt b/games/taisei/files/patch-src_CMakeLists.txt
deleted file mode 100644
index 418602a71077..000000000000
--- a/games/taisei/files/patch-src_CMakeLists.txt
+++ /dev/null
@@ -1,28 +0,0 @@
---- src/CMakeLists.txt.orig 2017-11-20 04:24:23 UTC
-+++ src/CMakeLists.txt
-@@ -205,25 +205,10 @@ if(DEBUG_USE_ASAN AND DEFINED DEBUG_BUIL
- CHECK_AND_SET_FLAGS(COMPILER_SUPPORTS_ASAN "-fsanitize=address" DEBUG_FLAGS "-fsanitize=address")
- endif()
-
--if(RELEASE_USE_LTO)
-- set(RELEASE_FLAGS "${RELEASE_FLAGS} -flto")
--endif()
--
--set(CMAKE_C_FLAGS_DEBUG "${DEBUG_FLAGS} -DDEBUG")
--set(CMAKE_C_FLAGS_RELEASE "${RELEASE_FLAGS} -O3")
--set(CMAKE_C_FLAGS_RELWITHDEBINFO "${RELEASE_FLAGS} -O2")
--set(CMAKE_C_FLAGS_MINSIZEREL "${RELEASE_FLAGS} -Os")
--
- if(RELWITHDEBINFO_USE_DEBUG_FLAGS)
- set(CMAKE_C_FLAGS_RELWITHDEBINFO "${CMAKE_C_FLAGS_RELWITHDEBINFO} ${DEBUG_FLAGS}")
- endif()
-
--check_symbol_exists(backtrace "execinfo.h" HAVE_BACKTRACE)
--if(${HAVE_BACKTRACE})
-- set(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -DLOG_ENABLE_BACKTRACE")
-- set(CMAKE_C_FLAGS_RELWITHDEBINFO "${CMAKE_C_FLAGS_RELWITHDEBINFO} -DLOG_ENABLE_BACKTRACE")
--endif()
--
- set(WANT_WARNINGS
- "all"
- "pedantic"
diff --git a/games/taisei/pkg-plist b/games/taisei/pkg-plist
index 606dce8f97ce..fad367a0e6b4 100644
--- a/games/taisei/pkg-plist
+++ b/games/taisei/pkg-plist
@@ -1,3 +1,6 @@
bin/taisei
+share/applications/taisei-replay-viewer.desktop
share/applications/taisei.desktop
share/icons/hicolor/128x128/apps/taisei.png
+share/icons/hicolor/256x256/mimetypes/taisei-replay.png
+share/mime/packages/taisei.xml