aboutsummaryrefslogtreecommitdiff
path: root/games/taisei
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2019-11-19 20:56:17 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2019-11-19 20:56:17 +0000
commita83e80b02d65732fb544d83f1ecf99474f3c502d (patch)
treeba72cc83fc79aaaf794522d2d032ef2681168884 /games/taisei
parentd12aa8fe0cc152376d6410874355de546b6c4cd5 (diff)
downloadports-a83e80b02d65732fb544d83f1ecf99474f3c502d.tar.gz
ports-a83e80b02d65732fb544d83f1ecf99474f3c502d.zip
Notes
Diffstat (limited to 'games/taisei')
-rw-r--r--games/taisei/Makefile24
-rw-r--r--games/taisei/distinfo10
-rw-r--r--games/taisei/files/patch-doc_meson.build36
-rw-r--r--games/taisei/files/patch-src_meson.build10
4 files changed, 54 insertions, 26 deletions
diff --git a/games/taisei/Makefile b/games/taisei/Makefile
index f48b53e6edd3..ba6be1377ab9 100644
--- a/games/taisei/Makefile
+++ b/games/taisei/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= taisei
-PORTVERSION= 1.2
+PORTVERSION= 1.3.1
DISTVERSIONPREFIX= v
CATEGORIES= games
@@ -14,15 +14,24 @@ LICENSE_COMB= multi
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpng.so:graphics/png \
- libzip.so:archivers/libzip
+ libzip.so:archivers/libzip \
+ libwebp.so:graphics/webp \
+ libfreetype.so:print/freetype2 \
+ libopusfile.so:audio/opusfile
USE_GITHUB= yes
-GH_ACCOUNT= ${PORTNAME}-project
+GH_ACCOUNT= taisei-project
+GH_TUPLE= taisei-project:cglm:ee15b56:cglm/external/cglm \
+ taisei-project:SDL_GameControllerDB:5651071:gamecontrollerdb/external/gamecontrollerdb
-USES= compiler:c11 desktop-file-utils meson pkgconfig python:3.6+,build sdl shebangfix shared-mime-info
+USES= compiler:c11 desktop-file-utils meson pkgconfig \
+ python:3.6+,build sdl shebangfix shared-mime-info
SHEBANG_FILES= scripts/*.py
-MESON_ARGS= -Dversion_fallback=${PORTVERSION} -Db_lto=false
+MESON_ARGS= -Dversion_fallback=${PORTVERSION} -Db_lto=false -Duse_libcrypto=false
USE_SDL= sdl2 ttf2 mixer2
+USE_GCC= yes
+
+CPPFLAGS+= -D__BSD_VISIBLE
PORTDOCS= *
PORTDATA= *
@@ -35,4 +44,9 @@ DOCS_MESON_TRUE=docs
post-install:
@${RM} ${STAGEDIR}${DOCSDIR}/COPYING.txt
+post-patch:
+ @${REINPLACE_CMD} -e "/^dep_crypto/ s|.*|\
+ dep_crypto = declare_dependency(link_with:shared_library('${OPENSSLLIB}/libcrypto.so'), include_directories:include_directories('${OPENSSLINC}'))|" \
+ ${WRKSRC}/meson.build
+
.include <bsd.port.mk>
diff --git a/games/taisei/distinfo b/games/taisei/distinfo
index 6efbbfc8ae32..34ec834d3386 100644
--- a/games/taisei/distinfo
+++ b/games/taisei/distinfo
@@ -1,3 +1,7 @@
-TIMESTAMP = 1517333579
-SHA256 (taisei-project-taisei-v1.2_GH0.tar.gz) = 8d2d682eeeb6284bc726b8ae52c355848b007957d2dc6bdd973f6384ae075ea3
-SIZE (taisei-project-taisei-v1.2_GH0.tar.gz) = 85562896
+TIMESTAMP = 1574095481
+SHA256 (taisei-project-taisei-v1.3.1_GH0.tar.gz) = 6ea04bd56f5cffee91dbcebb08526e8743322d868dd9a077438718d5758ad233
+SIZE (taisei-project-taisei-v1.3.1_GH0.tar.gz) = 70811878
+SHA256 (taisei-project-cglm-ee15b56_GH0.tar.gz) = 5ec0a9574ec3621d563540a9c7ab9225dfed65173aad15668f0fb9e690e60aec
+SIZE (taisei-project-cglm-ee15b56_GH0.tar.gz) = 209318
+SHA256 (taisei-project-SDL_GameControllerDB-5651071_GH0.tar.gz) = 90c5493761116cd31b639dc175aae60c931a8c5f627d3465b04dad973c04d957
+SIZE (taisei-project-SDL_GameControllerDB-5651071_GH0.tar.gz) = 209047
diff --git a/games/taisei/files/patch-doc_meson.build b/games/taisei/files/patch-doc_meson.build
index 25316cb77390..608f29b0b5d8 100644
--- a/games/taisei/files/patch-doc_meson.build
+++ b/games/taisei/files/patch-doc_meson.build
@@ -1,24 +1,24 @@
---- doc/meson.build.orig 2018-01-26 17:39:17 UTC
+--- doc/meson.build.orig 2019-09-28 18:31:40 UTC
+++ doc/meson.build
-@@ -1,21 +1,7 @@
+@@ -1,20 +1,7 @@
- if get_option('docs')
+ if install_docs
+- rst2html_variants = []
+-
+- # This is *completely* ridiculous, but apparently this thing has THAT many faces.
+- basenames = ['rst2html5', 'rst2html', 'rst2html4']
+- suffixes = ['', '-3', '3', '-docutils']
+-
+- foreach basename : basenames
+- foreach suffix : suffixes
+- variant = '@0@@1@'.format(basename, suffix)
+- rst2html_variants += [variant, '@0@.py'.format(variant)]
+- endforeach
+- endforeach
+-
rst2html5 = find_program(
-- 'rst2html5',
- 'rst2html5.py',
-- 'rst2html5-docutils',
-- 'rst2html5-3',
-- 'rst2html5-3.py',
-- 'rst2html4',
-- 'rst2html4.py',
-- 'rst2html4-3',
-- 'rst2html4-3.py',
-- 'rst2html4-docutils',
-- 'rst2html',
-- 'rst2html.py',
-- 'rst2html-3',
-- 'rst2html-3.py',
-- 'rst2html-docutils',
+- rst2html_variants,
++ 'rst2html5.py',
required : false
)
diff --git a/games/taisei/files/patch-src_meson.build b/games/taisei/files/patch-src_meson.build
new file mode 100644
index 000000000000..2b85d0576a9a
--- /dev/null
+++ b/games/taisei/files/patch-src_meson.build
@@ -0,0 +1,10 @@
+--- src/meson.build.orig 2019-09-28 18:31:40 UTC
++++ src/meson.build
+@@ -325,7 +325,6 @@ else
+ taisei = executable(taisei_basename, taisei_src, version_deps,
+ dependencies : taisei_deps,
+ c_args : taisei_c_args,
+- c_pch : 'pch/taisei_pch.h',
+ gui_app : not get_option('win_console'),
+ install : true,
+ install_dir : bindir,