aboutsummaryrefslogtreecommitdiff
path: root/games/taisei
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-11-24 16:02:29 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-11-24 16:02:29 +0000
commitb90ac5538beeeda42f553fa36966e63a944340ff (patch)
tree781fc553fab51532dcb47848f041fd0b339091e8 /games/taisei
parent26253817ff1ef7c8e0db0589ece60dbd61f175ec (diff)
downloadports-b90ac5538beeeda42f553fa36966e63a944340ff.tar.gz
ports-b90ac5538beeeda42f553fa36966e63a944340ff.zip
Notes
Diffstat (limited to 'games/taisei')
-rw-r--r--games/taisei/Makefile34
-rw-r--r--games/taisei/distinfo3
-rw-r--r--games/taisei/files/patch-src_CMakeLists.txt28
-rw-r--r--games/taisei/pkg-descr8
-rw-r--r--games/taisei/pkg-plist3
5 files changed, 76 insertions, 0 deletions
diff --git a/games/taisei/Makefile b/games/taisei/Makefile
new file mode 100644
index 000000000000..3652e915fbda
--- /dev/null
+++ b/games/taisei/Makefile
@@ -0,0 +1,34 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= taisei
+PORTVERSION= 1.1.2
+DISTVERSIONPREFIX= v
+CATEGORIES= games
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Open source Touhou clone
+
+LICENSE= MIT CC0-1.0 PD
+LICENSE_COMB= multi
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libpng.so:graphics/png \
+ libzip.so:archivers/libzip
+
+USE_GITHUB= yes
+GH_ACCOUNT= ${PORTNAME}-project
+
+USES= cmake pkgconfig
+CMAKE_ARGS= -DTAISEI_VERSION_OVERRIDE=${PORTVERSION}
+USE_SDL= sdl2 ttf2 mixer2
+
+PORTDOCS= *
+PORTDATA= *
+
+OPTIONS_DEFINE= DOCS
+
+post-install:
+ @${RM} ${STAGEDIR}${DOCSDIR}/COPYING.txt
+
+.include <bsd.port.mk>
diff --git a/games/taisei/distinfo b/games/taisei/distinfo
new file mode 100644
index 000000000000..d7de31eaf76e
--- /dev/null
+++ b/games/taisei/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1511265010
+SHA256 (taisei-project-taisei-v1.1.2_GH0.tar.gz) = 9b9ce2828a9c1fcc1de148e927c00b8bd541f891cae2df50552b9bba8f34122f
+SIZE (taisei-project-taisei-v1.1.2_GH0.tar.gz) = 36400214
diff --git a/games/taisei/files/patch-src_CMakeLists.txt b/games/taisei/files/patch-src_CMakeLists.txt
new file mode 100644
index 000000000000..418602a71077
--- /dev/null
+++ b/games/taisei/files/patch-src_CMakeLists.txt
@@ -0,0 +1,28 @@
+--- src/CMakeLists.txt.orig 2017-11-20 04:24:23 UTC
++++ src/CMakeLists.txt
+@@ -205,25 +205,10 @@ if(DEBUG_USE_ASAN AND DEFINED DEBUG_BUIL
+ CHECK_AND_SET_FLAGS(COMPILER_SUPPORTS_ASAN "-fsanitize=address" DEBUG_FLAGS "-fsanitize=address")
+ endif()
+
+-if(RELEASE_USE_LTO)
+- set(RELEASE_FLAGS "${RELEASE_FLAGS} -flto")
+-endif()
+-
+-set(CMAKE_C_FLAGS_DEBUG "${DEBUG_FLAGS} -DDEBUG")
+-set(CMAKE_C_FLAGS_RELEASE "${RELEASE_FLAGS} -O3")
+-set(CMAKE_C_FLAGS_RELWITHDEBINFO "${RELEASE_FLAGS} -O2")
+-set(CMAKE_C_FLAGS_MINSIZEREL "${RELEASE_FLAGS} -Os")
+-
+ if(RELWITHDEBINFO_USE_DEBUG_FLAGS)
+ set(CMAKE_C_FLAGS_RELWITHDEBINFO "${CMAKE_C_FLAGS_RELWITHDEBINFO} ${DEBUG_FLAGS}")
+ endif()
+
+-check_symbol_exists(backtrace "execinfo.h" HAVE_BACKTRACE)
+-if(${HAVE_BACKTRACE})
+- set(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -DLOG_ENABLE_BACKTRACE")
+- set(CMAKE_C_FLAGS_RELWITHDEBINFO "${CMAKE_C_FLAGS_RELWITHDEBINFO} -DLOG_ENABLE_BACKTRACE")
+-endif()
+-
+ set(WANT_WARNINGS
+ "all"
+ "pedantic"
diff --git a/games/taisei/pkg-descr b/games/taisei/pkg-descr
new file mode 100644
index 000000000000..400003d4717c
--- /dev/null
+++ b/games/taisei/pkg-descr
@@ -0,0 +1,8 @@
+Taisei (lit. Occident) is a fan-made Open Source clone of the Touhou
+series, written in C using SDL/OpenGL.
+
+Basically, it is a shoot'em up game with lots of bullets (the genre
+is literally called bullet hell). The game is mostly done and very
+playable, so feel free to give it a try!
+
+WWW: https://taisei-project.org/
diff --git a/games/taisei/pkg-plist b/games/taisei/pkg-plist
new file mode 100644
index 000000000000..606dce8f97ce
--- /dev/null
+++ b/games/taisei/pkg-plist
@@ -0,0 +1,3 @@
+bin/taisei
+share/applications/taisei.desktop
+share/icons/hicolor/128x128/apps/taisei.png