aboutsummaryrefslogtreecommitdiff
path: root/games/tecnoballz
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-03-13 16:10:56 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-03-13 16:10:56 +0000
commit8f8213d50af7f5d8722e6e5f54c78baaeb2e2c2e (patch)
tree187c2a7858922caf11c0fae194e81e313632e1fd /games/tecnoballz
parentafecccb80dff3101a0e8410e87ec75d87336da4b (diff)
downloadports-8f8213d50af7f5d8722e6e5f54c78baaeb2e2c2e.tar.gz
ports-8f8213d50af7f5d8722e6e5f54c78baaeb2e2c2e.zip
Notes
Diffstat (limited to 'games/tecnoballz')
-rw-r--r--games/tecnoballz/Makefile7
-rw-r--r--games/tecnoballz/distinfo6
-rw-r--r--games/tecnoballz/files/patch-64bit144
-rw-r--r--games/tecnoballz/files/patch-sizeof34
-rw-r--r--games/tecnoballz/files/patch-src::Makefile25
-rw-r--r--games/tecnoballz/pkg-install10
-rw-r--r--games/tecnoballz/pkg-plist243
7 files changed, 142 insertions, 327 deletions
diff --git a/games/tecnoballz/Makefile b/games/tecnoballz/Makefile
index e8a5c7d16567..74f5065fb69b 100644
--- a/games/tecnoballz/Makefile
+++ b/games/tecnoballz/Makefile
@@ -6,19 +6,16 @@
#
PORTNAME= tecnoballz
-PORTVERSION= 0.91
-PORTREVISION= 1
+PORTVERSION= 0.92
CATEGORIES= games
MASTER_SITES= http://linux.tlk.fr/games/TecnoballZ/download/
EXTRACT_SUFX= .tgz
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= amdmi3@amdmi3.ru
COMMENT= A brick breaker (Arkanoid-like game)
LIB_DEPENDS= mikmod:${PORTSDIR}/audio/libmikmod
-BROKEN= Size mismatch
-
BUILD_WRKSRC= ${WRKSRC}/src
USE_X_PREFIX= yes
diff --git a/games/tecnoballz/distinfo b/games/tecnoballz/distinfo
index 913272c604e5..b0d7a57d7e9b 100644
--- a/games/tecnoballz/distinfo
+++ b/games/tecnoballz/distinfo
@@ -1,3 +1,3 @@
-MD5 (tecnoballz-0.91.tgz) = 6af1aea114f4d22d6c6d0e12babecddf
-SHA256 (tecnoballz-0.91.tgz) = 0a8fc519b37c3ecd1bf56c0fdb362384b8661bf63b370e10e47642fb04ef5622
-SIZE (tecnoballz-0.91.tgz) = 1833861
+MD5 (tecnoballz-0.92.tgz) = 111022212bc77b7dfcb453eaa5eac751
+SHA256 (tecnoballz-0.92.tgz) = 3ae9d084d7a65af52ef8657c2adbeda0a0747825f9b3b58b8352b7403d5b95b5
+SIZE (tecnoballz-0.92.tgz) = 2763879
diff --git a/games/tecnoballz/files/patch-64bit b/games/tecnoballz/files/patch-64bit
deleted file mode 100644
index 80f8ce93856a..000000000000
--- a/games/tecnoballz/files/patch-64bit
+++ /dev/null
@@ -1,144 +0,0 @@
-These changes are mostly (though not enirely) cosmetic --
-they ensure warning-free compilation on 64-bit platforms.
-
- -mi
-
---- src/audiomixer.cc 2005-03-01 09:15:08.000000000 -0500
-+++ src/audiomixer.cc 2007-07-27 01:38:09.000000000 -0400
-@@ -350,5 +350,5 @@
- return (erreur_num = E_SDLMIXER);
- }
-- Sint32 *p = (Sint32 *)pMixmodule;
-+ intptr_t *p = (intptr_t *)pMixmodule;
- ptModAmiga = (MODULE *)p[1];
-
---- src/fond_ecran.cc 2005-03-01 09:15:08.000000000 -0500
-+++ src/fond_ecran.cc 2007-07-27 01:39:22.000000000 -0400
-@@ -134,6 +134,6 @@
- //###############################################################
- Sint32 src_X = 0;
-- Sint32 h = (Sint32)ecran; //use pointer address as random value
-- Sint32 k = (Sint32)fonds; //use pointer address as random value
-+ Sint32 h = (intptr_t)ecran; //use pointer address as random value
-+ Sint32 k = (intptr_t)fonds; //use pointer address as random value
- Sint32 nline;
- if(mVert > 0)
---- src/mentatCode.cc 2005-03-01 09:15:08.000000000 -0500
-+++ src/mentatCode.cc 2007-07-27 01:42:19.000000000 -0400
-@@ -86,5 +86,5 @@
- if(is_verbose)
- printf("mentatCode::first_init() [START]\n");
-- hasard_val = (Sint32)first_init;
-+ hasard_val = (intptr_t)first_init;
- memGestion = new RAM_killer();
- memGestion->initialise(8000);
-@@ -337,14 +337,14 @@
- delete ptScoreTab;
- if(is_verbose)
-- printf("==7 ecran_gere %x\n", (Sint32)ecran_gere);
-+ printf("==7 ecran_gere %p\n", ecran_gere);
- delete ecran_gere;
- #ifndef SOUNDISOFF
- if(is_verbose)
-- printf("==8 audiomixer %x\n", (Sint32)ptAudiomix);
-+ printf("==8 audiomixer %p\n", ptAudiomix);
- delete ptAudiomix;
- #endif
- delete pRessource;
- if(is_verbose)
-- printf("==9 memGestion %x \n", (Sint32)memGestion);
-+ printf("==9 memGestion %p\n", memGestion);
- delete memGestion;
- return num_erreur;
---- src/scrolledit.cc 2005-03-01 09:15:08.000000000 -0500
-+++ src/scrolledit.cc 2007-07-27 01:43:05.000000000 -0400
-@@ -657,5 +657,5 @@
- table += (brush_posx / defilement->motiflarge);
-
-- printf("scrolledit::brush_draw() : (table - carteFirst):%i / i:%i\n",
-+ printf("scrolledit::brush_draw() : (table - carteFirst):%ti / i:%i\n",
- (table - defilement->carteFirst), i);
-
---- src/tecno_boui.cc 2005-03-01 09:15:08.000000000 -0500
-+++ src/tecno_boui.cc 2007-07-27 01:44:19.000000000 -0400
-@@ -64,5 +64,5 @@
- { flag_actif = 1;
- Sint32 *monPT = ghost_bobs + (hasard_val & 31);
-- hasard_val += (Sint32)this;
-+ hasard_val += (intptr_t)this;
- Sint32 k = *monPT;
- miniOffset = k;
-@@ -191,5 +191,5 @@
- i &= 31;
- atom_traje = i;
-- hasard_val += (Sint32)this;
-+ hasard_val += (intptr_t)this;
-
-
---- src/zeNewBalls.cc 2005-03-01 09:15:08.000000000 -0500
-+++ src/zeNewBalls.cc 2007-07-27 01:45:35.000000000 -0400
-@@ -629,6 +629,6 @@
- //(char *)monPT += j;
- monPT = (Sint32 *)((char *)monPT + j);
-- printf("monPT = %x / bumpX->rebonds_GD = %x / *monPT = %i\n",
-- (Sint32)monPT, (Sint32)bumpX->rebonds_GD, *monPT);
-+ printf("monPT = %p / bumpX->rebonds_GD = %p / *monPT = %i\n",
-+ monPT, bumpX->rebonds_GD, *monPT);
-
- printf("%i %i\n", bumpX->rebonds_GD[16], bumpX->rebonds_GD[64]);
---- src/ze_magneye.cc 2005-03-01 09:15:08.000000000 -0500
-+++ src/ze_magneye.cc 2007-07-27 01:46:11.000000000 -0400
-@@ -70,5 +70,5 @@
- { techno_eye *ptEye = objetListe[i];
- ptEye->centerPosx = Xcoordinat[hval & 31] * resolution;
-- hval += (Sint32)ptEye;
-+ hval += (intptr_t)ptEye;
- ptEye->centerPosy = Ycoordinat[hval & 31] * resolution;
- hval += keyGestion->sourisGetY();
---- src/RAM_killer.cc 2005-03-01 09:15:08.000000000 -0500
-+++ src/RAM_killer.cc 2007-07-27 08:24:00.000000000 -0400
-@@ -78,8 +78,5 @@
- {
- place *= double_mem;
-- char *memPt = NULL;
-- char nulle = 0;
-- char *monPT;
-- Sint32 i ;
-+ char *memPt;
-
- if(mem_nombre == memMaximum)
-@@ -87,5 +84,5 @@
- return 0;
- }
-- memPt = (char *) malloc((Sint32)place);
-+ memPt = (char *) calloc(place, 1);
- if(!memPt)
- { erreur_num = E_NOMEMORY; //allocate error
-@@ -102,7 +99,4 @@
- if(mem_nombre > maxi_zones)
- maxi_zones = mem_nombre;
-- monPT = memPt;
-- for(i = 0; i < place; i++)
-- *(monPT++) = nulle; //clear memory
- //printf("RAM_killer::reserveMem(%i, %x)\n", place, ident);
- return memPt;
-@@ -140,6 +134,6 @@
- if(adres)
- { adrNoFound++;
-- fprintf(stderr, "RAM_killer::liberation() : %i) address %x not found\n",
-- adrNoFound, (Sint32)adres);
-+ fprintf(stderr, "RAM_killer::liberation() : %i) address %p not found\n",
-+ adrNoFound, adres);
- }
- }
-@@ -156,7 +150,7 @@
- if(adres)
- { fprintf(stderr,
-- "RAM_killer::libereTout() : addr:%x; size:%i; id:%x\n",
-- (Sint32)memPT->adresseMem, memPT->taille_mem,
-- (Sint32)memPT->identifier);
-+ "RAM_killer::libereTout() : addr:%p; size:%i; id:%p\n",
-+ memPT->adresseMem, memPT->taille_mem,
-+ memPT->identifier);
- free(adres); //release memory
- octetTotal -= memPT->taille_mem;
diff --git a/games/tecnoballz/files/patch-sizeof b/games/tecnoballz/files/patch-sizeof
deleted file mode 100644
index e09e824c4669..000000000000
--- a/games/tecnoballz/files/patch-sizeof
+++ /dev/null
@@ -1,34 +0,0 @@
-This patch allows the program to run on platforms, where
-pointers are wider than 32-bit...
-
- -mi
-
---- src/BOB_killer.cc 2005-03-01 09:15:08.000000000 -0500
-+++ src/BOB_killer.cc 2007-07-27 13:49:30.000000000 -0400
-@@ -271,10 +271,10 @@
-
- // tables of offsets and counters (words and bytes)
-- BOBtableP1 = (Sint16 **)(memGestion->reserveMem(sizeof(Sint32) * animationN, 0x424F4250));
-+ BOBtableP1 = (Sint16 **)(memGestion->reserveMem(sizeof(*BOBtableP1) * animationN, 0x424F4250));
- error_init(memGestion->retour_err());
- if(erreur_num) return erreur_num;
-
- // tables of data (pixels of the sprite)
-- BOBtableP2 = (char **)(memGestion->reserveMem(sizeof(Sint32) * animationN, 0x424F4250));
-+ BOBtableP2 = (char **)(memGestion->reserveMem(sizeof(*BOBtableP2) * animationN, 0x424F4250));
- error_init(memGestion->retour_err());
- if(erreur_num) return erreur_num;
-@@ -282,5 +282,5 @@
- // tables of offsets and counters (byte peer byte)
- if(fTableByte)
-- { BOBtableP3 = (Sint16 **)(memGestion->reserveMem(sizeof(Sint32) * animationN, 0x424F4250));
-+ { BOBtableP3 = (Sint16 **)(memGestion->reserveMem(sizeof(*BOBtableP3) * animationN, 0x424F4250));
- error_init(memGestion->retour_err());
- if(erreur_num) return erreur_num;
-@@ -358,5 +358,5 @@
- //###################################################################
- adresseTAB = (char **)
-- (memGestion->reserveMem(sizeof(Sint32) * animationN, 0x424F4250));
-+ (memGestion->reserveMem(sizeof(*adresseTAB) * animationN, 0x424F4250));
- error_init(memGestion->retour_err());
- if(erreur_num) return erreur_num;
diff --git a/games/tecnoballz/files/patch-src::Makefile b/games/tecnoballz/files/patch-src::Makefile
deleted file mode 100644
index f2eb024e04ec..000000000000
--- a/games/tecnoballz/files/patch-src::Makefile
+++ /dev/null
@@ -1,25 +0,0 @@
---- src/Makefile.orig Wed Jan 19 23:37:51 2005
-+++ src/Makefile Thu Jan 20 00:17:11 2005
-@@ -1,10 +1,9 @@
- CC = gcc
--CXX = g++
- #CXXFLAGS = -O3 -Wall -s
--CXXFLAGS = -O3 -Wall
-+CXXFLAGS += -Wall `$(SDL_CONFIG) --cflags` `$(LIBMIKMOD_CONFIG) --cflags`
- PROG = tecnoballz
- PREFIX = /usr/local
--LIBPATH = -L/usr/X11R6/lib -L.
-+LIBPATH = `$(SDL_CONFIG) --libs` -lSDL_mixer `$(LIBMIKMOD_CONFIG) --libs`
- TMPDIR = /var/tmp/tecnoballz.dist
- ifeq ($(PREFIX),)
- EXEDIR = $(HOME)/bin
-@@ -94,8 +93,7 @@
-
-
- $(PROG): $(OBJ)
-- $(CXX) $(LIBPATH) $(OBJ) $(PROFLAG) -lm \
-- -lSDL -lSDL_mixer -lmikmod -o $@
-+ $(CXX) $(LIBPATH) $(OBJ) $(PROFLAG) -o $@
-
- clean:
- rm -f $(OBJ) nomfichierscore.o
diff --git a/games/tecnoballz/pkg-install b/games/tecnoballz/pkg-install
index c8de25f28eae..189842e9f74d 100644
--- a/games/tecnoballz/pkg-install
+++ b/games/tecnoballz/pkg-install
@@ -1,11 +1,13 @@
#!/bin/sh
-SCOREDIR="/var/games"
-SCOREFILE="/var/games/tecnoballz.hi"
+SCOREDIR="/var/games/tecnoballs"
+SCOREFILE="/var/games/tecnoballz/tecnoballz.hi"
[ "$2" != "POST-INSTALL" -o -f "$SCOREFILE" ] && exit 0
+echo "Creating hiscore directory..."
mkdir -p $SCOREDIR
touch $SCOREFILE
-chown root:games $SCOREFILE
-chmod 664 $SCOREFILE
+
+chgrp -R games $SCOREDIR
+chmod g+w $SCOREFILE
diff --git a/games/tecnoballz/pkg-plist b/games/tecnoballz/pkg-plist
index 353ce85b7b27..b5f7f4354b4b 100644
--- a/games/tecnoballz/pkg-plist
+++ b/games/tecnoballz/pkg-plist
@@ -1,47 +1,49 @@
bin/tecnoballz
%%DATADIR%%/cosinus128.list
-%%DATADIR%%/edmap01.data
-%%DATADIR%%/edmap02.data
-%%DATADIR%%/edmap03.data
%%DATADIR%%/gard_lissa.list
-%%DATADIR%%/hires/ani_head.bmp
-%%DATADIR%%/hires/ba_score2.bmp
-%%DATADIR%%/hires/bumper_1.bmp
-%%DATADIR%%/hires/bumper_2.bmp
-%%DATADIR%%/hires/font_messa.bmp
-%%DATADIR%%/hires/font_score.bmp
-%%DATADIR%%/hires/fontgame.bmp
-%%DATADIR%%/hires/fontmenu.bmp
-%%DATADIR%%/hires/gigablzt.bmp
-%%DATADIR%%/hires/map_edit.bmp
-%%DATADIR%%/hires/new_shop.bmp
-%%DATADIR%%/hires/pagezbob.bmp
-%%DATADIR%%/hires/zebricks.bmp
-%%DATADIR%%/lores/ani_head.bmp
-%%DATADIR%%/lores/ba_score2.bmp
-%%DATADIR%%/lores/bumper_1.bmp
-%%DATADIR%%/lores/bumper_2.bmp
-%%DATADIR%%/lores/font_messa.bmp
-%%DATADIR%%/lores/font_score.bmp
-%%DATADIR%%/lores/fontgame.bmp
-%%DATADIR%%/lores/fontmenu.bmp
-%%DATADIR%%/lores/gigablzt.bmp
-%%DATADIR%%/lores/map_edit.bmp
-%%DATADIR%%/lores/new_shop.bmp
-%%DATADIR%%/lores/pagezbob.bmp
-%%DATADIR%%/lores/zebricks.bmp
-%%DATADIR%%/min60map.bmp
+%%DATADIR%%/hires/all_sprites.png
+%%DATADIR%%/hires/bricks.png
+%%DATADIR%%/hires/font_score.png
+%%DATADIR%%/hires/game_fonts.png
+%%DATADIR%%/hires/gigablitz.png
+%%DATADIR%%/hires/head_animation.png
+%%DATADIR%%/hires/menu_fonts.png
+%%DATADIR%%/hires/paddles_1.png
+%%DATADIR%%/hires/paddles_2.png
+%%DATADIR%%/hires/right_panel.png
+%%DATADIR%%/hires/shop.png
+%%DATADIR%%/hires/small_fonts.png
+%%DATADIR%%/hires/tilesmap.png
+%%DATADIR%%/levels-data.xml
+%%DATADIR%%/lores/all_sprites.png
+%%DATADIR%%/lores/bricks.png
+%%DATADIR%%/lores/font_score.png
+%%DATADIR%%/lores/game_fonts.png
+%%DATADIR%%/lores/gigablitz.png
+%%DATADIR%%/lores/head_animation.png
+%%DATADIR%%/lores/menu_fonts.png
+%%DATADIR%%/lores/paddles_1.png
+%%DATADIR%%/lores/paddles_2.png
+%%DATADIR%%/lores/right_panel.png
+%%DATADIR%%/lores/shop.png
+%%DATADIR%%/lores/small_fonts.png
+%%DATADIR%%/lores/tilesmap.png
+%%DATADIR%%/min60map.png
%%DATADIR%%/musics/area1-game.mod
%%DATADIR%%/musics/area1-game2.mod
%%DATADIR%%/musics/area2-game.mod
%%DATADIR%%/musics/area3-game.mod
%%DATADIR%%/musics/area4-game.mod
%%DATADIR%%/musics/area5-game.mod
+%%DATADIR%%/musics/fridge-in-space_from_reg-zbb.mod
%%DATADIR%%/musics/gardien-go.mod
%%DATADIR%%/musics/high-score.mod
+%%DATADIR%%/musics/in-game-music-1_reg.mod
+%%DATADIR%%/musics/mon-lapin_reg-zbb.mod
%%DATADIR%%/musics/over-theme.mod
%%DATADIR%%/musics/tecno-winn.mod
%%DATADIR%%/musics/tecnoballz.mod
+%%DATADIR%%/musics/termigator_reg-zbb.mod
%%DATADIR%%/sounds/ralarm.wav
%%DATADIR%%/sounds/rappar.wav
%%DATADIR%%/sounds/raspire.wav
@@ -70,87 +72,104 @@ bin/tecnoballz
%%DATADIR%%/sounds/rtir_rak.wav
%%DATADIR%%/sounds/rtransfo.wav
%%DATADIR%%/tableau.data
-%%DATADIR%%/textures/map01.bmp
-%%DATADIR%%/textures/map02.bmp
-%%DATADIR%%/textures/map03.bmp
-%%DATADIR%%/textures/map04.bmp
-%%DATADIR%%/textures/map05.bmp
-%%DATADIR%%/textures/map06.bmp
-%%DATADIR%%/textures/map07.bmp
-%%DATADIR%%/textures/map08.bmp
-%%DATADIR%%/textures/map09.bmp
-%%DATADIR%%/textures/map10.bmp
-%%DATADIR%%/textures/map11.bmp
-%%DATADIR%%/textures/map12.bmp
-%%DATADIR%%/textures/map13.bmp
-%%DATADIR%%/textures/map14.bmp
-%%DATADIR%%/textures/map15.bmp
-%%DATADIR%%/textures/map16.bmp
-%%DATADIR%%/textures/map17.bmp
-%%DATADIR%%/textures/map18.bmp
-%%DATADIR%%/textures/map19.bmp
-%%DATADIR%%/textures/map20.bmp
-%%DATADIR%%/textures/map21.bmp
-%%DATADIR%%/textures/map22.bmp
-%%DATADIR%%/textures/map23.bmp
-%%DATADIR%%/textures/map24.bmp
-%%DATADIR%%/textures/map25.bmp
-%%DATADIR%%/textures/map26.bmp
-%%DATADIR%%/textures/map27.bmp
-%%DATADIR%%/textures/map28.bmp
-%%DATADIR%%/textures/map29.bmp
-%%DATADIR%%/textures/map30.bmp
-%%DATADIR%%/textures/map31.bmp
-%%DATADIR%%/textures/map32.bmp
-%%DATADIR%%/textures/map33.bmp
-%%DATADIR%%/textures/map34.bmp
-%%DATADIR%%/textures/map35.bmp
-%%DATADIR%%/textures/map36.bmp
-%%DATADIR%%/textures/map37.bmp
-%%DATADIR%%/textures/map38.bmp
-%%DATADIR%%/textures/map39.bmp
-%%DATADIR%%/textures/map40.bmp
-%%DATADIR%%/textures/map41.bmp
-%%DATADIR%%/textures/map42.bmp
-%%DATADIR%%/textures/map43.bmp
-%%DATADIR%%/textures/map44.bmp
-%%DATADIR%%/textures/map45.bmp
-%%DATADIR%%/textures/map46.bmp
-%%DATADIR%%/textures/map47.bmp
-%%DATADIR%%/textures/map48.bmp
-%%DATADIR%%/textures/map49.bmp
-%%DATADIR%%/textures/map50.bmp
-%%DATADIR%%/textures/map51.bmp
-%%DATADIR%%/textures/map52.bmp
-%%DATADIR%%/textures/map53.bmp
-%%DATADIR%%/textures/map54.bmp
-%%DATADIR%%/textures/map55.bmp
-%%DATADIR%%/textures/map56.bmp
-%%DATADIR%%/textures/map57.bmp
-%%DATADIR%%/textures/map58.bmp
-%%DATADIR%%/textures/map59.bmp
-%%DATADIR%%/textures/map60.bmp
-%%DATADIR%%/textures/map61.bmp
-%%DATADIR%%/textures/map62.bmp
-%%DATADIR%%/textures/map63.bmp
-%%DATADIR%%/textures/map64.bmp
-%%DATADIR%%/textures/map65.bmp
-%%DATADIR%%/textures/map66.bmp
-%%DATADIR%%/textures/map67.bmp
-%%DATADIR%%/textures/map68.bmp
-%%DATADIR%%/textures/map69.bmp
-%%DATADIR%%/textures/map70.bmp
-%%DATADIR%%/textures/map71.bmp
-%%DATADIR%%/textures/map72.bmp
-%%DATADIR%%/textures/map73.bmp
-%%DATADIR%%/textures/map74.bmp
-%%DATADIR%%/textures/map75.bmp
-%%DATADIR%%/textures/map76.bmp
-%%DATADIR%%/textures/map77.bmp
-%%DATADIR%%/textures/map78.bmp
-@dirrm %%DATADIR%%/hires
-@dirrm %%DATADIR%%/lores
-@dirrm %%DATADIR%%/musics
-@dirrm %%DATADIR%%/sounds
+%%DATADIR%%/texts/main_menu_en.txt
+%%DATADIR%%/texts/main_menu_fr.txt
+%%DATADIR%%/texts/popup_menu_en.txt
+%%DATADIR%%/texts/popup_menu_fr.txt
+%%DATADIR%%/texts/scrolltext_en.txt
+%%DATADIR%%/texts/scrolltext_fr.txt
+%%DATADIR%%/texts/shop_en.txt
+%%DATADIR%%/texts/shop_fr.txt
+%%DATADIR%%/texts/short_info_messages_en.txt
+%%DATADIR%%/texts/short_info_messages_fr.txt
+%%DATADIR%%/textures/map01.png
+%%DATADIR%%/textures/map02.png
+%%DATADIR%%/textures/map03.png
+%%DATADIR%%/textures/map04.png
+%%DATADIR%%/textures/map05.png
+%%DATADIR%%/textures/map06.png
+%%DATADIR%%/textures/map07.png
+%%DATADIR%%/textures/map08.png
+%%DATADIR%%/textures/map09.png
+%%DATADIR%%/textures/map10.png
+%%DATADIR%%/textures/map11.png
+%%DATADIR%%/textures/map12.png
+%%DATADIR%%/textures/map13.png
+%%DATADIR%%/textures/map14.png
+%%DATADIR%%/textures/map15.png
+%%DATADIR%%/textures/map16.png
+%%DATADIR%%/textures/map17.png
+%%DATADIR%%/textures/map18.png
+%%DATADIR%%/textures/map19.png
+%%DATADIR%%/textures/map20.png
+%%DATADIR%%/textures/map21.png
+%%DATADIR%%/textures/map22.png
+%%DATADIR%%/textures/map23.png
+%%DATADIR%%/textures/map24.png
+%%DATADIR%%/textures/map25.png
+%%DATADIR%%/textures/map26.png
+%%DATADIR%%/textures/map27.png
+%%DATADIR%%/textures/map28.png
+%%DATADIR%%/textures/map29.png
+%%DATADIR%%/textures/map30.png
+%%DATADIR%%/textures/map31.png
+%%DATADIR%%/textures/map32.png
+%%DATADIR%%/textures/map33.png
+%%DATADIR%%/textures/map34.png
+%%DATADIR%%/textures/map35.png
+%%DATADIR%%/textures/map36.png
+%%DATADIR%%/textures/map37.png
+%%DATADIR%%/textures/map38.png
+%%DATADIR%%/textures/map39.png
+%%DATADIR%%/textures/map40.png
+%%DATADIR%%/textures/map41.png
+%%DATADIR%%/textures/map42.png
+%%DATADIR%%/textures/map43.png
+%%DATADIR%%/textures/map44.png
+%%DATADIR%%/textures/map45.png
+%%DATADIR%%/textures/map46.png
+%%DATADIR%%/textures/map47.png
+%%DATADIR%%/textures/map48.png
+%%DATADIR%%/textures/map49.png
+%%DATADIR%%/textures/map50.png
+%%DATADIR%%/textures/map51.png
+%%DATADIR%%/textures/map52.png
+%%DATADIR%%/textures/map53.png
+%%DATADIR%%/textures/map54.png
+%%DATADIR%%/textures/map55.png
+%%DATADIR%%/textures/map56.png
+%%DATADIR%%/textures/map57.png
+%%DATADIR%%/textures/map58.png
+%%DATADIR%%/textures/map59.png
+%%DATADIR%%/textures/map60.png
+%%DATADIR%%/textures/map61.png
+%%DATADIR%%/textures/map62.png
+%%DATADIR%%/textures/map63.png
+%%DATADIR%%/textures/map64.png
+%%DATADIR%%/textures/map65.png
+%%DATADIR%%/textures/map66.png
+%%DATADIR%%/textures/map67.png
+%%DATADIR%%/textures/map68.png
+%%DATADIR%%/textures/map69.png
+%%DATADIR%%/textures/map70.png
+%%DATADIR%%/textures/map71.png
+%%DATADIR%%/textures/map72.png
+%%DATADIR%%/textures/map73.png
+%%DATADIR%%/textures/map74.png
+%%DATADIR%%/textures/map75.png
+%%DATADIR%%/textures/map76.png
+%%DATADIR%%/textures/map77.png
+%%DATADIR%%/textures/map78.png
+%%DATADIR%%/tilemap-congratulation_20.data
+%%DATADIR%%/tilemap-congratulation_40.data
+%%DATADIR%%/tilemap-guardians_20.data
+%%DATADIR%%/tilemap-guardians_40.data
+%%DATADIR%%/tilemap-menu_20.data
+%%DATADIR%%/tilemap-menu_40.data
@dirrm %%DATADIR%%/textures
+@dirrm %%DATADIR%%/texts
+@dirrm %%DATADIR%%/sounds
+@dirrm %%DATADIR%%/musics
+@dirrm %%DATADIR%%/lores
+@dirrm %%DATADIR%%/hires
@dirrm %%DATADIR%%