aboutsummaryrefslogtreecommitdiff
path: root/games/tenebrae/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-11-17 11:50:32 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-11-17 11:50:32 +0000
commitcd71f9a949789413606cc00b5e2e2b8773d3ceaa (patch)
treecfcbad3ef21c9af5ec539ebff7dd03a3a1696f06 /games/tenebrae/Makefile
parent2bb0d3f519fdf6d903d27adeac9a0a8176a34df1 (diff)
downloadports-cd71f9a949789413606cc00b5e2e2b8773d3ceaa.tar.gz
ports-cd71f9a949789413606cc00b5e2e2b8773d3ceaa.zip
Notes
Diffstat (limited to 'games/tenebrae/Makefile')
-rw-r--r--games/tenebrae/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/games/tenebrae/Makefile b/games/tenebrae/Makefile
index 6569f164e8fe..4eb4896fe767 100644
--- a/games/tenebrae/Makefile
+++ b/games/tenebrae/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tenebrae
PORTVERSION= 1.04
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://tenebrae.sourceforge.net/downloads/
DISTFILES= ${PORTNAME}_src${EXTRACT_SUFX} \
@@ -18,9 +19,9 @@ COMMENT= Quake 1 source port with advanced graphics
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
USE_ZIP= yes
+USE_REINPLACE= yes
USE_GMAKE= yes
USE_GL= yes
-USE_XLIB= yes
USE_SDL= yes
USE_REINPLACE= yes
ONLY_FOR_ARCHS= i386
@@ -31,6 +32,8 @@ MAKE_ENV= DATADIR="${DATADIR}" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
SDL_CONFIG="${SDL_CONFIG}"
+.include "${.CURDIR}/../quake-data/Makefile.include"
+
pre-patch:
@${REINPLACE_CMD} -e "s|$$(${PRINTF} '\r')||g" `${FIND} ${WRKSRC} -type f`
@@ -50,6 +53,6 @@ do-install:
.endif
post-install:
- @${SED} -e 's|%%DATADIR%%|${DATADIR}|' <${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>