aboutsummaryrefslogtreecommitdiff
path: root/games/tenebrae
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 16:35:45 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 16:35:45 +0000
commit3a283e24f296371e9b753c09e3e62a92ef3d8703 (patch)
tree88e0a2bbddafb5c9bdc18e8e02c5e59fb9f9d471 /games/tenebrae
parent7a0a8929bea1c510b4f30261d294a78b556b49d7 (diff)
downloadports-3a283e24f296371e9b753c09e3e62a92ef3d8703.tar.gz
ports-3a283e24f296371e9b753c09e3e62a92ef3d8703.zip
Convert to new options framework
Notes
Notes: svn path=/head/; revision=299119
Diffstat (limited to 'games/tenebrae')
-rw-r--r--games/tenebrae/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/games/tenebrae/Makefile b/games/tenebrae/Makefile
index a548a6a3c500..412ada7bc998 100644
--- a/games/tenebrae/Makefile
+++ b/games/tenebrae/Makefile
@@ -25,16 +25,18 @@ USE_XORG= xxf86dga
USE_GL= gl
USE_SDL= yes
-OPTIONS= X86_ASM "Enable use of x86 assembly code" on
+OPTIONS_DEFINE= X86_ASM DOCS
+OPTIONS_DEFAULT= X86_ASM
+X86_ASM_DESC= Enable use of x86 assembly code
WRKSRC= ${WRKDIR}/${PORTNAME}_0
BUILD_WRKSRC= ${WRKSRC}/linux
MAKEFILE= Makefile.i386linux
MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}"
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_X86_ASM)
+.if ${PORT_OPTIONS:MX86_ASM}
MAKE_ENV+= USE_ASM=1
.endif
@@ -50,7 +52,7 @@ do-install:
${PREFIX}/bin
@${MKDIR} ${Q1DIR}/${PORTNAME}
${INSTALL_DATA} ${WRKDIR}/${PORTNAME}/Pak0.pak ${Q1DIR}/${PORTNAME}
-.ifndef (NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${TR} -d '\r' <${WRKDIR}/Tenebrae_Readme.txt \
>${DOCSDIR}/Tenebrae_Readme.txt
@@ -63,4 +65,4 @@ post-install:
.include "${.CURDIR}/../quake-data/Makefile.include"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>