aboutsummaryrefslogtreecommitdiff
path: root/games/tenebrae
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2020-09-30 11:33:22 +0000
committerStefan Eßer <se@FreeBSD.org>2020-09-30 11:33:22 +0000
commita563c59fb314096a8fef522b8342ff391c83a777 (patch)
tree80b9000e921a5b9cfd3de7fb484cb3a53793c247 /games/tenebrae
parent06042cec26c36727683ee891ff2e04d457773e80 (diff)
downloadports-a563c59fb314096a8fef522b8342ff391c83a777.tar.gz
ports-a563c59fb314096a8fef522b8342ff391c83a777.zip
Notes
Diffstat (limited to 'games/tenebrae')
-rw-r--r--games/tenebrae/Makefile9
-rw-r--r--games/tenebrae/files/patch-cd_linux.c28
-rw-r--r--games/tenebrae/files/patch-common.c6
-rw-r--r--games/tenebrae/files/patch-common.h6
-rw-r--r--games/tenebrae/files/patch-gl_common.c6
-rw-r--r--games/tenebrae/files/patch-gl_vidlinuxglx.c8
-rw-r--r--games/tenebrae/files/patch-glquake.h26
-rw-r--r--games/tenebrae/files/patch-linux__Makefile.i386linux23
-rw-r--r--games/tenebrae/files/patch-net.h6
-rw-r--r--games/tenebrae/files/patch-quakeasm.h6
-rw-r--r--games/tenebrae/files/patch-quakedef.h6
-rw-r--r--games/tenebrae/files/patch-snd_sdl.c8
-rw-r--r--games/tenebrae/files/patch-sys_dosa.s6
-rw-r--r--games/tenebrae/files/patch-sys_linux.c6
-rw-r--r--games/tenebrae/files/patch-sys_uxfindfirst.c6
15 files changed, 85 insertions, 71 deletions
diff --git a/games/tenebrae/Makefile b/games/tenebrae/Makefile
index c549adc22b19..ce85397dd8ab 100644
--- a/games/tenebrae/Makefile
+++ b/games/tenebrae/Makefile
@@ -3,7 +3,7 @@
PORTNAME= tenebrae
PORTVERSION= 1.04
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= games
MASTER_SITES= http://tenebrae.sourceforge.net/downloads/
DISTFILES= ${PORTNAME}_src${EXTRACT_SUFX} \
@@ -12,6 +12,8 @@ DISTFILES= ${PORTNAME}_src${EXTRACT_SUFX} \
MAINTAINER= ports@FreeBSD.org
COMMENT= Quake engine with lighting similar to that in Doom III
+LICENSE= GPLv2+
+
LIB_DEPENDS= libpng.so:graphics/png
USES= gl gmake dos2unix sdl xorg zip
@@ -19,11 +21,12 @@ USE_GL= gl glu
USE_SDL= sdl
USE_XORG= x11 xext xxf86vm xxf86dga
-WRKSRC= ${WRKDIR}/${PORTNAME}_0
-BUILD_WRKSRC= ${WRKSRC}/linux
MAKEFILE= Makefile.i386linux
MAKE_ENV= PTHREAD_LIBS="-lpthread"
+BUILD_WRKSRC= ${WRKSRC}/linux
+WRKSRC= ${WRKDIR}/${PORTNAME}_0
+
OPTIONS_DEFINE= DOCS
OPTIONS_DEFINE_amd64= ASM
OPTIONS_DEFAULT_amd64= ASM
diff --git a/games/tenebrae/files/patch-cd_linux.c b/games/tenebrae/files/patch-cd_linux.c
index ac2d85b32dbb..faa7ed643042 100644
--- a/games/tenebrae/files/patch-cd_linux.c
+++ b/games/tenebrae/files/patch-cd_linux.c
@@ -1,6 +1,6 @@
---- ./cd_linux.c.orig Sat Jun 10 12:08:13 2006
-+++ ./cd_linux.c Sat Jun 10 12:08:13 2006
-@@ -31,7 +31,7 @@
+--- cd_linux.c.orig 2020-09-30 11:25:10 UTC
++++ cd_linux.c
+@@ -31,7 +31,7 @@ Foundation, Inc., 59 Temple Place - Suite 330, Boston,
#include <time.h>
#include <errno.h>
@@ -9,7 +9,7 @@
#include "quakedef.h"
-@@ -54,8 +54,8 @@
+@@ -54,8 +54,8 @@ static void CDAudio_Eject(void)
if (cdfile == -1 || !enabled)
return; // no cd init'd
@@ -20,7 +20,7 @@
}
-@@ -64,30 +64,30 @@
+@@ -64,30 +64,30 @@ static void CDAudio_CloseDoor(void)
if (cdfile == -1 || !enabled)
return; // no cd init'd
@@ -58,7 +58,7 @@
return 0;
}
-@@ -95,8 +95,8 @@
+@@ -95,8 +95,8 @@ static int CDAudio_GetAudioDiskInfo(void)
void CDAudio_Play(byte track, qboolean looping)
{
@@ -69,7 +69,7 @@
if (cdfile == -1 || !enabled)
return;
-@@ -115,7 +115,7 @@
+@@ -115,7 +115,7 @@ void CDAudio_Play(byte track, qboolean looping)
Con_DPrintf("CDAudio: Bad track number %u.\n", track);
return;
}
@@ -78,7 +78,7 @@
// don't try to play a non-audio track
entry.cdte_track = track;
entry.cdte_format = CDROM_MSF;
-@@ -129,7 +129,7 @@
+@@ -129,7 +129,7 @@ void CDAudio_Play(byte track, qboolean looping)
Con_Printf("CDAudio: track %i is not audio\n", track);
return;
}
@@ -87,7 +87,7 @@
if (playing)
{
if (playTrack == track)
-@@ -137,19 +137,19 @@
+@@ -137,19 +137,19 @@ void CDAudio_Play(byte track, qboolean looping)
CDAudio_Stop();
}
@@ -116,7 +116,7 @@
playLooping = looping;
playTrack = track;
-@@ -168,8 +168,8 @@
+@@ -168,8 +168,8 @@ void CDAudio_Stop(void)
if (!playing)
return;
@@ -127,7 +127,7 @@
wasPlaying = false;
playing = false;
-@@ -183,8 +183,8 @@
+@@ -183,8 +183,8 @@ void CDAudio_Pause(void)
if (!playing)
return;
@@ -138,7 +138,7 @@
wasPlaying = playing;
playing = false;
-@@ -202,8 +202,8 @@
+@@ -202,8 +202,8 @@ void CDAudio_Resume(void)
if (!wasPlaying)
return;
@@ -149,7 +149,7 @@
playing = true;
}
-@@ -327,7 +327,8 @@
+@@ -327,7 +327,8 @@ static void CD_f (void)
void CDAudio_Update(void)
{
@@ -159,7 +159,7 @@
static time_t lastchk;
if (!enabled)
-@@ -351,14 +352,17 @@
+@@ -351,14 +352,17 @@ void CDAudio_Update(void)
if (playing && lastchk < time(NULL)) {
lastchk = time(NULL) + 2; //two seconds between chks
diff --git a/games/tenebrae/files/patch-common.c b/games/tenebrae/files/patch-common.c
index facc89061cb8..a34a5602017a 100644
--- a/games/tenebrae/files/patch-common.c
+++ b/games/tenebrae/files/patch-common.c
@@ -1,6 +1,6 @@
---- ./common.c.orig Sat Jun 10 12:08:13 2006
-+++ ./common.c Sat Jun 10 12:08:13 2006
-@@ -2221,7 +2221,10 @@
+--- common.c.orig 2020-09-30 11:25:10 UTC
++++ common.c
+@@ -2221,7 +2221,10 @@ void COM_InitFilesystem (void)
if ((userdir[j-1] == '\\') || (userdir[j-1] == '/'))
userdir[j-1] = 0;
}
diff --git a/games/tenebrae/files/patch-common.h b/games/tenebrae/files/patch-common.h
index 71db3b3f11d7..c44ccbcce4af 100644
--- a/games/tenebrae/files/patch-common.h
+++ b/games/tenebrae/files/patch-common.h
@@ -1,6 +1,6 @@
---- ./common.h.orig Sat Jun 10 12:08:13 2006
-+++ ./common.h Sat Jun 10 12:08:13 2006
-@@ -169,6 +169,10 @@
+--- common.h.orig 2020-09-30 11:25:10 UTC
++++ common.h
+@@ -169,6 +169,10 @@ struct cache_user_s;
extern char com_gamedir[MAX_OSPATH];
diff --git a/games/tenebrae/files/patch-gl_common.c b/games/tenebrae/files/patch-gl_common.c
index 6b594dd712af..366e4559ab65 100644
--- a/games/tenebrae/files/patch-gl_common.c
+++ b/games/tenebrae/files/patch-gl_common.c
@@ -1,6 +1,6 @@
---- ./gl_common.c.orig Sat Jun 10 12:08:13 2006
-+++ ./gl_common.c Sat Jun 10 12:08:13 2006
-@@ -248,11 +248,11 @@
+--- gl_common.c.orig 2020-09-30 11:25:10 UTC
++++ gl_common.c
+@@ -248,11 +248,11 @@ void CheckDiffuseBumpMappingExtensions(void)
if (!strstr(gl_extensions, "GL_ARB_texture_env_dot3")) {
Sys_Error ("ARB_texture_env_dot3 not found.\nProbably your 3d-card is not supported.\n");
}
diff --git a/games/tenebrae/files/patch-gl_vidlinuxglx.c b/games/tenebrae/files/patch-gl_vidlinuxglx.c
index f98a7cbefac9..16ad14869cd6 100644
--- a/games/tenebrae/files/patch-gl_vidlinuxglx.c
+++ b/games/tenebrae/files/patch-gl_vidlinuxglx.c
@@ -1,6 +1,6 @@
---- ./gl_vidlinuxglx.c.orig Sat Jun 10 12:08:13 2006
-+++ ./gl_vidlinuxglx.c Sat Jun 10 12:08:13 2006
-@@ -20,7 +20,6 @@
+--- gl_vidlinuxglx.c.orig 2020-09-30 11:25:10 UTC
++++ gl_vidlinuxglx.c
+@@ -20,7 +20,6 @@ Foundation, Inc., 59 Temple Place - Suite 330, Boston,
#include <termios.h>
#include <sys/ioctl.h>
#include <sys/stat.h>
@@ -8,7 +8,7 @@
#include <stdarg.h>
#include <stdio.h>
#include <signal.h>
-@@ -339,8 +338,6 @@
+@@ -339,8 +338,6 @@ static void HandleEvents(void)
{
mx += ((int)event.xmotion.x - mwx) * 2;
my += ((int)event.xmotion.y - mwy) * 2;
diff --git a/games/tenebrae/files/patch-glquake.h b/games/tenebrae/files/patch-glquake.h
index d081bebb63e8..51e4a758d9e7 100644
--- a/games/tenebrae/files/patch-glquake.h
+++ b/games/tenebrae/files/patch-glquake.h
@@ -1,6 +1,6 @@
---- ./glquake.h.orig Sat Jun 10 12:08:13 2006
-+++ ./glquake.h Sat Jun 10 12:08:13 2006
-@@ -419,8 +419,8 @@
+--- glquake.h.orig 2020-09-30 11:25:10 UTC
++++ glquake.h
+@@ -419,8 +419,8 @@ extern const char *gl_extensions;
void R_TranslatePlayerSkin (int playernum);
void GL_Bind (int texnum);
@@ -11,7 +11,7 @@
#endif
#if !defined (__APPLE__) && !defined (MACOSX)
-@@ -470,6 +470,9 @@
+@@ -470,6 +470,9 @@ void GL_Bind (int texnum);
// ARB_texture_compression defines
#define GL_COMPRESSED_RGBA_ARB 0x84EE
@@ -21,7 +21,7 @@
#define GL_STENCIL_BACK_FUNC_ATI 0x8800
#define GL_STENCIL_BACK_FAIL_ATI 0x8801
#define GL_STENCIL_BACK_PASS_DEPTH_FAIL_ATI 0x8802
-@@ -478,6 +481,8 @@
+@@ -478,6 +481,8 @@ void GL_Bind (int texnum);
typedef void (APIENTRY *PFNGLSTENCILOPSEPARATEATIPROC)(GLenum face, GLenum sfail, GLenum dpfail, GLenum dppass);
typedef void (APIENTRY *PFNGLSTENCILFUNCSEPARATEATIPROC)(GLenum frontfunc, GLenum backfunc, GLint ref, GLuint mask);
@@ -30,7 +30,7 @@
extern PFNGLSTENCILOPSEPARATEATIPROC qglStencilOpSeparateATI;
extern PFNGLSTENCILFUNCSEPARATEATIPROC qglStencilFuncSeparateATI;
-@@ -1134,8 +1139,13 @@
+@@ -1134,9 +1139,14 @@ extern PFNGLVERTEXATTRIBS4UBVNVPROC qglVertexAttribs4u
// <AWE> There are some diffs with the function parameters. wgl stuff not present with MacOS X. -DC- and SDL
#if defined (__APPLE__) || defined (MACOSX) || defined(SDL) || defined (__glx__)
@@ -39,8 +39,18 @@
+
typedef void (APIENTRY * PFNGLFLUSHVERTEXARRAYRANGEAPPLEPROC) (GLsizei length, const GLvoid *pointer);
typedef void (APIENTRY * PFNGLVERTEXARRAYRANGEAPPLEPROC) (GLsizei size, const GLvoid *pointer);
-+
-+#endif
++#endif
++
extern PFNGLFLUSHVERTEXARRAYRANGEAPPLEPROC qglFlushVertexArrayRangeAPPLE;
extern PFNGLVERTEXARRAYRANGEAPPLEPROC qglVertexArrayRangeAPPLE;
+
+@@ -1524,7 +1534,7 @@ extern mirrorplane_t mirrorplanes[NUM_MIRROR_PLANES];
+ extern int mirror_contents;
+ extern int newenvmap;
+
+-msurface_t *causticschain;
++extern msurface_t *causticschain;
+ extern int caustics_textures[8];
+ extern qboolean busy_caustics;
+
diff --git a/games/tenebrae/files/patch-linux__Makefile.i386linux b/games/tenebrae/files/patch-linux__Makefile.i386linux
index 9e038de53580..76b1dc491e06 100644
--- a/games/tenebrae/files/patch-linux__Makefile.i386linux
+++ b/games/tenebrae/files/patch-linux__Makefile.i386linux
@@ -1,6 +1,6 @@
---- ./linux/Makefile.i386linux.orig Sat Jun 10 12:08:13 2006
-+++ ./linux/Makefile.i386linux Sat Jun 10 12:12:17 2006
-@@ -18,56 +18,60 @@
+--- linux/Makefile.i386linux.orig 2020-09-30 11:25:10 UTC
++++ linux/Makefile.i386linux
+@@ -18,57 +18,61 @@ NOARCH=noarch
MOUNT_DIR = ../
@@ -54,11 +54,11 @@
-TARGETS=$(BUILDDIR)/bin/tenebrae.run
+TARGETS=$(BUILDDIR)/bin/tenebrae
-+
+
+all: build_release
+
+targets: $(TARGETS)
-
++
build_debug:
@-mkdir -p $(BUILD_DEBUG_DIR) \
$(BUILD_DEBUG_DIR)/bin \
@@ -71,15 +71,16 @@
$(BUILD_RELEASE_DIR)/bin \
$(BUILD_RELEASE_DIR)/glquake
- $(MAKE) targets BUILDDIR=$(BUILD_RELEASE_DIR) CFLAGS="$(RELEASE_CFLAGS)"
--
++ $(MAKE) targets BUILDDIR=$(BUILD_RELEASE_DIR) CFLAGS+="$(RELEASE_CFLAGS)"
+
-all: build_debug build_release
-
-targets: $(TARGETS)
-+ $(MAKE) targets BUILDDIR=$(BUILD_RELEASE_DIR) CFLAGS+="$(RELEASE_CFLAGS)"
-
+-
#############################################################################
# GLQuake
-@@ -143,7 +147,7 @@
+ #############################################################################
+@@ -143,7 +147,7 @@ GLQUAKE_OBJS= \
$(BUILDDIR)/glquake/snd_dma.o \
$(BUILDDIR)/glquake/snd_mem.o \
$(BUILDDIR)/glquake/snd_mix.o \
@@ -88,7 +89,7 @@
$(BUILDDIR)/glquake/gl_vidlinuxglx.o \
$(BUILDDIR)/glquake/math.o \
$(BUILDDIR)/glquake/worlda.o \
-@@ -154,7 +158,7 @@
+@@ -154,7 +158,7 @@ GLQUAKE_OBJS= \
$(BUILDDIR)/glquake/te_scripts.o
@@ -97,7 +98,7 @@
$(CC) $(CFLAGS) -o $@ $(GLQUAKE_OBJS) $(LDFLAGS)
$(BUILDDIR)/glquake/cl_demo.o : $(MOUNT_DIR)/cl_demo.c
-@@ -361,7 +365,7 @@
+@@ -361,7 +365,7 @@ $(BUILDDIR)/glquake/snd_mem.o : $(MOUNT_DIR)/snd_
$(BUILDDIR)/glquake/snd_mix.o : $(MOUNT_DIR)/snd_mix.c
$(DO_GL_CC)
diff --git a/games/tenebrae/files/patch-net.h b/games/tenebrae/files/patch-net.h
index 55290a9d1fff..5d6989dc667b 100644
--- a/games/tenebrae/files/patch-net.h
+++ b/games/tenebrae/files/patch-net.h
@@ -1,6 +1,6 @@
---- ./net.h.orig Sat Jun 10 12:08:13 2006
-+++ ./net.h Sat Jun 10 12:08:13 2006
-@@ -239,7 +239,7 @@
+--- net.h.orig 2020-09-30 11:25:10 UTC
++++ net.h
+@@ -239,7 +239,7 @@ typedef struct
extern int hostCacheCount;
extern hostcache_t hostcache[HOSTCACHESIZE];
diff --git a/games/tenebrae/files/patch-quakeasm.h b/games/tenebrae/files/patch-quakeasm.h
index f3bdf43f3b24..b86482a3a733 100644
--- a/games/tenebrae/files/patch-quakeasm.h
+++ b/games/tenebrae/files/patch-quakeasm.h
@@ -1,6 +1,6 @@
---- ./quakeasm.h.orig Sat Jun 10 12:08:13 2006
-+++ ./quakeasm.h Sat Jun 10 12:08:13 2006
-@@ -31,7 +31,7 @@
+--- quakeasm.h.orig 2020-09-30 11:25:10 UTC
++++ quakeasm.h
+@@ -31,7 +31,7 @@ Foundation, Inc., 59 Temple Place - Suite 330, Boston,
#endif
diff --git a/games/tenebrae/files/patch-quakedef.h b/games/tenebrae/files/patch-quakedef.h
index 63e957213790..82ebf9f65875 100644
--- a/games/tenebrae/files/patch-quakedef.h
+++ b/games/tenebrae/files/patch-quakedef.h
@@ -1,6 +1,6 @@
---- ./quakedef.h.orig Sat Jun 10 12:08:13 2006
-+++ ./quakedef.h Sat Jun 10 12:08:13 2006
-@@ -74,11 +74,6 @@
+--- quakedef.h.orig 2020-09-30 11:25:10 UTC
++++ quakedef.h
+@@ -74,11 +74,6 @@ void VID_UnlockBuffer (void);
#endif
diff --git a/games/tenebrae/files/patch-snd_sdl.c b/games/tenebrae/files/patch-snd_sdl.c
index 454dd5ce2969..9432a86613b7 100644
--- a/games/tenebrae/files/patch-snd_sdl.c
+++ b/games/tenebrae/files/patch-snd_sdl.c
@@ -1,6 +1,6 @@
---- ./snd_sdl.c.orig Sat Jun 10 12:08:13 2006
-+++ ./snd_sdl.c Sat Jun 10 12:08:13 2006
-@@ -94,7 +94,7 @@
+--- snd_sdl.c.orig 2020-09-30 11:25:10 UTC
++++ snd_sdl.c
+@@ -94,7 +94,7 @@ qboolean SNDDMA_Init(void)
shm = &the_shm;
shm->splitbuffer = 0;
shm->samplebits = (obtained.format & 0xFF);
@@ -9,7 +9,7 @@
shm->channels = obtained.channels;
shm->samples = obtained.samples*shm->channels;
shm->samplepos = 0;
-@@ -119,3 +119,12 @@
+@@ -119,3 +119,12 @@ void SNDDMA_Shutdown(void)
}
}
diff --git a/games/tenebrae/files/patch-sys_dosa.s b/games/tenebrae/files/patch-sys_dosa.s
index e22d80c2012e..223d9c0a4db1 100644
--- a/games/tenebrae/files/patch-sys_dosa.s
+++ b/games/tenebrae/files/patch-sys_dosa.s
@@ -1,5 +1,5 @@
---- ./sys_dosa.s.orig Sat Jun 10 12:08:13 2006
-+++ ./sys_dosa.s Sat Jun 10 12:08:13 2006
+--- sys_dosa.s.orig 2020-09-30 11:25:10 UTC
++++ sys_dosa.s
@@ -5,6 +5,7 @@
#include "asm_i386.h"
#include "quakeasm.h"
@@ -8,7 +8,7 @@
.data
-@@ -93,3 +94,4 @@
+@@ -93,3 +94,4 @@ C(Sys_SetFPCW):
ret
diff --git a/games/tenebrae/files/patch-sys_linux.c b/games/tenebrae/files/patch-sys_linux.c
index 5bf74ff89970..9cbaf735fb32 100644
--- a/games/tenebrae/files/patch-sys_linux.c
+++ b/games/tenebrae/files/patch-sys_linux.c
@@ -1,6 +1,6 @@
---- ./sys_linux.c.orig Sat Jun 10 12:08:13 2006
-+++ ./sys_linux.c Sat Jun 10 12:08:13 2006
-@@ -27,7 +27,7 @@
+--- sys_linux.c.orig 2020-09-30 11:25:10 UTC
++++ sys_linux.c
+@@ -27,7 +27,7 @@ int nostdout = 0;
// user preference directory
#if defined (USERPREF_DIR)
diff --git a/games/tenebrae/files/patch-sys_uxfindfirst.c b/games/tenebrae/files/patch-sys_uxfindfirst.c
index 0241db267614..8add50d7a8b3 100644
--- a/games/tenebrae/files/patch-sys_uxfindfirst.c
+++ b/games/tenebrae/files/patch-sys_uxfindfirst.c
@@ -1,6 +1,6 @@
---- ./sys_uxfindfirst.c.orig Sat Jun 10 12:08:13 2006
-+++ ./sys_uxfindfirst.c Sat Jun 10 12:08:13 2006
-@@ -36,7 +36,7 @@
+--- sys_uxfindfirst.c.orig 2020-09-30 11:25:10 UTC
++++ sys_uxfindfirst.c
+@@ -36,7 +36,7 @@ Foundation, Inc., 59 Temple Place - Suite 330, Boston,
#include "quakedef.h"
#include <errno.h>