aboutsummaryrefslogtreecommitdiff
path: root/games/textmaze
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2013-05-07 08:42:29 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2013-05-07 08:42:29 +0000
commit6f4bb5f8df6606c43015dc2ce97bb21167008d30 (patch)
tree8a88caff05c37366ca99d8d7a8bf0e00aedaf6ce /games/textmaze
parent2da5963202030cf2a29037a6ab159c904c31e550 (diff)
downloadports-6f4bb5f8df6606c43015dc2ce97bb21167008d30.tar.gz
ports-6f4bb5f8df6606c43015dc2ce97bb21167008d30.zip
Convert to use shebangfix USES flag.
Notes
Notes: svn path=/head/; revision=317587
Diffstat (limited to 'games/textmaze')
-rw-r--r--games/textmaze/Makefile13
1 files changed, 3 insertions, 10 deletions
diff --git a/games/textmaze/Makefile b/games/textmaze/Makefile
index f5dd5c80920d..646a56ffe442 100644
--- a/games/textmaze/Makefile
+++ b/games/textmaze/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# New ports collection makefile for: textmaze
-# Date created: Sep 8, 2001
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= textmaze
PORTVERSION= 1.2
@@ -18,17 +13,15 @@ COMMENT= Generates mazes on a text terminal and lets you traverse them
RUN_DEPENDS= p5-Curses>=0:${PORTSDIR}/devel/p5-Curses
+USES= shebangfix
USE_PERL5= yes
NO_BUILD= yes
+SHEBANG_FILES= textmaze
PLIST_FILES= bin/textmaze
WRKSRC= ${WRKDIR}/TextMaze
-post-patch:
- @${REINPLACE_CMD} -e 's|/usr/local/bin/perl|${PERL}|' \
- ${WRKSRC}/${PORTNAME}
-
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin