aboutsummaryrefslogtreecommitdiff
path: root/games/tomatoes
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-08-19 20:23:15 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-08-19 20:23:15 +0000
commit9e305a5abe9e0cc4aca2b90d9a8a39cea03f8dd1 (patch)
treeb54b66c6e2d515db0b0b6fc4eb608b60e4a5f3d1 /games/tomatoes
parent743ac0ebedca812893181e2f4ec3d5209c0311e0 (diff)
downloadports-9e305a5abe9e0cc4aca2b90d9a8a39cea03f8dd1.tar.gz
ports-9e305a5abe9e0cc4aca2b90d9a8a39cea03f8dd1.zip
Add desktop entry
Approved by: amdmi3 (maintainer via jabber)
Notes
Notes: svn path=/head/; revision=259590
Diffstat (limited to 'games/tomatoes')
-rw-r--r--games/tomatoes/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/games/tomatoes/Makefile b/games/tomatoes/Makefile
index 7815a7a1503d..d9bd34c76d1e 100644
--- a/games/tomatoes/Makefile
+++ b/games/tomatoes/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tomatoes
PORTVERSION= 1.5
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= games
MASTER_SITES= SF
DISTFILES= ${PORTNAME}-linux-src-${PORTVERSION}5${EXTRACT_SUFX} \
@@ -35,7 +35,8 @@ MAKE_ARGS= CC="${CXX}" \
PLIST_FILES= bin/tomatoes \
%%DATADIR%%/config.cfg \
%%DATADIR%%/music/IHaveNoTomatoes.it \
- %%DATADIR%%/tomatoes.mpk
+ %%DATADIR%%/tomatoes.mpk \
+ %%DATADIR%%/icon.png
PLIST_DIRS= %%DATADIR%%/music \
%%DATADIR%%
@@ -43,6 +44,13 @@ SDL_CFLAGS= `${SDL_CONFIG} --cflags` -I${LOCALBASE}/include
SDL_LDFLAGS= `${SDL_CONFIG} --libs` -lSDL_image -lSDL_mixer \
-L${LOCALBASE}/lib -lGL -lGLU
+DESKTOP_ENTRIES= "Tomatoes" \
+ "I Have No Tomatoes" \
+ "${DATADIR}/icon.png" \
+ "tomatoes" \
+ "Game;ArcadeGame;" \
+ false
+
.include <bsd.port.pre.mk>
post-patch:
@@ -56,6 +64,7 @@ do-install:
${MKDIR} ${DATADIR}/music
${INSTALL_DATA} ${TDATA}/config.cfg ${DATADIR}
${INSTALL_DATA} ${TDATA}/tomatoes.mpk ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/icon.png ${DATADIR}
${INSTALL_DATA} ${TDATA}/music/IHaveNoTomatoes.it ${DATADIR}/music
.include <bsd.port.post.mk>