aboutsummaryrefslogtreecommitdiff
path: root/games/torcs/Makefile
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2013-07-17 00:09:16 +0000
committerRene Ladan <rene@FreeBSD.org>2013-07-17 00:09:16 +0000
commitb463af324c12921f91674302b38adcf1c9bc631e (patch)
tree7f16465f2a1dc739d378ac84930af7bee99aa6b6 /games/torcs/Makefile
parentd7599bf7a5556450738cb46408ea9fe839732c6e (diff)
downloadports-b463af324c12921f91674302b38adcf1c9bc631e.tar.gz
ports-b463af324c12921f91674302b38adcf1c9bc631e.zip
Notes
Diffstat (limited to 'games/torcs/Makefile')
-rw-r--r--games/torcs/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/games/torcs/Makefile b/games/torcs/Makefile
index cbd855ca719d..052c56c2a7be 100644
--- a/games/torcs/Makefile
+++ b/games/torcs/Makefile
@@ -44,6 +44,8 @@ INSTDIR= ${PREFIX}/share/games/${PORTNAME}
PORTDOCS= faq.html
+BASH2FIX= src/linux/torcs.in Make-default.mk
+
DESKTOP_ENTRIES= "TORCS" \
"The Open Racing Car Simulator" \
"${INSTDIR}/Ticon.png" \
@@ -57,6 +59,13 @@ OPTIONS_DEFINE= DOCS
EMPTYDIR= champ dtmrace endrace ncrace practice quickrace
+# shebangfix does not catch these two (not at top of file):
+post-patch:
+.for FILE in ${BASH2FIX}
+ @${REINPLACE_CMD} -E -e "s|/bin/bash|${LOCALBASE}/bin/bash|" \
+ ${WRKSRC}/${FILE}
+.endfor
+
pre-install:
@${MKDIR} ${PREFIX}/share/games