aboutsummaryrefslogtreecommitdiff
path: root/games/torcs/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2008-12-31 15:02:03 +0000
committerThierry Thomas <thierry@FreeBSD.org>2008-12-31 15:02:03 +0000
commitfdd6beb59f533c529aab9c259a81c8c9b72e7eeb (patch)
tree7ac09fe7a373ed26ec0579cc3e148a7be51058e1 /games/torcs/Makefile
parent5d4936352fc7d9874cb6d25a23fa8f3f8dbf0961 (diff)
downloadports-fdd6beb59f533c529aab9c259a81c8c9b72e7eeb.tar.gz
ports-fdd6beb59f533c529aab9c259a81c8c9b72e7eeb.zip
Notes
Diffstat (limited to 'games/torcs/Makefile')
-rw-r--r--games/torcs/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/games/torcs/Makefile b/games/torcs/Makefile
index 9952b6ef403f..69cc3be7d1ed 100644
--- a/games/torcs/Makefile
+++ b/games/torcs/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= torcs
-DISTVERSION= 1.3.0
-PORTREVISION= 4
+DISTVERSION= 1.3.1
CATEGORIES= games
MASTER_SITES= SF
@@ -55,12 +54,14 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include -DHAVE_DE
LIBS="${PTHREAD_LIBS}" LDFLAGS="${LDFLAGS}"
.endif
-.if !defined(WITHOUT_FREEGLUT)
+.if defined(WITH_FREEGLUT)
LIB_DEPENDS+= glut.11:${PORTSDIR}/graphics/freeglut
.else
USE_GL= yes
.endif
+EMPTYDIR= champ dtmrace endrace ncrace practice quickrace
+
post-patch:
.for FILE in ${BASH2FIX}
@${REINPLACE_CMD} -E -e "s|/bin/bash|${LOCALBASE}/bin/bash|" \
@@ -75,5 +76,8 @@ post-install:
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/doc/faq/|} ${DOCSDIR}
.endif
+.for ed in ${EMPTYDIR}
+ ${TOUCH} ${INSTDIR}/results/${ed}/.keep_me
+.endfor
.include <bsd.port.post.mk>