aboutsummaryrefslogtreecommitdiff
path: root/games/torrent
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-11-17 15:45:12 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-11-17 15:45:12 +0000
commitee44393910b33c33df7f34dbc14a325b799f703b (patch)
tree67d1c55f81f1a4aab17d8159e552d4dbbe345665 /games/torrent
parent2d5cc3a0fd74299d49381d905a91d97ff1705b88 (diff)
downloadports-ee44393910b33c33df7f34dbc14a325b799f703b.tar.gz
ports-ee44393910b33c33df7f34dbc14a325b799f703b.zip
Notes
Diffstat (limited to 'games/torrent')
-rw-r--r--games/torrent/Makefile35
-rw-r--r--games/torrent/distinfo3
-rw-r--r--games/torrent/files/patch-src-sound.c17
-rw-r--r--games/torrent/files/patch-src-torrent.c48
-rw-r--r--games/torrent/pkg-descr7
-rw-r--r--games/torrent/pkg-plist32
6 files changed, 142 insertions, 0 deletions
diff --git a/games/torrent/Makefile b/games/torrent/Makefile
new file mode 100644
index 000000000000..8d494bb8b97d
--- /dev/null
+++ b/games/torrent/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: torrent
+# Date created: 10 Nov 2005
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= torrent
+PORTVERSION= 0.8.2
+CATEGORIES= games
+MASTER_SITES= http://www.shiftygames.com/torrent/
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= Score points without letting the tiles touch the top of the board
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+USE_SDL= sdl mixer image ttf
+
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= LDFLAGS="`${SDL_CONFIG} --libs`" \
+ CPPFLAGS="`${SDL_CONFIG} --cflags`" \
+ SDL_CONFIG="${SDL_CONFIG}"
+
+MAN6= torrent.6
+
+post-extract:
+ @${FIND} -E ${WRKDIR} -type f -iregex ".*\.(c|cpp|h|txt)" -print0 | \
+ ${XARGS} -0 ${REINPLACE_CMD} -e 's/[[:cntrl:]]*$$//'
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|SDL/|SDL11/|g; s|-std=gnu99 ||g' ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/games/torrent/distinfo b/games/torrent/distinfo
new file mode 100644
index 000000000000..32e5a82cb697
--- /dev/null
+++ b/games/torrent/distinfo
@@ -0,0 +1,3 @@
+MD5 (torrent-0.8.2.tar.gz) = ae295ac6ed6c3df42bca9423d99e065d
+SHA256 (torrent-0.8.2.tar.gz) = 93890ed9287061f6b8d63993962c188013388fe7cf4d3d334ca7e72cc3209a67
+SIZE (torrent-0.8.2.tar.gz) = 555686
diff --git a/games/torrent/files/patch-src-sound.c b/games/torrent/files/patch-src-sound.c
new file mode 100644
index 000000000000..7f2edaa64125
--- /dev/null
+++ b/games/torrent/files/patch-src-sound.c
@@ -0,0 +1,17 @@
+--- src/sound.c.orig Wed Mar 3 04:03:54 2004
++++ src/sound.c Thu Nov 10 05:29:19 2005
+@@ -46,12 +46,13 @@
+ Mix_Chunk * loadSound(const char * name)
+ {
+ Mix_Chunk * temp;
++ char * newname;
+ int len1 = strlen(sg_data_path), len2 = strlen(name);
+
+ if(disabled)
+ return NULL;
+
+- char * newname = (char*)malloc(len1 + len2 + 1);
++ newname = (char*)malloc(len1 + len2 + 1);
+ if(newname == NULL) {
+ fprintf(stderr, "Out of memory!\n");
+ exit(1);
diff --git a/games/torrent/files/patch-src-torrent.c b/games/torrent/files/patch-src-torrent.c
new file mode 100644
index 000000000000..50a778b7f668
--- /dev/null
+++ b/games/torrent/files/patch-src-torrent.c
@@ -0,0 +1,48 @@
+--- src/torrent.c.orig Thu Nov 17 16:18:29 2005
++++ src/torrent.c Thu Nov 17 16:19:26 2005
+@@ -328,6 +328,8 @@
+ int x, y;
+
+ if(++level > LEVELSIZE) {
++ int y;
++
+ level--; //to keep from showing -1 on board
+ playSound(levelOverSound);
+ stateChanged = 1;
+@@ -340,10 +342,11 @@
+
+
+ // Count number of empty layers and remaining blocks
+- for(int y = 0; y < yBSize; y++) {
++ for(y = 0; y < yBSize; y++) {
++ int x;
+ int start = remaining;
+
+- for(int x = 0; x < xBSize; x++) {
++ for(x = 0; x < xBSize; x++) {
+ if(board[y][x])
+ remaining++;
+ }
+@@ -693,10 +696,10 @@
+ {
+ static char odd = 0;
+ if((scoreAdd || scoreTexts) && !drawing) {
++ struct scoreText * t = scoreTexts;
+ odd = !odd;
+ drawing = 1;
+ /* draw the text scores */
+- struct scoreText * t = scoreTexts;
+ while(t && odd) {
+ SE_Redraw();
+ drawing = 0;
+@@ -857,9 +860,9 @@
+ ****************************************************/
+ int clickBomb(enum Color color, enum Color bombColor)
+ {
++ int c = 0, x, y;
+ playSound(bombClickSound);
+ isBomb = 1;
+- int c = 0, x, y;
+ for(y = 0; y < yBSize; y++) {
+ for(x = 0; x < xBSize; x++) {
+ if(board[y][x] && (board[y][x]->color == color ||
diff --git a/games/torrent/pkg-descr b/games/torrent/pkg-descr
new file mode 100644
index 000000000000..114262edbc1f
--- /dev/null
+++ b/games/torrent/pkg-descr
@@ -0,0 +1,7 @@
+You must keep the tiles from piling up to the top of the board or
+they will crash down on you. But be warned they keep coming and
+they come faster each time. Click on groups of three or more to
+remove tiles. Additional "helper" tiles are given occasionally to
+assist and some times hinder in the removal of tiles.
+
+WWW: http://www.shiftygames.com/torrent/torrent.html
diff --git a/games/torrent/pkg-plist b/games/torrent/pkg-plist
new file mode 100644
index 000000000000..ea6bc5f96ff7
--- /dev/null
+++ b/games/torrent/pkg-plist
@@ -0,0 +1,32 @@
+bin/torrent
+%%DATADIR%%/fonts/amerdreams.ttf
+%%DATADIR%%/pics/help.png
+%%DATADIR%%/pics/main.png
+%%DATADIR%%/pics/set1/blank.png
+%%DATADIR%%/pics/set1/blue.png
+%%DATADIR%%/pics/set1/blue_bomb.png
+%%DATADIR%%/pics/set1/gold.png
+%%DATADIR%%/pics/set1/gold_bomb.png
+%%DATADIR%%/pics/set1/green.png
+%%DATADIR%%/pics/set1/green_bomb.png
+%%DATADIR%%/pics/set1/purple.png
+%%DATADIR%%/pics/set1/purple_bomb.png
+%%DATADIR%%/pics/set1/red.png
+%%DATADIR%%/pics/set1/red_bomb.png
+%%DATADIR%%/pics/sg_icon.png
+%%DATADIR%%/pics/shiftygames.png
+%%DATADIR%%/pics/sound_high.png
+%%DATADIR%%/pics/sound_low.png
+%%DATADIR%%/pics/sound_medium.png
+%%DATADIR%%/sounds/bomb.ogg
+%%DATADIR%%/sounds/bonus.ogg
+%%DATADIR%%/sounds/cheering.ogg
+%%DATADIR%%/sounds/click.ogg
+%%DATADIR%%/sounds/gameover.ogg
+%%DATADIR%%/sounds/levelover.ogg
+%%DATADIR%%/sounds/over.ogg
+@dirrm %%DATADIR%%/fonts
+@dirrm %%DATADIR%%/pics/set1
+@dirrm %%DATADIR%%/pics
+@dirrm %%DATADIR%%/sounds
+@dirrm %%DATADIR%%