aboutsummaryrefslogtreecommitdiff
path: root/games/tremulous
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-10-02 18:56:06 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-10-02 18:56:06 +0000
commit0abb5f88931e62bc95e14c8d880cf15980bfaa1d (patch)
treed44a27e55d798c91f9379293a7028c41d925c666 /games/tremulous
parentb9ab78aea3d7377d9b97f25ab5e3ae9c40e94691 (diff)
downloadports-0abb5f88931e62bc95e14c8d880cf15980bfaa1d.tar.gz
ports-0abb5f88931e62bc95e14c8d880cf15980bfaa1d.zip
- Add USE_XLIB since after the 7.x Xorg update, USE_GL doesn't imply it [1].
- Remove 4.x support. Reported by: linimon [1]
Notes
Notes: svn path=/head/; revision=200686
Diffstat (limited to 'games/tremulous')
-rw-r--r--games/tremulous/Makefile10
-rw-r--r--games/tremulous/files/extra-patch-src__unix__unix_shared.c24
2 files changed, 1 insertions, 33 deletions
diff --git a/games/tremulous/Makefile b/games/tremulous/Makefile
index 62c5005a2243..13bb4f30b8ed 100644
--- a/games/tremulous/Makefile
+++ b/games/tremulous/Makefile
@@ -18,7 +18,6 @@ MAINTAINER= alepulver@FreeBSD.org
COMMENT= Free FPS game featuring two opposing teams, humans and aliens
USE_ZIP= yes
-USE_GCC= 3.2+
USE_GMAKE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
BUILD_WRKSRC= ${WRKSRC}/${DISTNAME}-src
@@ -42,10 +41,6 @@ VM_ARCHS= amd64 i386 powerpc
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src__unix__unix_shared.c
-.endif
-
.if defined(WITHOUT_CLIENT) && defined(WITHOUT_DEDICATED) && \
defined(WITHOUT_SMP)
IGNORE= needs at least one of CLIENT, DEDICATED and SMP options
@@ -80,6 +75,7 @@ USE_SDL= sdl
MAKE_ENV+= USE_SDL_VIDEO=1
. else
USE_GL= yes
+USE_XLIB= yes
. endif
# Vorbis
. if defined(WITH_VORBIS)
@@ -137,10 +133,6 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e 's|botlib\.log|/dev/null|' \
${BUILD_WRKSRC}/src/botlib/be_interface.c
-.if ${OSVERSION} < 500000
- @${REINPLACE_CMD} -e 's|stdint\.h|inttypes.h|' \
- ${BUILD_WRKSRC}/src/qcommon/q_shared.h
-.endif
do-install:
.for bin in ${TRBIN}
diff --git a/games/tremulous/files/extra-patch-src__unix__unix_shared.c b/games/tremulous/files/extra-patch-src__unix__unix_shared.c
deleted file mode 100644
index 628935fa5e38..000000000000
--- a/games/tremulous/files/extra-patch-src__unix__unix_shared.c
+++ /dev/null
@@ -1,24 +0,0 @@
---- ./tremulous-1.1.0-src/src/unix/unix_shared.c.orig Sat Dec 10 17:19:52 2005
-+++ ./tremulous-1.1.0-src/src/unix/unix_shared.c Wed Jun 7 16:59:51 2006
-@@ -22,6 +22,7 @@
- */
- #include <sys/types.h>
- #include <sys/stat.h>
-+#include <sys/sysctl.h>
- #include <errno.h>
- #include <stdio.h>
- #include <dirent.h>
-@@ -431,6 +432,12 @@
- // sysconf() in libc, POSIX.1 compliant
- unsigned int Sys_ProcessorCount(void)
- {
-- return sysconf(_SC_NPROCESSORS_ONLN);
-+ int mib[2], value, len;
-+
-+ mib[0] = CTL_HW;
-+ mib[1] = HW_NCPU;
-+ len = sizeof(value);
-+ sysctl(mib, 2, &value, &len, NULL, 0);
-+ return (value);
- }
- #endif