aboutsummaryrefslogtreecommitdiff
path: root/games/tremulous
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /games/tremulous
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=211584
Diffstat (limited to 'games/tremulous')
-rw-r--r--games/tremulous/Makefile6
-rw-r--r--games/tremulous/files/patch-Makefile4
2 files changed, 5 insertions, 5 deletions
diff --git a/games/tremulous/Makefile b/games/tremulous/Makefile
index 1eefd8182dad..3cb730e704d4 100644
--- a/games/tremulous/Makefile
+++ b/games/tremulous/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tremulous
PORTVERSION= 1.1.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:S|$|${PORTNAME}/|} \
http://0day.icculus.org/mirrors/tremulous/ \
@@ -74,8 +74,8 @@ MAKE_ENV+= USE_SDL_AUDIO=1
USE_SDL= sdl
MAKE_ENV+= USE_SDL_VIDEO=1
. else
-USE_GL= yes
-USE_XLIB= yes
+USE_GL= gl
+USE_XORG= x11 xxf86dga
. endif
# Vorbis
. if defined(WITH_VORBIS)
diff --git a/games/tremulous/files/patch-Makefile b/games/tremulous/files/patch-Makefile
index 270ac4aa5ab7..705c84b3e52a 100644
--- a/games/tremulous/files/patch-Makefile
+++ b/games/tremulous/files/patch-Makefile
@@ -77,7 +77,7 @@
+ BASE_CFLAGS = -I$(LOCALBASE)/include -DARCH='\"$(ARCH)\"' -Wall -fno-strict-aliasing -Wimplicit -Wstrict-prototypes
- GL_CFLAGS = -I/usr/X11R6/include
-+ GL_CFLAGS = -I$(X11BASE)/include
++ GL_CFLAGS = -I$(LOCALBASE)/include
DEBUG_CFLAGS=$(BASE_CFLAGS) -g
+ RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG -pipe
@@ -159,7 +159,7 @@
+ endif
+
+ ifneq ($(USE_SDL_VIDEO),1)
-+ CLIENT_LDFLAGS += -L$(X11BASE)/lib -lGL -lX11 -lXext -lXxf86dga -lXxf86vm
++ CLIENT_LDFLAGS += -L$(LOCALBASE)/lib -lGL -lX11 -lXext -lXxf86dga -lXxf86vm
endif
ifeq ($(USE_OPENAL),1)