aboutsummaryrefslogtreecommitdiff
path: root/games/tremulous
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2009-08-19 22:19:12 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2009-08-19 22:19:12 +0000
commit93d49a592874ae76c929a1ba076772f678124619 (patch)
tree55d0c6a128c6925312df6e6b392c1eafc3024028 /games/tremulous
parent3518a3f8c7ae97e09f1db6d409f38ed6d918eb36 (diff)
downloadports-93d49a592874ae76c929a1ba076772f678124619.tar.gz
ports-93d49a592874ae76c929a1ba076772f678124619.zip
Notes
Diffstat (limited to 'games/tremulous')
-rw-r--r--games/tremulous/Makefile31
1 files changed, 15 insertions, 16 deletions
diff --git a/games/tremulous/Makefile b/games/tremulous/Makefile
index 1097884ecdce..f7cd8f31f713 100644
--- a/games/tremulous/Makefile
+++ b/games/tremulous/Makefile
@@ -1,6 +1,6 @@
-# New ports collection makefile for: tremulous
+# New ports collection makefile for: Tremulous
# Date created: 3 Jun 2006
-# Whom: alepulver
+# Whom: Alejandro Pulver <alepulver@FreeBSD.org>
#
# $FreeBSD$
#
@@ -9,12 +9,11 @@ PORTNAME= tremulous
PORTVERSION= 1.1.0
PORTREVISION= 6
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:S|$|${PORTNAME}/|} \
- http://0day.icculus.org/mirrors/tremulous/ \
+MASTER_SITES= SF http://0day.icculus.org/mirrors/tremulous/ \
ftp://ftp.wireplay.co.uk/pub/quake3arena/mods/tremulous/ \
http://www.planetgloom.com/trem/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= danfe@FreeBSD.org
COMMENT= Free FPS game featuring two opposing teams, humans and aliens
USE_ZIP= yes
@@ -22,17 +21,17 @@ USE_GMAKE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
BUILD_WRKSRC= ${WRKSRC}/${DISTNAME}-src
-OPTIONS= CLIENT "Build client" on \
- GAMELIBS "Build game libraries (when not mandatory)" off \
- DEDICATED "Build dedicated server" on \
- MASTER_SERVER "Build master server" off \
- OPENAL "Enable OpenAL (3D sound) support" off \
- OPENAL_DLOPEN "Enable dynamic loading of OpenAL" off \
+OPTIONS= CLIENT "Build client" on \
+ GAMELIBS "Build game libraries (when not mandatory)" off \
+ DEDICATED "Build dedicated server" on \
+ MASTER_SERVER "Build master server" off \
+ OPENAL "Enable OpenAL (3D sound) support" off \
+ OPENAL_DLOPEN "Enable dynamic loading of OpenAL" off \
OPTIMIZED_CFLAGS "Enable compilation optimizations" on \
- SDL_AUDIO "Use SDL for audio" off \
- SDL_VIDEO "Use SDL for video" off \
- SMP "Build SMP (threaded) client" on \
- VORBIS "Enable Ogg Vorbis codec support" off
+ SDL_AUDIO "Use SDL for audio" off \
+ SDL_VIDEO "Use SDL for video" off \
+ SMP "Build SMP (threaded) client" on \
+ VORBIS "Enable Ogg Vorbis codec support" off
MAKE_ENV+= DEFAULT_BASEDIR="${DATADIR}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
@@ -43,7 +42,7 @@ VM_ARCHS= amd64 i386 powerpc
.if defined(WITHOUT_CLIENT) && defined(WITHOUT_DEDICATED) && \
defined(WITHOUT_SMP)
-IGNORE= needs at least one of CLIENT, DEDICATED and SMP options
+IGNORE= needs at least one of CLIENT, DEDICATED, or SMP options
.endif
.for i in ${ARCH}