aboutsummaryrefslogtreecommitdiff
path: root/games/triplane
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2011-01-17 08:04:48 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2011-01-17 08:04:48 +0000
commit97e28a8680449cd7b54022cf542d6d0b8c2d8351 (patch)
tree27317064d8a347bdf453e0d3d9f203ce0937367a /games/triplane
parent57f67727fed9a03a86eacb14360e6c0b9e82f7d4 (diff)
downloadports-97e28a8680449cd7b54022cf542d6d0b8c2d8351.tar.gz
ports-97e28a8680449cd7b54022cf542d6d0b8c2d8351.zip
Add games/triplane, a side-scrolling dogfighting game.
Approved by: ehaupt (mentor) Feature safe: yes
Notes
Notes: svn path=/head/; revision=267904
Diffstat (limited to 'games/triplane')
-rw-r--r--games/triplane/Makefile29
-rw-r--r--games/triplane/distinfo2
-rw-r--r--games/triplane/files/patch-Makefile36
-rw-r--r--games/triplane/pkg-descr7
-rw-r--r--games/triplane/pkg-plist3
5 files changed, 77 insertions, 0 deletions
diff --git a/games/triplane/Makefile b/games/triplane/Makefile
new file mode 100644
index 000000000000..01638d04b6cd
--- /dev/null
+++ b/games/triplane/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: triplane
+# Date created: 01 Jan 2011
+# Whom: Ganael Laplanche <ganael.laplanche@martymac.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= triplane
+PORTVERSION= 1.04.r20110114
+CATEGORIES= games
+MASTER_SITES= http://contribs.martymac.org/FreeBSD-ports/distfiles/ \
+ SF/${PORTNAME}
+DISTNAME= ${PORTNAME}-classic-${PORTVERSION}
+
+MAINTAINER= martymac@FreeBSD.org
+COMMENT= Port of the original Triplane Turmoil game
+
+LICENSE= GPLv3
+
+USE_SDL= sdl mixer
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}
+
+CFLAGS+= -DTRIPLANE_DATA=\\\"${DATADIR}\\\"
+MAKE_ENV= DATADIR="${DATADIR}"
+
+ALL_TARGET= depend all
+
+.include <bsd.port.mk>
diff --git a/games/triplane/distinfo b/games/triplane/distinfo
new file mode 100644
index 000000000000..341c7c56acfd
--- /dev/null
+++ b/games/triplane/distinfo
@@ -0,0 +1,2 @@
+SHA256 (triplane-classic-1.04.r20110114.tar.gz) = 3d72b528dddaa9c4ef147df3b26db00ff38a9ef561c3b826fc56f46d529f5aa2
+SIZE (triplane-classic-1.04.r20110114.tar.gz) = 3471686
diff --git a/games/triplane/files/patch-Makefile b/games/triplane/files/patch-Makefile
new file mode 100644
index 000000000000..5f6b308b3746
--- /dev/null
+++ b/games/triplane/files/patch-Makefile
@@ -0,0 +1,36 @@
+--- Makefile.orig 2011-01-14 15:46:08.000000000 +0000
++++ Makefile 2011-01-14 15:49:40.248413763 +0000
+@@ -1,11 +1,11 @@
+-PREFIX = /usr/local
+-DESTDIR = ""
+-
+-CXX = g++
+-OPTIFLAG = -O2 -g
+-CFLAGS := -Wall -Isrc $(OPTIFLAG) $(CFLAGS_NOSDL) `sdl-config --cflags` -DHAVE_SDL_MIXER "-DTRIPLANE_DATA=\"$(PREFIX)/share/games/triplane-classic\""
+-LDFLAGS =
+-LIBS := `sdl-config --libs` -lSDL_mixer -lm
++PREFIX ?= /usr/local
++DESTDIR ?= ""
++SDL_CONFIG ?= sdl-config
++
++CXX ?= g++
++#OPTIFLAG = -O2 -g
++CFLAGS += -Wall -Isrc $(OPTIFLAG) $(CFLAGS_NOSDL) `$(SDL_CONFIG) --cflags` -DHAVE_SDL_MIXER
++LIBS := `$(SDL_CONFIG) --libs` -lSDL_mixer -lm
+
+ COMMON_OBJS = src/gfx/bitmap.o src/gfx/font.o \
+ src/gfx/gfx.o src/util/wutil.o src/util/random.o \
+@@ -72,10 +72,9 @@
+ $(CXX) -o tools/dksbuild -g src/tools/dksbuild/dksbuild.cc
+
+ install:
+- mkdir -p $(DESTDIR)$(PREFIX)/games
+- install triplane-classic $(DESTDIR)$(PREFIX)/games/triplane-classic
+- mkdir -p $(DESTDIR)$(PREFIX)/share/games/triplane-classic
+- install -m 644 fokker.dks $(DESTDIR)$(PREFIX)/share/games/triplane-classic/fokker.dks
++ $(BSD_INSTALL_PROGRAM) triplane-classic $(DESTDIR)$(PREFIX)/bin/triplane
++ mkdir -p $(DESTDIR)$(DATADIR)
++ $(BSD_INSTALL_DATA) fokker.dks $(DESTDIR)$(DATADIR)/fokker.dks
+ test:
+ if [ ! -d triplane-testsuite ]; then echo Please darcs get http://iki.fi/lindi/darcs/triplane-testsuite; false; fi
+ bash tools/run-all-tests tools/run-one-test ./triplane-classic triplane-testsuite
diff --git a/games/triplane/pkg-descr b/games/triplane/pkg-descr
new file mode 100644
index 000000000000..a58086481abc
--- /dev/null
+++ b/games/triplane/pkg-descr
@@ -0,0 +1,7 @@
+Triplane Classic is a side-scrolling dogfighting game featuring solo
+missions and multiplayer mode with up to four players. It is a port of
+the original Triplane Turmoil game for DOS and aims to match the
+original game exactly so that high scores remain comparable to the
+original.
+
+WWW: http://triplane.sourceforge.net
diff --git a/games/triplane/pkg-plist b/games/triplane/pkg-plist
new file mode 100644
index 000000000000..5724ba2438c0
--- /dev/null
+++ b/games/triplane/pkg-plist
@@ -0,0 +1,3 @@
+bin/triplane
+%%DATADIR%%/fokker.dks
+@dirrm %%DATADIR%%