aboutsummaryrefslogtreecommitdiff
path: root/games/trojka
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2000-07-18 09:45:05 +0000
committerKevin Lo <kevlo@FreeBSD.org>2000-07-18 09:45:05 +0000
commit802185c16ac893316a6cd0aa3b7def6eb0565202 (patch)
tree3a12aa698c59d4a07d30418f46be6113b540e33b /games/trojka
parenta3c7da85f7a44e447d16953258ba4a1c8fc85ad3 (diff)
downloadports-802185c16ac893316a6cd0aa3b7def6eb0565202.tar.gz
ports-802185c16ac893316a6cd0aa3b7def6eb0565202.zip
Initial import of trojka-1.0
trojka is a game of skill PR: 19911 Submitted by: Edwin Mons <edwinme@ik.nu> Reviewed by: sobomax
Notes
Notes: svn path=/head/; revision=30783
Diffstat (limited to 'games/trojka')
-rw-r--r--games/trojka/Makefile21
-rw-r--r--games/trojka/distinfo1
-rw-r--r--games/trojka/files/patch-aa36
-rw-r--r--games/trojka/files/patch-ab30
-rw-r--r--games/trojka/files/patch-ac12
-rw-r--r--games/trojka/files/patch-ad11
-rw-r--r--games/trojka/pkg-comment1
-rw-r--r--games/trojka/pkg-descr7
-rw-r--r--games/trojka/pkg-message7
-rw-r--r--games/trojka/pkg-plist5
10 files changed, 131 insertions, 0 deletions
diff --git a/games/trojka/Makefile b/games/trojka/Makefile
new file mode 100644
index 000000000000..aff44025803b
--- /dev/null
+++ b/games/trojka/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: trojka
+# Date created: 22 march 2000
+# Whom: Edwin Mons
+#
+# $FreeBSD$
+#
+
+PORTNAME= trojka
+PORTVERSION= 1.0
+CATEGORIES= games
+MASTER_SITES= ftp://ftp.funet.fi/pub/unix/games/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= e@ik.nu
+
+MAN6= trojka.6
+
+post-install:
+ ${SED} "s|%%PREFIX%%|${PREFIX}|" ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/games/trojka/distinfo b/games/trojka/distinfo
new file mode 100644
index 000000000000..8ab72c6f3d82
--- /dev/null
+++ b/games/trojka/distinfo
@@ -0,0 +1 @@
+MD5 (trojka.tar.gz) = e5d09a395df937b4e09a089013648a77
diff --git a/games/trojka/files/patch-aa b/games/trojka/files/patch-aa
new file mode 100644
index 000000000000..d814e16729af
--- /dev/null
+++ b/games/trojka/files/patch-aa
@@ -0,0 +1,36 @@
+--- Makefile.orig Sat Oct 21 05:17:43 1995
++++ Makefile Tue Jul 18 11:39:08 2000
+@@ -6,14 +6,25 @@
+ #
+
+
+-
++SCOREDIR=$(PREFIX)/share/trojka
++SCOREFILE=$(SCOREDIR)/trojka.scores
++CFLAGS+= -DSCOREFILE=\"$(SCOREFILE)\"
+ OBJS= trojka.o screen.o scan.o hiscore.o system.o
+
++all: freebsd trojka.6.out
++
+ make:
+ @echo please specify: hpux, xenix68, linux or sunos
+
+ install:
+- cp trojka /usr/games
++ install -c -d -m 0755 $(SCOREDIR)
++ install -c -m 2755 -g games -s trojka $(PREFIX)/bin
++ install -c -m 0644 COPYRIGHT README $(SCOREDIR)
++ install -c -m 0664 -g games /dev/null $(SCOREFILE)
++ install -c -m 0444 trojka.6.out $(PREFIX)/man/man6/trojka.6
++
++trojka.6.out: trojka.6
++ sed "s|%%PREFIX%%|$(PREFIX)|" trojka.6 > trojka.6.out
+
+ clean:
+ rm -f $(PROGS) *.o core a.out trojka.scores
+@@ -53,3 +64,5 @@
+
+ linux:
+ make trojka "CFLAGS=-DLINUX"
++
++freebsd: trojka
diff --git a/games/trojka/files/patch-ab b/games/trojka/files/patch-ab
new file mode 100644
index 000000000000..e4940565d031
--- /dev/null
+++ b/games/trojka/files/patch-ab
@@ -0,0 +1,30 @@
+--- system.c.orig Sat Oct 21 05:16:20 1995
++++ system.c Mon Jul 17 21:09:48 2000
+@@ -23,6 +23,9 @@
+ #include <stdio.h>
+ #include <time.h>
+ #include <fcntl.h>
++#ifdef __FreeBSD__
++#include <sys/ioctl.h>
++#endif
+
+ #include "trojka.h"
+
+@@ -42,7 +45,7 @@
+
+ char getkey() /* get key from keyboard */
+ {
+-#if SUNOS | HPUX | LINUX
++#if SUNOS | HPUX | LINUX | __FreeBSD__
+ long count;
+ char ch;
+
+@@ -119,7 +122,7 @@
+ int delay(millisecs)
+ int millisecs;
+ {
+-#if SUNOS | LINUX
++#if SUNOS | LINUX | __FreeBSD__
+ usleep(millisecs * 1200); /* usleep does microsecs; need millisecs */
+ #endif
+ #ifdef HPUX
diff --git a/games/trojka/files/patch-ac b/games/trojka/files/patch-ac
new file mode 100644
index 000000000000..b11771664e50
--- /dev/null
+++ b/games/trojka/files/patch-ac
@@ -0,0 +1,12 @@
+--- sys_custom.h.orig Mon Jul 17 21:02:18 2000
++++ sys_custom.h Mon Jul 17 21:02:41 2000
+@@ -7,7 +7,9 @@
+ #ifndef _sys_custom_
+ #define _sys_custom_
+
++#ifndef SCOREFILE
+ #define SCOREFILE "/usr/games/lib/trojka.scores"
++#endif
+
+ #define UMASK 0666 /* creation mask for hiscorefile */
+
diff --git a/games/trojka/files/patch-ad b/games/trojka/files/patch-ad
new file mode 100644
index 000000000000..c581ceb7cc6f
--- /dev/null
+++ b/games/trojka/files/patch-ad
@@ -0,0 +1,11 @@
+--- trojka.6.orig Mon Jul 17 21:03:06 2000
++++ trojka.6 Mon Jul 17 21:03:36 2000
+@@ -40,7 +40,7 @@
+
+ .SH FILES
+ .nf
+-/usr/local/games/lib/trojka.scores The Trojka hiscore file
++%%PREFIX%%/share/trojka/trojka.scores The Trojka hiscore file
+
+ .SH HISTORY
+ First version written in 1989 for MS-Dog. Not long thereafter (in 1990)
diff --git a/games/trojka/pkg-comment b/games/trojka/pkg-comment
new file mode 100644
index 000000000000..b0da04a501c2
--- /dev/null
+++ b/games/trojka/pkg-comment
@@ -0,0 +1 @@
+A game of skill
diff --git a/games/trojka/pkg-descr b/games/trojka/pkg-descr
new file mode 100644
index 000000000000..6b3645bbd5b6
--- /dev/null
+++ b/games/trojka/pkg-descr
@@ -0,0 +1,7 @@
+Trojka is a game of skill. The aim of the game is to control and place
+falling blocks so that you get three patterns or colors in a row,
+horizontally or diagonally. These patterns then disappear, the above
+blocks collapse and you get points.
+
+- Edwin Mons
+e@ik.nu
diff --git a/games/trojka/pkg-message b/games/trojka/pkg-message
new file mode 100644
index 000000000000..6f3b8e6278c6
--- /dev/null
+++ b/games/trojka/pkg-message
@@ -0,0 +1,7 @@
+============================================================
+You now have suid binary (2755):
+
+ %%PREFIX%%/bin/trojka
+
+Scores will not be writed if you don't set suid.
+============================================================
diff --git a/games/trojka/pkg-plist b/games/trojka/pkg-plist
new file mode 100644
index 000000000000..c74345df8212
--- /dev/null
+++ b/games/trojka/pkg-plist
@@ -0,0 +1,5 @@
+bin/trojka
+share/trojka/COPYRIGHT
+share/trojka/README
+share/trojka/trojka.scores
+@dirrm share/trojka