aboutsummaryrefslogtreecommitdiff
path: root/games/trophy/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2004-10-06 05:10:30 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2004-10-06 05:10:30 +0000
commitcc2b3f217a5138201eb65ec8dc1411de3c1262ec (patch)
tree676e534fae914c76542c5b99c38dbc80b41355d8 /games/trophy/Makefile
parentc545d87f456250e67f60cbb0835805a5ffbf5e14 (diff)
downloadports-cc2b3f217a5138201eb65ec8dc1411de3c1262ec.tar.gz
ports-cc2b3f217a5138201eb65ec8dc1411de3c1262ec.zip
Notes
Diffstat (limited to 'games/trophy/Makefile')
-rw-r--r--games/trophy/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/games/trophy/Makefile b/games/trophy/Makefile
index b1cc5fd8802e..f1562baa72d6 100644
--- a/games/trophy/Makefile
+++ b/games/trophy/Makefile
@@ -20,19 +20,16 @@ LIB_DEPENDS= clanCore.2:${PORTSDIR}/devel/clanlib
USE_X_PREFIX= yes
USE_GMAKE= yes
+USE_REINPLACE= yes
BUILD_WRKSRC= ${WRKSRC}/trophy
MAKE_ENV= PTHREAD_CFLAGS=${PTHREAD_CFLAGS} \
PTHREAD_LIBS=${PTHREAD_LIBS}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
post-extract:
@${FIND} ${BUILD_WRKSRC}/resources -name .cvsignore -exec ${RM} -f {} \;
+ @${REINPLACE_CMD} -e 's/std::sqrt/sqrt/' ${BUILD_WRKSRC}/caimagemanipulation.cpp \
+ ${BUILD_WRKSRC}/catrophy.cpp ${BUILD_WRKSRC}/camath.cpp
do-install:
${MKDIR} ${PREFIX}/bin
@@ -51,4 +48,4 @@ do-install:
${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>