aboutsummaryrefslogtreecommitdiff
path: root/games/tsito
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-10-15 23:49:06 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-10-15 23:49:06 +0000
commit9ecfab52b8b5c6cffd3fb5914c42f77685831a47 (patch)
tree1e2160197000cb58d7792b454382e3358f6ec6d4 /games/tsito
parent4f15f0b1f73ad7417c1f3ea706619cfe395c7b07 (diff)
downloadports-9ecfab52b8b5c6cffd3fb5914c42f77685831a47.tar.gz
ports-9ecfab52b8b5c6cffd3fb5914c42f77685831a47.zip
Tsito plays XiangQi (Chinese Chess) against the user or it referees two
players. It can be used on the console (or an xterm) or can communicate through pipes to a GUI frontend. If used in a console it uses ASCII characters to display the board on the screen. PR: ports/72705 Submitted by: Kuang-che Wu <kcwu@csie.org>
Notes
Notes: svn path=/head/; revision=119542
Diffstat (limited to 'games/tsito')
-rw-r--r--games/tsito/Makefile23
-rw-r--r--games/tsito/distinfo2
-rw-r--r--games/tsito/files/patch-src-Interface.cpp11
-rw-r--r--games/tsito/pkg-descr11
-rw-r--r--games/tsito/pkg-plist3
5 files changed, 50 insertions, 0 deletions
diff --git a/games/tsito/Makefile b/games/tsito/Makefile
new file mode 100644
index 000000000000..ced3cffef20f
--- /dev/null
+++ b/games/tsito/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: tsito
+# Date created: 14 Oct 2004
+# Whom: Kuang-che Wu <kcwu@csie.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tsito
+PORTVERSION= 0.8.4
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= xiangqi-engine
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A Chinese chess (Xiangqi) program
+
+HAS_CONFIGURE= yes
+CONFIGURE_ENV= LIBS="-lcompat"
+CONFIGURE_ARGS= --prefix="${PREFIX}"
+
+MAN1= tsito.1
+
+.include <bsd.port.mk>
diff --git a/games/tsito/distinfo b/games/tsito/distinfo
new file mode 100644
index 000000000000..9d9784bbc39f
--- /dev/null
+++ b/games/tsito/distinfo
@@ -0,0 +1,2 @@
+MD5 (tsito-0.8.4.tar.gz) = 198b7313067959f7530d569ca9b48a1e
+SIZE (tsito-0.8.4.tar.gz) = 184809
diff --git a/games/tsito/files/patch-src-Interface.cpp b/games/tsito/files/patch-src-Interface.cpp
new file mode 100644
index 000000000000..423af42c7e24
--- /dev/null
+++ b/games/tsito/files/patch-src-Interface.cpp
@@ -0,0 +1,11 @@
+--- src/Interface.cpp.orig Mon Jun 9 21:07:05 2003
++++ src/Interface.cpp Sat Oct 16 01:43:23 2004
+@@ -5,6 +5,8 @@
+ #include <windows.h>
+ #include <conio.h>
+ #else
++#include <sys/types.h>
++#include <sys/time.h>
+ #include <sys/select.h>
+ #include <unistd.h>
+ #endif
diff --git a/games/tsito/pkg-descr b/games/tsito/pkg-descr
new file mode 100644
index 000000000000..86583b1f1276
--- /dev/null
+++ b/games/tsito/pkg-descr
@@ -0,0 +1,11 @@
+Tsito plays XiangQi (Chinese Chess) against the user or it referees two
+players. It can be used on the console (or an xterm) or can communicate through
+pipes to a GUI frontend. If used in a console it uses ASCII characters to
+display the board on the screen.
+
+'tsito', stands for "The Secret Inside The Orange".
+
+WWW: http://xiangqi-engine.sourceforge.net/
+
+- Kuang-che Wu
+ kcwu@csie.org
diff --git a/games/tsito/pkg-plist b/games/tsito/pkg-plist
new file mode 100644
index 000000000000..a4481eae4a53
--- /dev/null
+++ b/games/tsito/pkg-plist
@@ -0,0 +1,3 @@
+bin/tsito
+%%DATADIR%%/book.dat
+@dirrm share/tsito