aboutsummaryrefslogtreecommitdiff
path: root/games/ttt
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2012-09-09 22:08:43 +0000
committerSteve Wills <swills@FreeBSD.org>2012-09-09 22:08:43 +0000
commit8e9facf25efa2433bcc53a2cae2b38a036084fcd (patch)
treee3993c6cdae567d24dbdcfc6b036f0ef751e9eef /games/ttt
parent87de998a149ef29204ea523420db9c5b176dd376 (diff)
downloadports-8e9facf25efa2433bcc53a2cae2b38a036084fcd.tar.gz
ports-8e9facf25efa2433bcc53a2cae2b38a036084fcd.zip
- Add second MASTER_SITE
- changed LICENSE (GPLv2) - changed to OptionsNG - Use PLIST_FILES instead of pkg_plist due to short package list - Give maintainership to submitter PR: ports/170995 Submitted by: nemysis <nemysis@gmx.ch>
Notes
Notes: svn path=/head/; revision=304004
Diffstat (limited to 'games/ttt')
-rw-r--r--games/ttt/Makefile55
-rw-r--r--games/ttt/files/patch-configure.ac10
-rw-r--r--games/ttt/files/ttt.in7
-rw-r--r--games/ttt/pkg-descr5
-rw-r--r--games/ttt/pkg-plist14
5 files changed, 53 insertions, 38 deletions
diff --git a/games/ttt/Makefile b/games/ttt/Makefile
index 8adbd8a41393..ddd53513c112 100644
--- a/games/ttt/Makefile
+++ b/games/ttt/Makefile
@@ -7,37 +7,52 @@
PORTNAME= ttt
PORTVERSION= 2011.04
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
-MASTER_SITES= ftp://ftp.tuxpaint.org/unix/x/ttt/
+MASTER_SITES= ftp://ftp.tuxpaint.org/unix/x/ttt/ \
+ ftp://ftp.billsgames.com/unix/x/ttt/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= nemysis@gmx.ch
COMMENT= Simple one or two player Tic Tac Toe game
-# net/ttt
-CONFLICTS= ttt-1*
-NO_LATEST_LINK= yes
+LICENSE= GPLv2
-LICENSE= GPLv2 GPLv3
-LICENSE_COMB= dual
-
-USE_SDL= sdl
-USE_GMAKE= yes
USE_AUTOTOOLS= aclocal automake autoheader autoconf
AUTOMAKE_ARGS= --add-missing --force
-MAKE_JOBS_SAFE= yes
+ALL_TARGET= ${PORTNAME}
+USE_SDL= mixer sdl
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-post-patch:
- @${REINPLACE_CMD} -e \
- '/SDL_mixer/d' ${WRKSRC}/configure.ac
- @${REINPLACE_CMD} -e \
- 's|\./images|${DATADIR}/images|g' ${WRKSRC}/src/init.c
+PLIST_FILES= bin/${PORTNAME} \
+ share/pixmaps/${PORTNAME}.bmp
+
+PORTDATA= *
+PORTDOCS= README
+
+SUB_FILES= ${PORTNAME}
+
+.include <bsd.port.options.mk>
+
+do-install:
+# Scripts
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
+
+# Executable
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${DATADIR}
+
+# Data
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} "images sounds" ${DATADIR})
+
+# Pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/images/program_logo.bmp ${PREFIX}/share/pixmaps/${PORTNAME}.bmp
-post-install:
- @${MKDIR} ${DATADIR}/images
- ${INSTALL_DATA} ${WRKSRC}/images/*.bmp ${DATADIR}/images
+# Documentation
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
.include <bsd.port.mk>
diff --git a/games/ttt/files/patch-configure.ac b/games/ttt/files/patch-configure.ac
new file mode 100644
index 000000000000..6b8f5e3fd7ec
--- /dev/null
+++ b/games/ttt/files/patch-configure.ac
@@ -0,0 +1,10 @@
+--- configure.ac.orig 2011-04-05 05:43:45.000000000 +0200
++++ configure.ac 2012-09-09 04:55:17.000000000 +0200
+@@ -44,6 +44,7 @@
+ AC_PROG_MKDIR_P
+ AC_PROG_SED
+ LT_INIT
++AC_SUBST([LIBTOOL_DEPS])
+
+ dnl AC_CHECK_LIB([duma], [_duma_malloc] ,,AC_MSG_ERROR(missing library))
+ AC_CHECK_LIB([SDL], [SDL_Init] ,,AC_MSG_ERROR(missing library))
diff --git a/games/ttt/files/ttt.in b/games/ttt/files/ttt.in
new file mode 100644
index 000000000000..864232e7b98c
--- /dev/null
+++ b/games/ttt/files/ttt.in
@@ -0,0 +1,7 @@
+#!/bin/sh
+#
+# $FreeBSD$
+
+echo "Tic Tac Toe: Starting up..."
+cd "%%DATADIR%%"
+./ttt
diff --git a/games/ttt/pkg-descr b/games/ttt/pkg-descr
index 6564609d0e9a..34a62ab8cd47 100644
--- a/games/ttt/pkg-descr
+++ b/games/ttt/pkg-descr
@@ -1,6 +1,3 @@
-TTT (Tic-Tac-Toe)
-
-"ttt" is a very simple one - or two - player Tic Tac Toe game played using a
-mouse.
+ttt is a very simple one- or two-player Tic Tac Toe game played using a mouse.
WWW: http://www.newbreedsoftware.com/ttt/
diff --git a/games/ttt/pkg-plist b/games/ttt/pkg-plist
deleted file mode 100644
index b4c37a718681..000000000000
--- a/games/ttt/pkg-plist
+++ /dev/null
@@ -1,14 +0,0 @@
-bin/ttt
-%%DATADIR%%/images/game_board.bmp
-%%DATADIR%%/images/human_vs_computer.bmp
-%%DATADIR%%/images/human_vs_human.bmp
-%%DATADIR%%/images/mark_o.bmp
-%%DATADIR%%/images/mark_x.bmp
-%%DATADIR%%/images/program_logo.bmp
-%%DATADIR%%/images/status_draw.bmp
-%%DATADIR%%/images/status_win_o.bmp
-%%DATADIR%%/images/status_win_x.bmp
-%%DATADIR%%/images/turn_o.bmp
-%%DATADIR%%/images/turn_x.bmp
-@dirrm %%DATADIR%%/images
-@dirrm %%DATADIR%%