aboutsummaryrefslogtreecommitdiff
path: root/games/ttt
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-04-24 21:15:49 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-04-24 21:15:49 +0000
commitaffa1eae3cacc9b85462de606556a3edd0487769 (patch)
treee90e2d2d6123928ece9228ede3071fd69fd42cbb /games/ttt
parent61caf9cf81206436a20d87c5aadab4781fd2551b (diff)
downloadports-affa1eae3cacc9b85462de606556a3edd0487769.tar.gz
ports-affa1eae3cacc9b85462de606556a3edd0487769.zip
- Remove USE_REINPLACE.
- Fix OPTIONS handling. - Format tabs. - Add '@' to permission fixing commands. - Bump PORTREVISION. Approved by: garga (mentor)
Notes
Notes: svn path=/head/; revision=160395
Diffstat (limited to 'games/ttt')
-rw-r--r--games/ttt/Makefile30
1 files changed, 15 insertions, 15 deletions
diff --git a/games/ttt/Makefile b/games/ttt/Makefile
index 16a40aebe12b..654e4025f39f 100644
--- a/games/ttt/Makefile
+++ b/games/ttt/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ttt
PORTVERSION= 2003.03.14
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= ftp://ftp.billsgames.com/unix/x/ttt/
@@ -15,7 +16,6 @@ COMMENT= Simple one or two player Tic Tac Toe game
USE_GMAKE= yes
USE_SDL= mixer sdl
-USE_REINPLACE= yes
OPTIONS= OPTIMIZED_CFLAGS "Enable compilation optimizations" on
@@ -26,36 +26,36 @@ NO_LATEST_LINK= yes
.include <bsd.port.pre.mk>
post-patch:
-# Fix Makefile
+# Fix Makefile.
@${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG}| ; \
- s|\(-Wall\)|${CFLAGS} \1|' \
- ${WRKSRC}/${MAKEFILE}
+ s|\(-Wall\)|${CFLAGS} \1|' \
+ ${WRKSRC}/${MAKEFILE}
-# Enable/disable compilation optimizations
-.if !defined(WITH_OPTIMIZED_CFLAGS)
+# Enable/disable compilation optimizations.
+.if defined(WITHOUT_OPTIMIZED_CFLAGS)
@${REINPLACE_CMD} -e 's|-O2||' ${WRKSRC}/${MAKEFILE}
.endif
-# Fix paths to ${DATADIR}
+# Fix paths to ${DATADIR}.
@${REINPLACE_CMD} -e 's|\(images/\)|${DATADIR}/\1| ; \
- s|\(sounds/\)|${DATADIR}/\1|' \
- ${WRKSRC}/ttt.c
+ s|\(sounds/\)|${DATADIR}/\1|' \
+ ${WRKSRC}/ttt.c
do-install:
-# Program
+# Program.
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
-# Data
+# Data.
${MKDIR} ${DATADIR}
.for d in images sounds
${CP} -R ${WRKSRC}/${d} ${DATADIR}
.endfor
-# Fix wrong permissions
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DATADIR}
- ${FIND} ${DATADIR} -type f -print0 | \
+# Fix wrong permissions.
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DATADIR}
+ @${FIND} ${DATADIR} -type f -print0 | \
${XARGS} -0 ${CHMOD} ${SHAREMODE}
- ${FIND} ${DATADIR} -type d -print0 | \
+ @${FIND} ${DATADIR} -type d -print0 | \
${XARGS} -0 ${CHMOD} ${BINMODE}
.include <bsd.port.post.mk>