aboutsummaryrefslogtreecommitdiff
path: root/games/tty-solitaire
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2020-01-02 09:23:47 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2020-01-02 09:23:47 +0000
commitf3d068d506d8823523ce77ee959e54f97c3041c6 (patch)
treec7007439084c666ad039758d9298204147cade43 /games/tty-solitaire
parentb6f2b70996dca2c37591b5a258bc35f66bf1a603 (diff)
downloadports-f3d068d506d8823523ce77ee959e54f97c3041c6.tar.gz
ports-f3d068d506d8823523ce77ee959e54f97c3041c6.zip
Modify the makefile so we can specify the ncurses implementation from the
command line
Notes
Notes: svn path=/head/; revision=521813
Diffstat (limited to 'games/tty-solitaire')
-rw-r--r--games/tty-solitaire/Makefile2
-rw-r--r--games/tty-solitaire/files/patch-Makefile16
2 files changed, 18 insertions, 0 deletions
diff --git a/games/tty-solitaire/Makefile b/games/tty-solitaire/Makefile
index 7b77f6529016..b489257ed5b4 100644
--- a/games/tty-solitaire/Makefile
+++ b/games/tty-solitaire/Makefile
@@ -17,6 +17,8 @@ GH_ACCOUNT= mpereira
USES= gmake ncurses
+MAKE_ARGS= NCURSES=-l${NCURSES_IMPL}
+
PORTDOCS= *
PLIST_FILES= bin/ttysolitaire
diff --git a/games/tty-solitaire/files/patch-Makefile b/games/tty-solitaire/files/patch-Makefile
new file mode 100644
index 000000000000..5671e22a7976
--- /dev/null
+++ b/games/tty-solitaire/files/patch-Makefile
@@ -0,0 +1,16 @@
+--- Makefile.orig 2018-11-10 05:00:46 UTC
++++ Makefile
+@@ -6,10 +6,11 @@ CFLAGS += -W -Wall -pedantic -ansi -std=c99 -DVERSION=
+
+ # OS X installs ncurses with wide character support, but not as "libncurses".
+ ifeq ($(shell uname -s),Darwin)
+- LDFLAGS += -lncurses
++ NCURSES = -lncurses
+ else
+- LDFLAGS += -lncursesw
++ NCURSES = -lncursesw
+ endif
++LDFLAGS += $(NCURSES)
+
+ PREFIX ?= /usr/local
+