aboutsummaryrefslogtreecommitdiff
path: root/games/tuxmath
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-12 03:18:09 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-12 03:18:09 +0000
commit7f8c13d51a16587515a1fad755bf8046b119dd9b (patch)
treed89809ae0c3fe44305d771fb3ff4656a60679be6 /games/tuxmath
parentd7c9140255f5a85e27473a09e76f5f355dd4472b (diff)
downloadports-7f8c13d51a16587515a1fad755bf8046b119dd9b.tar.gz
ports-7f8c13d51a16587515a1fad755bf8046b119dd9b.zip
- Add stage support
- Convert all "if's" in options helpers - Fix a problem (file not found) during execution
Notes
Notes: svn path=/head/; revision=333544
Diffstat (limited to 'games/tuxmath')
-rw-r--r--games/tuxmath/Makefile29
-rw-r--r--games/tuxmath/pkg-plist1
2 files changed, 10 insertions, 20 deletions
diff --git a/games/tuxmath/Makefile b/games/tuxmath/Makefile
index a5782479e3ab..3c3fa7e2a0a3 100644
--- a/games/tuxmath/Makefile
+++ b/games/tuxmath/Makefile
@@ -18,6 +18,7 @@ LICENSE= GPLv3 # (or later)
OPTIONS_DEFINE= NLS SVG DOCS
OPTIONS_DEFAULT= SVG
+OPTIONS_SUB= yes
WRKSRC= ${WRKDIR}/${PORTNAME}_w_fonts-${PORTVERSION}
@@ -38,23 +39,12 @@ T4K_VERSION= 0.1.1
T4K_DISTFILE= ${T4K_NAME}-${T4K_VERSION}${EXTRACT_SUFX}
T4K_WRKSRC= ${WRKDIR}/${T4K_NAME}-${T4K_VERSION}
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext
+NLS_LDFLAGS= -lintl
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-LDFLAGS+= -lintl
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MSVG}
-USE_GNOME+= librsvg2
-.else
-CONFIGURE_ARGS+=--without-rsvg
-.endif
+SVG_CONFIGURE_WITH= rsvg
+SVG_USE= GNOME=librsvg2
# use multiple make jobs for T4K_WRKSRC
_make_jobs= -j${MAKE_JOBS_NUMBER}
@@ -80,11 +70,10 @@ pre-build:
${MAKEFILE} ${_make_jobs} ${ALL_TARGET})
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+ ${LN} -s ${DATADIR}/images/status ${STAGEDIR}${DATADIR}/images/menu
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in OFL README README_DATA_LICENSES TODO changelog
- ${INSTALL_DATA} ${WRKSRC}/doc/${file} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${file} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>
diff --git a/games/tuxmath/pkg-plist b/games/tuxmath/pkg-plist
index e5985621d027..d64d6f0e3997 100644
--- a/games/tuxmath/pkg-plist
+++ b/games/tuxmath/pkg-plist
@@ -536,6 +536,7 @@ bin/tuxmathtestclient
%%DATADIR%%/sounds/tock.wav
%%DATADIR%%/sounds/towerclock.wav
%%DATADIR%%/sounds/tuxi.ogg
+%%DATADIR%%/images/menu
@dirrm %%DATADIR%%/sounds
@dirrm %%DATADIR%%/missions/multiplay
@dirrm %%DATADIR%%/missions/lessons