aboutsummaryrefslogtreecommitdiff
path: root/games/tuxpaint-fonts
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-05-05 09:45:36 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-05-05 09:45:36 +0000
commit4a4ec28d37b64039d4eff0f34ad66b543767d758 (patch)
tree96cc94ba02edcc043c52eb3f26adbc632bbe44d8 /games/tuxpaint-fonts
parenta5d24d4bb4a43375b4bbb7f8bc673f8c557f06b4 (diff)
downloadports-4a4ec28d37b64039d4eff0f34ad66b543767d758.tar.gz
ports-4a4ec28d37b64039d4eff0f34ad66b543767d758.zip
Convert all :U to :tu and :L to :tl
Since FreeBSD 8.4 and FreeBSD 9.1 make(1) do support :tu and :tl as a replacement for :U and :L (which has been marked as deprecated) bmake which is the default on FreeBSD 10+ only support by default :tu/:tl a hack has been added at the time to support :U and :L to ease migration. This hack is now not necessary anymore Note that this makes the ports tree incompatible with make(1) from FreeBSD 8.3 or earlier With hat: portmgr
Notes
Notes: svn path=/head/; revision=352986
Diffstat (limited to 'games/tuxpaint-fonts')
-rw-r--r--games/tuxpaint-fonts/Makefile33
1 files changed, 15 insertions, 18 deletions
diff --git a/games/tuxpaint-fonts/Makefile b/games/tuxpaint-fonts/Makefile
index a08d0ef51d00..4a448d85cf93 100644
--- a/games/tuxpaint-fonts/Makefile
+++ b/games/tuxpaint-fonts/Makefile
@@ -29,19 +29,16 @@ CHINESE_SIMPLIFIED_CODE= zh_cn
KOREAN_CODE= ko
VIETNAMESE_CODE= vi
-#Bmake compatibility
-.MAKE.FreeBSD_UL= yes
-
# Generate options menu.
.for l in ${LANGS}
-OPTIONS_DEFINE+= ${l:U}
-OPTIONS_DEFAULT+= ${l:U}
-${l:U}_DESC= ${l:S/_/ /} fonts
+OPTIONS_DEFINE+= ${l:tu}
+OPTIONS_DEFAULT+= ${l:tu}
+${l:tu}_DESC= ${l:S/_/ /} fonts
.endfor
# Set MASTER_SITES
.for l in ${LANGS}
-MASTER_SITES+= SF/${PORTNAME}/${PORTNAME}-fonts/${${l:U}_DISTNAME}:${l:U}
+MASTER_SITES+= SF/${PORTNAME}/${PORTNAME}-fonts/${${l:tu}_DISTNAME}:${l:tu}
.endfor
# Do not use the same OPTIONS directory as "games/tuxpaint".
@@ -51,12 +48,12 @@ LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
# Set DISTFILES and PLIST_FILES according to OPTIONS.
.for l in ${LANGS}
-. if ${PORT_OPTIONS:M${l:U}}
-DISTFILES+= ${PORTNAME}-ttf-${${l:U}_DISTNAME}${EXTRACT_SUFX}:${l:U}
-PLIST_FILES+= %%DATADIR%%/fonts/locale/${${l:U}_CODE}.ttf
-PLIST_FILES+= %%DATADIR%%/fonts/locale/${${l:U}_CODE}_docs/COPYING.txt
-PLIST_FILES+= %%DATADIR%%/fonts/locale/${${l:U}_CODE}_docs/README.txt
-PLIST_DIRS+= %%DATADIR%%/fonts/locale/${${l:U}_CODE}_docs
+. if ${PORT_OPTIONS:M${l:tu}}
+DISTFILES+= ${PORTNAME}-ttf-${${l:tu}_DISTNAME}${EXTRACT_SUFX}:${l:tu}
+PLIST_FILES+= %%DATADIR%%/fonts/locale/${${l:tu}_CODE}.ttf
+PLIST_FILES+= %%DATADIR%%/fonts/locale/${${l:tu}_CODE}_docs/COPYING.txt
+PLIST_FILES+= %%DATADIR%%/fonts/locale/${${l:tu}_CODE}_docs/README.txt
+PLIST_DIRS+= %%DATADIR%%/fonts/locale/${${l:tu}_CODE}_docs
. endif
.endfor
@@ -64,14 +61,14 @@ PLIST_DIRS+= %%DATADIR%%/fonts/locale/${${l:U}_CODE}_docs
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}/fonts/locale
.for l in ${LANGS}
-. if ${PORT_OPTIONS:M${l:U}}
+. if ${PORT_OPTIONS:M${l:tu}}
${INSTALL_DATA} \
- ${WRKSRC}/${PORTNAME}-ttf-${${l:U}_DISTNAME}/${${l:U}_CODE}.ttf \
+ ${WRKSRC}/${PORTNAME}-ttf-${${l:tu}_DISTNAME}/${${l:tu}_CODE}.ttf \
${STAGEDIR}${DATADIR}/fonts/locale
- @${MKDIR} ${STAGEDIR}${DATADIR}/fonts/locale/${${l:U}_CODE}_docs
+ @${MKDIR} ${STAGEDIR}${DATADIR}/fonts/locale/${${l:tu}_CODE}_docs
${INSTALL_DATA} \
- ${WRKSRC}/${PORTNAME}-ttf-${${l:U}_DISTNAME}/*.txt \
- ${STAGEDIR}${DATADIR}/fonts/locale/${${l:U}_CODE}_docs
+ ${WRKSRC}/${PORTNAME}-ttf-${${l:tu}_DISTNAME}/*.txt \
+ ${STAGEDIR}${DATADIR}/fonts/locale/${${l:tu}_CODE}_docs
. endif
.endfor