aboutsummaryrefslogtreecommitdiff
path: root/games/tuxpaint/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-11-29 01:07:46 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-11-29 01:07:46 +0000
commit13ee8b167eb22ad4716a2e6099c20bc26017765f (patch)
tree4c327c81796e88f8375f8045ed6b17b7470d9647 /games/tuxpaint/Makefile
parent80ac2a3dc66b94b5d4026ee73abe33a108d1dce3 (diff)
downloadports-13ee8b167eb22ad4716a2e6099c20bc26017765f.tar.gz
ports-13ee8b167eb22ad4716a2e6099c20bc26017765f.zip
Notes
Diffstat (limited to 'games/tuxpaint/Makefile')
-rw-r--r--games/tuxpaint/Makefile21
1 files changed, 4 insertions, 17 deletions
diff --git a/games/tuxpaint/Makefile b/games/tuxpaint/Makefile
index 22b1dff65dea..c552bde8148c 100644
--- a/games/tuxpaint/Makefile
+++ b/games/tuxpaint/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= tuxpaint
-PORTVERSION= 0.9.14
-PORTREVISION= 1
+PORTVERSION= 0.9.15
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -29,27 +28,15 @@ MANCOMPRESSED= yes
IGNORE= needs wide character string functions in libc
.endif
-post-extract:
-# Remove CVS directories
- @${FIND} ${WRKSRC} -type d -name CVS -print0 | \
- ${XARGS} -0 ${RM} -rf
-
post-patch:
-# Fix Makefile
- @${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}| ; \
- s|$$(PREFIX)/share/tuxpaint|${DATADIR}| ; \
- s|$$(PREFIX)/share/doc/tuxpaint|${DOCSDIR}|; \
- s|sdl-config|${SDL_CONFIG}|' \
- ${WRKSRC}/${MAKEFILE}
-
-# Documentation (optional)
+# Documentation.
.if defined(NOPORTDOCS)
@${REINPLACE_CMD} -e 's|install-doc\([^:]\)|\1|' ${WRKSRC}/${MAKEFILE}
.endif
# Fix SDL include statement and remove "#error" statement
@${REINPLACE_CMD} -e 's|\(#include.*\)SDL/\(SDL.*\)|\1\2| ; \
- s|#error.*||' \
- ${WRKSRC}/src/${PORTNAME}.c
+ s|#error.*||' \
+ ${WRKSRC}/src/${PORTNAME}.c
.include <bsd.port.post.mk>