aboutsummaryrefslogtreecommitdiff
path: root/games/tuxtype
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-12-03 13:36:55 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-12-03 13:36:55 +0000
commit72395c650d55431fb67337d74388feb839e073ef (patch)
treec0152efa014ec13ffa5ebc65daa059731243e180 /games/tuxtype
parent0511a923c0109906ba7c9d62252548e468e8b5a8 (diff)
downloadports-72395c650d55431fb67337d74388feb839e073ef.tar.gz
ports-72395c650d55431fb67337d74388feb839e073ef.zip
Notes
Diffstat (limited to 'games/tuxtype')
-rw-r--r--games/tuxtype/Makefile4
-rw-r--r--games/tuxtype/files/patch-Makefile.in15
-rw-r--r--games/tuxtype/pkg-plist5
3 files changed, 21 insertions, 3 deletions
diff --git a/games/tuxtype/Makefile b/games/tuxtype/Makefile
index 13e9190437f0..d1ebcdd36b00 100644
--- a/games/tuxtype/Makefile
+++ b/games/tuxtype/Makefile
@@ -13,7 +13,8 @@ DISTFILES= ${PORTNAME}_w_fonts-${PORTVERSION}${EXTRACT_SUFX} \
MAINTAINER= ports@FreeBSD.org
COMMENT= Educational typing tutor starring Tux the Linux Penguin
-LICENSE= GPLv3 # (or later)
+LICENSE= GPLv2 # (or later)
+LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= gsed:${PORTSDIR}/textproc/gsed
@@ -23,6 +24,7 @@ USES= gmake iconv perl5 pkgconfig
USE_GNOME= libxml2
USE_SDL= image mixer net pango sdl
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --localstatedir=/var/games
CONFIGURE_ENV= T4K_COMMON_CFLAGS="-I${T4K_WRKSRC}/src" \
T4K_COMMON_LIBS="${T4K_WRKSRC}/src/.libs/libt4k_common.a" \
ac_cv_lib_m_csin=yes
diff --git a/games/tuxtype/files/patch-Makefile.in b/games/tuxtype/files/patch-Makefile.in
new file mode 100644
index 000000000000..3d55a33e12c7
--- /dev/null
+++ b/games/tuxtype/files/patch-Makefile.in
@@ -0,0 +1,15 @@
+--- Makefile.in.orig 2014-12-02 21:50:06.000000000 +0300
++++ Makefile.in 2014-12-02 21:52:09.000000000 +0300
+@@ -776,10 +776,9 @@
+ # Global configuration (e.g. /etc/tuxtype):
+ $(MKDIR_P) -m 755 $(DESTDIR)$(pkgsysconfdir)
+ # Global sites for game state data (e.g. /var/games/tuxtype):
+- $(MKDIR_P) -m 2755 $(DESTDIR)$(pkglocalstatedir)
+- $(MKDIR_P) -m 2755 $(DESTDIR)$(pkglocalstatedir)/words
++ $(MKDIR_P) $(DESTDIR)$(pkglocalstatedir)
++ $(MKDIR_P) $(DESTDIR)$(pkglocalstatedir)/words
+ # chown root:games $(DESTDIR)$(pkglocalstatedir)
+- chown root:games $(DESTDIR)$(pkglocalstatedir)/words
+
+ uninstall-hook:
+ rm -rf $(DESTDIR)$(pkglocalstatedir)/words
diff --git a/games/tuxtype/pkg-plist b/games/tuxtype/pkg-plist
index 705fa825c9e2..143c33dfee05 100644
--- a/games/tuxtype/pkg-plist
+++ b/games/tuxtype/pkg-plist
@@ -1,4 +1,4 @@
-bin/tuxtype
+@(,games,2555) bin/tuxtype
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/OFL
@@ -795,5 +795,6 @@ bin/tuxtype
%%DATADIR%%/words/words1.txt
%%DATADIR%%/words/words2.txt
%%DATADIR%%/words/words3.txt
-@dir var/tuxtype/words
+@dir(,games,775) /var/games/tuxtype/words
+@dir(,games,775) /var/games/tuxtype
@dir %%ETCDIR%%