aboutsummaryrefslogtreecommitdiff
path: root/games/tycho
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-12 19:47:07 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-12 19:47:07 +0000
commitd9f99366939ffc2637c86274c197d9be38b9ac27 (patch)
tree268137df9f6b5c92de7f36cd9ae1eebdf5605664 /games/tycho
parentb6c6d461d964528cdf2e7c241508e3c8aec0ac88 (diff)
downloadports-d9f99366939ffc2637c86274c197d9be38b9ac27.tar.gz
ports-d9f99366939ffc2637c86274c197d9be38b9ac27.zip
- Convert USE_GMAKE to USES
- Add stage support
Notes
Notes: svn path=/head/; revision=333609
Diffstat (limited to 'games/tycho')
-rw-r--r--games/tycho/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/games/tycho/Makefile b/games/tycho/Makefile
index d156c8ca3844..2bcb4ad6d6aa 100644
--- a/games/tycho/Makefile
+++ b/games/tycho/Makefile
@@ -12,15 +12,14 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Program to gather data (statistics) on Core War warriors
USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake
WRKSRC= ${WRKDIR}/${PORTNAME}
PLIST_FILES= bin/tycho \
bin/tycho-exstat
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/exstat ${PREFIX}/bin/${PORTNAME}-exstat
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/exstat ${STAGEDIR}${PREFIX}/bin/${PORTNAME}-exstat
.include <bsd.port.mk>