aboutsummaryrefslogtreecommitdiff
path: root/games/typespeed/Makefile
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-04-28 17:44:52 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-04-28 17:44:52 +0000
commite14c68b537eeaa358e60567516f13ab8323b4df9 (patch)
tree2b013f0b61ea84ced21b7160072144b8bdcf2f4f /games/typespeed/Makefile
parentf83eb9ea5a75c09bf559e9d8977bd3516a7bd270 (diff)
Notes
Diffstat (limited to 'games/typespeed/Makefile')
-rw-r--r--games/typespeed/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/games/typespeed/Makefile b/games/typespeed/Makefile
index 77d3af8f3e95..08d5c2caead1 100644
--- a/games/typespeed/Makefile
+++ b/games/typespeed/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= typespeed
-PORTVERSION= 0.4.1
+PORTVERSION= 0.4.4
CATEGORIES= games
-MASTER_SITES= http://www.sicom.fi/~bestis/
+MASTER_SITES= http://ls.purkki.org/typespeed/
DISTNAME= typespeed-${PORTVERSION}
-MAINTAINER= refugee@vt.edu
+MAINTAINER= ehaupt@critical.ch
COMMENT= Test your typing speed, and get your fingers\' CPS
MAN1= typespeed.1
@@ -19,10 +19,13 @@ MAN1= typespeed.1
USE_REINPLACE= yes
USE_GETOPT_LONG= yes
-MAKE_ENV= LFLAGS="${LDFLAGS}"
+MAKE_ENV= CPPFLAGS="${CPPFLAGS}" LFLAGS="${LDFLAGS}"
post-patch:
- ${REINPLACE_CMD} -e 's#_PREFIX_HERE#${PREFIX}#g' \
+ @${REINPLACE_CMD} -e 's|\(/etc\)|${PREFIX}\1|' \
${WRKSRC}/typespeed.h
+post-install:
+ @PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+
.include <bsd.port.mk>