aboutsummaryrefslogtreecommitdiff
path: root/games/ufoai
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2019-11-05 22:16:14 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2019-11-05 22:16:14 +0000
commitbe6c15b5c6de864408ba3f414a57f20ff622a2d0 (patch)
tree86bd1ae6afedaa57f4eef276444e85b00f8c8e63 /games/ufoai
parent2428d822895b6225746f9e1d2bed3143711fcf14 (diff)
downloadports-be6c15b5c6de864408ba3f414a57f20ff622a2d0.tar.gz
ports-be6c15b5c6de864408ba3f414a57f20ff622a2d0.zip
Add USES=xorg USES=gl, ports categories g
Add USES=xorg and USES=gl to ports in categories starting with 'g'. While here, try to sprinkle other USES (mostly gnome and sdl) as needed.
Notes
Notes: svn path=/head/; revision=516845
Diffstat (limited to 'games/ufoai')
-rw-r--r--games/ufoai/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/games/ufoai/Makefile b/games/ufoai/Makefile
index b67eeca16cc1..8a676c1cd7ff 100644
--- a/games/ufoai/Makefile
+++ b/games/ufoai/Makefile
@@ -25,11 +25,11 @@ BUILD_DEPENDS= zip:archivers/zip
RUN_DEPENDS= ${LOCALBASE}/share/${PORTNAME}/base/default.cfg:games/ufoai-data
ALL_TARGET= all lang
+USES= compiler:c++11-lang gettext gl gmake jpeg openal:soft \
+ pkgconfig python:build sdl tar:bzip2
USE_GL= yes
USE_SDL= sdl image mixer ttf
USE_CXXSTD= c++11
-USES= compiler:c++11-lang gettext gmake jpeg openal:soft pkgconfig \
- python:build tar:bzip2
HAS_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-release --target-os=freebsd
LDFLAGS+= -lpthread -lexecinfo
@@ -70,6 +70,7 @@ PLIST_SUB+= UFO2MAP="@comment "
.if ${PORT_OPTIONS:MUFORADIANT}
ALL_TARGET+= uforadiant
CONFIGURE_ARGS+=--enable-uforadiant
+USES+= gnome
USE_GNOME+= gtk20 glib20 gtksourceview2 libxml2
LIB_DEPENDS+= libgtkglext-x11-1.0.so:x11-toolkits/gtkglext
RADIANT_FILES= colours.xml game.xml input.xml mapdef.template menu.xml user.xml