aboutsummaryrefslogtreecommitdiff
path: root/games/uhexen
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2012-11-22 15:37:58 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2012-11-22 15:37:58 +0000
commitfbe68a3a4fb0142888e6b5cad68d46bcd52cc24b (patch)
tree9002012d5e53f9e1faa5ff54bc8728601668ec51 /games/uhexen
parent9febedbe67306a28cf1720b757448479bdbb9859 (diff)
downloadports-fbe68a3a4fb0142888e6b5cad68d46bcd52cc24b.tar.gz
ports-fbe68a3a4fb0142888e6b5cad68d46bcd52cc24b.zip
- Switch to the official sf.net CDN in MASTER_SITES
- Integrate with our standard shareware game data port - Convert to the new OPTIONS framework - Relinquish maintainership, cleanup Makefile Feature safe: yes
Notes
Notes: svn path=/head/; revision=307656
Diffstat (limited to 'games/uhexen')
-rw-r--r--games/uhexen/Makefile52
-rw-r--r--games/uhexen/distinfo6
-rw-r--r--games/uhexen/files/patch-src::h2_main.c2
3 files changed, 15 insertions, 45 deletions
diff --git a/games/uhexen/Makefile b/games/uhexen/Makefile
index 482d909bb216..ef2895f11580 100644
--- a/games/uhexen/Makefile
+++ b/games/uhexen/Makefile
@@ -1,62 +1,34 @@
-# New ports collection makefile for: U-Hexen
-# Date created: 10 February 2003
-# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
-#
+# Created by: Maxim Sobolev <sobomax@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= uhexen
PORTVERSION= 0.601
PORTREVISION= 8
CATEGORIES= games
-MASTER_SITES= http://uhexen.sourceforge.net/
-DISTNAME= ${PORTNAME}-latest
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/U-hexen%20version%20${PORTVERSION}
-MAINTAINER= danfe@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Yet another port of Hexen, popular game from Raven Software
-USE_SDL= mixer sdl
USE_GMAKE= yes
+USE_SDL= mixer sdl
-OPTIONS= WAD "Install demo-version WAD file" on \
- MUSIC "Enable support for in-game music" on
+OPTIONS_DEFINE= MUSIC
+OPTIONS_DEFAULT= MUSIC
+MUSIC_DESC= In-game MIDI music support
.include <bsd.port.pre.mk>
.if ${ARCH} == "powerpc"
-BROKEN= Does not compile on powerpc
+BROKEN= Does not compile on ${ARCH}
.endif
-.if !defined(WITHOUT_WAD)
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} hexen.zip
-EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
-EXTRACT_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
-PLIST_SUB= WAD=""
-.else
-PLIST_SUB= WAD="@comment "
-.endif
-
-.if !defined(WITHOUT_MUSIC)
-RUN_DEPENDS+= ${LOCALBASE}/lib/timidity/goemon.cfg:${PORTSDIR}/audio/timidity
-.endif
-
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-
-PLIST_FILES= bin/uhexen %%DATADIR%%/.keep_me %%WAD%%%%DATADIR%%/hexen.wad
-PLIST_DIRS= %%DATADIR%%
-
-post-extract:
-.if !defined(WITHOUT_WAD)
- @${UNZIP_CMD} -qo ${DISTDIR}/hexen.zip \
- -d ${WRKSRC}
+.if ${PORT_OPTIONS:MMUSIC}
+RUN_DEPENDS= ${LOCALBASE}/lib/timidity/goemon.cfg:${PORTSDIR}/audio/timidity
.endif
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/uhexen ${PREFIX}/bin
- @${MKDIR} ${DATADIR}
-.if !defined(WITHOUT_WAD)
- ${INSTALL_DATA} ${WRKSRC}/hexen.wad ${DATADIR}
-.endif
- @${TOUCH} ${DATADIR}/.keep_me
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+.include "${.CURDIR}/../doom-data/Makefile.include"
.include <bsd.port.post.mk>
diff --git a/games/uhexen/distinfo b/games/uhexen/distinfo
index 8786241691b4..fb1416886473 100644
--- a/games/uhexen/distinfo
+++ b/games/uhexen/distinfo
@@ -1,4 +1,2 @@
-SHA256 (uhexen-latest.tar.gz) = 2bcfee59530573b44d3cf560a9df285da4af0407f9ab68ee05ee3e537f1457de
-SIZE (uhexen-latest.tar.gz) = 407703
-SHA256 (hexen.zip) = 739aa91b307b5b2dc46089f7a062cde0559bb5b75859d46950b2f1812f7e54f6
-SIZE (hexen.zip) = 5216479
+SHA256 (uhexen-0.601.tar.gz) = 2bcfee59530573b44d3cf560a9df285da4af0407f9ab68ee05ee3e537f1457de
+SIZE (uhexen-0.601.tar.gz) = 407703
diff --git a/games/uhexen/files/patch-src::h2_main.c b/games/uhexen/files/patch-src::h2_main.c
index 2e55366d713c..9d673878a690 100644
--- a/games/uhexen/files/patch-src::h2_main.c
+++ b/games/uhexen/files/patch-src::h2_main.c
@@ -8,7 +8,7 @@ $FreeBSD$
{
"hexen.wad",
- "/usr/local/share/games/uhexen/hexen.wad"
-+ PREFIX "/share/uhexen/hexen.wad"
++ PREFIX "/share/doom/hexen.wad"
};
#else
static char *wadfiles[MAXWADFILES] =