aboutsummaryrefslogtreecommitdiff
path: root/games/ultimatestunts
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-12-02 12:57:00 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-12-02 12:57:00 +0000
commit726b6935c522131238c460915188e8e040655ae5 (patch)
treee6b70654286bf29969e3ea127fbba47ef31c566e /games/ultimatestunts
parent3b92ef4214fef78009122b09cbee8f57471cab2e (diff)
downloadports-726b6935c522131238c460915188e8e040655ae5.tar.gz
ports-726b6935c522131238c460915188e8e040655ae5.zip
games/ultimatestunts: Unbreak build
udpnet.cpp:61:6: error: no viable conversion from '__bind<int &, sockaddr *, unsigned long>' to 'int' int rc = bind (m_Socket, (struct sockaddr *) &MyAddress, sizeof(MyAddress)); ^ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ http://beefy9.nyi.freebsd.org/data/113amd64-default/518685/logs/errors/ultimatestunts-0.7.7.1_5.log While here apply r518709 to this port too and link with lld when possible
Notes
Notes: svn path=/head/; revision=518845
Diffstat (limited to 'games/ultimatestunts')
-rw-r--r--games/ultimatestunts/Makefile4
-rw-r--r--games/ultimatestunts/files/patch-simulation_udpnet.cpp15
2 files changed, 19 insertions, 0 deletions
diff --git a/games/ultimatestunts/Makefile b/games/ultimatestunts/Makefile
index 67951ef4f5a3..545b65cea342 100644
--- a/games/ultimatestunts/Makefile
+++ b/games/ultimatestunts/Makefile
@@ -25,12 +25,16 @@ USE_SDL= sdl image
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-openal
MAKE_JOBS_UNSAFE= yes
+# XXX Drop after FreeBSD 12.0 EOL
+.if exists(/usr/lib/clang/6.0.1)
LLD_UNSAFE= yes
+.endif
CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
CXXFLAGS_clang= -Wno-c++11-narrowing
CPPFLAGS+= $$(pkgconf --cflags-only-I sdl)
LDFLAGS+= $$(pkgconf --libs-only-L sdl)
+LDFLAGS_i386= -Wl,-z,notext
PORTDOCS= *
OPTIONS_DEFINE= DOCS NLS
diff --git a/games/ultimatestunts/files/patch-simulation_udpnet.cpp b/games/ultimatestunts/files/patch-simulation_udpnet.cpp
new file mode 100644
index 000000000000..c0837cbddcc8
--- /dev/null
+++ b/games/ultimatestunts/files/patch-simulation_udpnet.cpp
@@ -0,0 +1,15 @@
+udpnet.cpp:61:6: error: no viable conversion from '__bind<int &, sockaddr *, unsigned long>' to 'int'
+ int rc = bind (m_Socket, (struct sockaddr *) &MyAddress, sizeof(MyAddress));
+ ^ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+
+--- simulation/udpnet.cpp.orig 2019-12-02 12:38:14 UTC
++++ simulation/udpnet.cpp
+@@ -58,7 +58,7 @@ CUDPNet::CUDPNet(unsigned int port)
+ MyAddress.sin_addr.s_addr = htonl(INADDR_ANY);
+ MyAddress.sin_port = htons(port);
+
+- int rc = bind (m_Socket, (struct sockaddr *) &MyAddress, sizeof(MyAddress));
++ int rc = ::bind (m_Socket, (struct sockaddr *) &MyAddress, sizeof(MyAddress));
+ if(rc < 0)
+ {
+ printf("cannot bind port number %d \n", port);