aboutsummaryrefslogtreecommitdiff
path: root/games/uqm
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /games/uqm
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=211584
Diffstat (limited to 'games/uqm')
-rw-r--r--games/uqm/Makefile2
-rw-r--r--games/uqm/files/patch-build-unix-config_proginfo_host4
2 files changed, 3 insertions, 3 deletions
diff --git a/games/uqm/Makefile b/games/uqm/Makefile
index 63addabbefd2..ab47a0659b79 100644
--- a/games/uqm/Makefile
+++ b/games/uqm/Makefile
@@ -92,7 +92,7 @@ do-configure:
@${ECHO_MSG} INPUT_install_bindir_VALUE=\''$$prefix/bin'\' >> ${WRKSRC}/sc2/config.state
@${ECHO_MSG} INPUT_install_libdir_VALUE=\''$$prefix/lib'\' >> ${WRKSRC}/sc2/config.state
@${ECHO_MSG} INPUT_install_sharedir_VALUE=\''$$prefix/share'\' >> ${WRKSRC}/sc2/config.state
- cd ${WRKSRC}/sc2 && ${SETENV} LOCALBASE=${LOCALBASE} X11BASE=${X11BASE} PREFIX=${PREFIX} ./build.sh uqm config
+ cd ${WRKSRC}/sc2 && ${SETENV} LOCALBASE=${LOCALBASE} PREFIX=${PREFIX} ./build.sh uqm config
do-build:
cd ${WRKSRC}/sc2 && ./build.sh uqm
diff --git a/games/uqm/files/patch-build-unix-config_proginfo_host b/games/uqm/files/patch-build-unix-config_proginfo_host
index c25505c7b934..fe744a212478 100644
--- a/games/uqm/files/patch-build-unix-config_proginfo_host
+++ b/games/uqm/files/patch-build-unix-config_proginfo_host
@@ -28,8 +28,8 @@
FreeBSD|OpenBSD)
- LIB_opengl_CFLAGS="-I/usr/X11R6/include -D_THREAD_SAFE"
- LIB_opengl_LDFLAGS="-L/usr/X11R6/lib -lX11 -lXext -pthread -lGL"
-+ LIB_opengl_CFLAGS="-I${X11BASE}/include -D_THREAD_SAFE"
-+ LIB_opengl_LDFLAGS="-L${X11BASE}/lib -lX11 -lXext -pthread -lGL"
++ LIB_opengl_CFLAGS="-I${LOCALBASE}/include -D_THREAD_SAFE"
++ LIB_opengl_LDFLAGS="-L${LOCALBASE}/lib -lX11 -lXext -pthread -lGL"
;;
MINGW32*|CYGWIN*)
LIB_opengl_CFLAGS=""