aboutsummaryrefslogtreecommitdiff
path: root/games/uqm
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-10-10 19:28:14 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-10-10 19:28:14 +0000
commit53b92ba854454b94d5e8664b631960551d8e5cc4 (patch)
tree0c43c208988f4734f9635e6c98371a7a75ff9a98 /games/uqm
parente060580dadff70bccf221f78ba902e892adbe48f (diff)
downloadports-53b92ba854454b94d5e8664b631960551d8e5cc4.tar.gz
ports-53b92ba854454b94d5e8664b631960551d8e5cc4.zip
* Fix Typo and spacing in Makefile
* Mark the port i386 only. If someone manages to compile it on another platform, please let me know. * Remove dependency on SDL_mixer, as this library is no longer actually used by Ur-Quan Masters * Add switches for installing the voice and 3domusic add-on packages * Modify wrapper script so to automatically take advantage of these add-on packages PR: 57851 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=90816
Diffstat (limited to 'games/uqm')
-rw-r--r--games/uqm/Makefile90
-rw-r--r--games/uqm/distinfo2
-rw-r--r--games/uqm/pkg-plist4
3 files changed, 77 insertions, 19 deletions
diff --git a/games/uqm/Makefile b/games/uqm/Makefile
index d31fd49df4e7..b79d0cc16320 100644
--- a/games/uqm/Makefile
+++ b/games/uqm/Makefile
@@ -1,30 +1,72 @@
# Ports collection makefile for: uqm
-# Date created: 14 September 2003
-# Whom: asami
+# Date created: 14 September 2003
+# Whom: benlutz@datacomm.ch
#
# $FreeBSD$
#
+# Ur-Quan Masters offers add-on packages that enhance the game. These are
+# optional. The following add-ons exist at the moment:
+#
+# Voice add-on (110 MB). Enable this with -DVOICEADDON
+#
+# 3DO Music add-on (18 MB). Enable this with -DMUSICADDON
+#
+
+PORTNAME= uqm
+PORTVERSION= 0.3
+PORTREVISION= 1
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= sc2
+DISTFILES= ${PORTNAME}-${PORTVERSION}-source.tgz ${PORTNAME}-${PORTVERSION}-content.zip
+EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}-source.tgz
+
+MAINTAINER= benlutz@datacomm.ch
+COMMENT= A port of the original Star Control 2 for 3DO consoles
+
+ONLY_FOR_ARCHS= i386
+
+LIB_DEPENDS= SDL_image:${PORTSDIR}/graphics/sdl_image \
+ vorbis:${PORTSDIR}/audio/libvorbis \
+ ogg:${PORTSDIR}/audio/libogg
-PORTNAME= uqm
-PORTVERSION= 0.3
-CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR=sc2
-DISTFILES= ${PORTNAME}-${PORTVERSION}-source.tgz ${PORTNAME}-${PORTVERSION}-content.zip
-EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}-source.tgz
+USE_XLIB= yes
+USE_GMAKE= yes
+USE_SDL= yes
+USE_REINPLACE= yes
+NO_INSTALL_MANPAGES= yes
-MAINTAINER= benlutz@datacomm.ch
-COMMENT= A port of the original Star Control 2 for 3DO consoles
+.ifdef(VOICEADDON)
+DISTFILES+= ${PORTNAME}-${PORTVERSION}-voice.zip
+PLIST_SUB+= VOICEADDON=""
+.else
+PLIST_SUB+= VOICEADDON="@comment "
+.endif
-LIB_DEPENDS= SDL_image:${PORTSDIR}/graphics/sdl_image \
- SDL_mixer:${PORTSDIR}/audio/sdl_mixer \
- vorbis:${PORTSDIR}/audio/libvorbis \
- ogg:${PORTSDIR}/audio/libogg
+.ifdef(MUSICADDON)
+DISTFILES+= ${PORTNAME}-${PORTVERSION}-3domusic.zip
+PLIST_SUB+= MUSICADDON=""
+.else
+PLIST_SUB+= MUSICADDON="@comment "
+.endif
-USE_XLIB= yes
-USE_GMAKE= yes
-USE_SDL= yes
-NO_INSTALL_MANPAGES=yes
+pre-everything::
+.ifdef(!VOICEADDON || !MUSICADDON)
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "You may specify the following options:"
+.endif
+.ifdef(!VOICEADDON)
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "-DVOICEADDON"
+ @${ECHO_MSG} " Installs the voice add-on (110MB)."
+.endif
+.ifdef(!MUSICADDON)
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "-DMUSICADDON"
+ @${ECHO_MSG} " Installs the music add-on (18MB) containing the original"
+ @${ECHO_MSG} " 3do music files. Note that there is music without this"
+ @${ECHO_MSG} " add-on, just not as much."
+.endif
post-extract:
${CP} ${DISTDIR}/${PORTNAME}-${PORTVERSION}-content.zip ${WRKSRC}/content/packages/
@@ -37,6 +79,16 @@ do-build:
do-install:
cd ${WRKSRC} && ./build.sh uqm install
+.ifdef(VOICEADDON)
+ ${MKDIR} ${PREFIX}/share/uqm/content/packages/addons/voice
+ ${CP} ${DISTDIR}/${PORTNAME}-${PORTVERSION}-voice.zip ${PREFIX}/share/uqm/content/packages/addons/voice
+ ${REINPLACE_CMD} -e "s/\"$$\@\"/--addon voice \"$$\@\"/" ${PREFIX}/bin/uqm
+.endif
+.ifdef(MUSICADDON)
+ ${MKDIR} ${PREFIX}/share/uqm/content/packages/addons/3domusic
+ ${CP} ${DISTDIR}/${PORTNAME}-${PORTVERSION}-3domusic.zip ${PREFIX}/share/uqm/content/packages/addons/3domusic
+ ${REINPLACE_CMD} -e "s/\"$$\@\"/--addon 3domusic \"$$\@\"/" ${PREFIX}/bin/uqm
+.endif
post-install:
${STRIP_CMD} ${PREFIX}/lib/uqm/uqm
diff --git a/games/uqm/distinfo b/games/uqm/distinfo
index ec4cea216c55..d5ccadfdd82e 100644
--- a/games/uqm/distinfo
+++ b/games/uqm/distinfo
@@ -1,2 +1,4 @@
MD5 (uqm-0.3-source.tgz) = 6abcdc3caf7efd3bd978332743ee7568
MD5 (uqm-0.3-content.zip) = b17bb7b54df03b2d0ae3a23b91382b27
+MD5 (uqm-0.3-voice.zip) = 9a44f0037d05c453b9e570b88b12595f
+MD5 (uqm-0.3-3domusic.zip) = 9073251b0d96393441f0b40016010576
diff --git a/games/uqm/pkg-plist b/games/uqm/pkg-plist
index b0664f04dea4..b5f356c63e63 100644
--- a/games/uqm/pkg-plist
+++ b/games/uqm/pkg-plist
@@ -2,6 +2,10 @@ bin/uqm
lib/uqm/uqm
share/uqm/content/packages/uqm-0.3-content.zip
share/uqm/content/version
+%%VOICEADDON%%share/uqm/content/packages/addons/voice/uqm-0.3-voice.zip
+%%MUSICADDON%%share/uqm/content/packages/addons/3domusic/uqm-0.3-3domusic.zip
+%%VOICEADDON%%@dirrm share/uqm/content/packages/addons/voice
+%%MUSICADDON%%@dirrm share/uqm/content/packages/addons/3domusic
@dirrm share/uqm/content/packages/addons
@dirrm share/uqm/content/packages
@dirrm share/uqm/content