aboutsummaryrefslogtreecommitdiff
path: root/games/uqm
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-06 17:26:51 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-06 17:26:51 +0000
commit7ce20a260e3f4ddea9779dee21dd961c103922ec (patch)
tree32ffcaa6fbf8e8d32f51a08e5c8fe7a339a342b6 /games/uqm
parent51a5a78484cac039bd1500483533941b776d1f56 (diff)
downloadports-7ce20a260e3f4ddea9779dee21dd961c103922ec.tar.gz
ports-7ce20a260e3f4ddea9779dee21dd961c103922ec.zip
- Update to 0.4.0
- No longer builds on FreeBSD 4.X PR: ports/83043 Submitted by: Benjamin Lutz <benlutz@datacomm.ch> (maintainer)
Notes
Notes: svn path=/head/; revision=138610
Diffstat (limited to 'games/uqm')
-rw-r--r--games/uqm/Makefile50
-rw-r--r--games/uqm/distinfo16
-rw-r--r--games/uqm/files/patch-build-unix-build_functions11
-rw-r--r--games/uqm/files/patch-build-unix-config_proginfo_host22
-rw-r--r--games/uqm/files/patch-build::unix::build.config194
-rw-r--r--games/uqm/files/patch-build::unix::config_proginfo22
-rw-r--r--games/uqm/pkg-plist9
7 files changed, 74 insertions, 250 deletions
diff --git a/games/uqm/Makefile b/games/uqm/Makefile
index bd29aaa6f893..c659ae03e34d 100644
--- a/games/uqm/Makefile
+++ b/games/uqm/Makefile
@@ -13,19 +13,16 @@
#
PORTNAME= uqm
-PORTVERSION= 0.3
-PORTREVISION= 4
+PORTVERSION= 0.4.0
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= sc2
-DISTFILES= ${PORTNAME}-${PORTVERSION}-source.tgz ${PORTNAME}-${PORTVERSION}-content.zip
-EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}-source.tgz
+DISTFILES= ${PORTNAME}-${PORTVERSION}-source.tar.gz ${PORTNAME}-${PORTVERSION}-content.uqm
+EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}-source.tar.gz
MAINTAINER= benlutz@datacomm.ch
COMMENT= A port of the original Star Control 2 for 3DO consoles
-ONLY_FOR_ARCHS= i386
-
LIB_DEPENDS= vorbis.3:${PORTSDIR}/audio/libvorbis
USE_XLIB= yes
@@ -34,20 +31,28 @@ USE_SDL= image sdl
USE_REINPLACE= yes
NO_INSTALL_MANPAGES= yes
+ONLY_FOR_ARCHS= i386
+
.ifdef(VOICEADDON)
-DISTFILES+= ${PORTNAME}-${PORTVERSION}-voice.zip
+DISTFILES+= ${PORTNAME}-${PORTVERSION}-voice.uqm
PLIST_SUB+= VOICEADDON=""
.else
PLIST_SUB+= VOICEADDON="@comment "
.endif
.ifdef(MUSICADDON)
-DISTFILES+= ${PORTNAME}-${PORTVERSION}-3domusic.zip
+DISTFILES+= ${PORTNAME}-${PORTVERSION}-3domusic.uqm
PLIST_SUB+= MUSICADDON=""
.else
PLIST_SUB+= MUSICADDON="@comment "
.endif
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "does not compile"
+.endif
+
pre-everything::
.ifdef(!VOICEADDON || !MUSICADDON)
@${ECHO_MSG} ""
@@ -67,9 +72,24 @@ pre-everything::
.endif
post-extract:
- ${CP} ${DISTDIR}/${PORTNAME}-${PORTVERSION}-content.zip ${WRKSRC}/content/packages/
+ ${MKDIR} ${WRKSRC}/content/packages
+ ${CP} ${DISTDIR}/${PORTNAME}-${PORTVERSION}-content.uqm ${WRKSRC}/content/packages/
+.ifdef(VOICEADDON)
+ ${CP} ${DISTDIR}/${PORTNAME}-${PORTVERSION}-voice.uqm ${WRKSRC}/content/packages/
+.endif
+.ifdef(MUSICADDON)
+ ${CP} ${DISTDIR}/${PORTNAME}-${PORTVERSION}-3domusic.uqm ${WRKSRC}/content/packages/
+.endif
do-configure:
+ @${ECHO_MSG} CHOICE_debug_VALUE=\'nodebug\' > ${WRKSRC}/config.state
+ @${ECHO_MSG} CHOICE_graphics_VALUE=\'opengl\' >> ${WRKSRC}/config.state
+ @${ECHO_MSG} CHOICE_sound_VALUE=\'mixsdl\' >> ${WRKSRC}/config.state
+ @${ECHO_MSG} CHOICE_ioformat_VALUE=\'stdio_zip\' >> ${WRKSRC}/config.state
+ @${ECHO_MSG} INPUT_install_prefix_VALUE=\'${PREFIX}\' >> ${WRKSRC}/config.state
+ @${ECHO_MSG} INPUT_install_bindir_VALUE=\''$$prefix/bin'\' >> ${WRKSRC}/config.state
+ @${ECHO_MSG} INPUT_install_libdir_VALUE=\''$$prefix/lib'\' >> ${WRKSRC}/config.state
+ @${ECHO_MSG} INPUT_install_sharedir_VALUE=\''$$prefix/share'\' >> ${WRKSRC}/config.state
cd ${WRKSRC} && ${SETENV} LOCALBASE=${LOCALBASE} PREFIX=${PREFIX} ./build.sh uqm config
do-build:
@@ -77,16 +97,6 @@ do-build:
do-install:
cd ${WRKSRC} && ./build.sh uqm install
-.ifdef(VOICEADDON)
- ${MKDIR} ${PREFIX}/share/uqm/content/packages/addons/voice
- ${CP} ${DISTDIR}/${PORTNAME}-${PORTVERSION}-voice.zip ${PREFIX}/share/uqm/content/packages/addons/voice
- ${REINPLACE_CMD} -e "s/\"$$\@\"/--addon voice \"$$\@\"/" ${PREFIX}/bin/uqm
-.endif
-.ifdef(MUSICADDON)
- ${MKDIR} ${PREFIX}/share/uqm/content/packages/addons/3domusic
- ${CP} ${DISTDIR}/${PORTNAME}-${PORTVERSION}-3domusic.zip ${PREFIX}/share/uqm/content/packages/addons/3domusic
- ${REINPLACE_CMD} -e "s/\"$$\@\"/--addon 3domusic \"$$\@\"/" ${PREFIX}/bin/uqm
-.endif
post-install:
${STRIP_CMD} ${PREFIX}/lib/uqm/uqm
@@ -95,4 +105,4 @@ post-install:
${INSTALL_MAN} ${WRKSRC}/doc/users/manual.txt ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/uqm/distinfo b/games/uqm/distinfo
index 52dbb423fdde..ee9058feb9d0 100644
--- a/games/uqm/distinfo
+++ b/games/uqm/distinfo
@@ -1,8 +1,8 @@
-MD5 (uqm-0.3-source.tgz) = 6abcdc3caf7efd3bd978332743ee7568
-SIZE (uqm-0.3-source.tgz) = 906653
-MD5 (uqm-0.3-content.zip) = b17bb7b54df03b2d0ae3a23b91382b27
-SIZE (uqm-0.3-content.zip) = 12554418
-MD5 (uqm-0.3-voice.zip) = 9a44f0037d05c453b9e570b88b12595f
-SIZE (uqm-0.3-voice.zip) = 114985054
-MD5 (uqm-0.3-3domusic.zip) = 9073251b0d96393441f0b40016010576
-SIZE (uqm-0.3-3domusic.zip) = 18980505
+MD5 (uqm-0.4.0-source.tar.gz) = 5f92d7307b3b2e32f4384e29131ecbc5
+SIZE (uqm-0.4.0-source.tar.gz) = 1198714
+MD5 (uqm-0.4.0-content.uqm) = f8daed517466d68805393e02a12fd642
+SIZE (uqm-0.4.0-content.uqm) = 11695898
+MD5 (uqm-0.4.0-voice.uqm) = 52a084cfaa0bc7fcc63a295feb8cbd28
+SIZE (uqm-0.4.0-voice.uqm) = 114823413
+MD5 (uqm-0.4.0-3domusic.uqm) = 9073251b0d96393441f0b40016010576
+SIZE (uqm-0.4.0-3domusic.uqm) = 18980505
diff --git a/games/uqm/files/patch-build-unix-build_functions b/games/uqm/files/patch-build-unix-build_functions
new file mode 100644
index 000000000000..44232edb710a
--- /dev/null
+++ b/games/uqm/files/patch-build-unix-build_functions
@@ -0,0 +1,11 @@
+--- build/unix/build_functions.orig Mon May 16 01:28:22 2005
++++ build/unix/build_functions Sun Jul 3 18:00:10 2005
+@@ -145,7 +145,7 @@
+ eval "${TARGET}_requirements"
+ eval "${TARGET}_prepare_config"
+ eval "${TARGET}_load_config"
+- eval "${TARGET}_do_config"
++ #eval "${TARGET}_do_config"
+ eval "${TARGET}_save_config"
+ }
+
diff --git a/games/uqm/files/patch-build-unix-config_proginfo_host b/games/uqm/files/patch-build-unix-config_proginfo_host
new file mode 100644
index 000000000000..943b0b9d7061
--- /dev/null
+++ b/games/uqm/files/patch-build-unix-config_proginfo_host
@@ -0,0 +1,22 @@
+--- build/unix/config_proginfo_host.orig Sun Jul 3 17:23:50 2005
++++ build/unix/config_proginfo_host Sun Jul 3 17:24:43 2005
+@@ -80,7 +80,7 @@
+ LIB_openal_CFLAGS=""
+ case "$HOST_SYSTEM" in
+ FreeBSD|OpenBSD)
+- LIB_openal_LDFLAGS="-L/usr/local/lib -pthread -lopenal"
++ LIB_openal_LDFLAGS="-L${LOCALBASE}/lib -pthread -lopenal"
+ ;;
+ MINGW32*)
+ LIB_openal_LDFLAGS="-lopenal32"
+@@ -132,8 +132,8 @@
+ LIB_vorbisfile_NAME="vorbisfile"
+ case "$HOST_SYSTEM" in
+ FreeBSD|OpenBSD)
+- LIB_vorbisfile_CFLAGS="-I/usr/local/include"
+- LIB_vorbisfile_LDFLAGS="-L/usr/local/lib -lvorbisfile -lvorbis"
++ LIB_vorbisfile_CFLAGS="-I${LOCALBASE}/include"
++ LIB_vorbisfile_LDFLAGS="-L${LOCALBASE}/lib -lvorbisfile -lvorbis"
+ ;;
+ MINGW32*)
+ LIB_vorbisfile_CFLAGS=""
diff --git a/games/uqm/files/patch-build::unix::build.config b/games/uqm/files/patch-build::unix::build.config
deleted file mode 100644
index b1b7ee165ff0..000000000000
--- a/games/uqm/files/patch-build::unix::build.config
+++ /dev/null
@@ -1,194 +0,0 @@
---- build/unix/build.config.orig Sat Sep 6 17:08:49 2003
-+++ build/unix/build.config Sun Sep 14 06:19:47 2003
-@@ -2,7 +2,6 @@
-
- # Include build functions used here
- . build/unix/config_functions
--. build/unix/menu_functions
- . build/unix/ansi
-
-
-@@ -37,168 +36,24 @@
- define_have_header getopt.h
-
-
--# Describe the menu:
--MENU_main_ITEMS="debug graphics sound ioformat install_path"
--MENU_main_TITLE="Main menu"
--MENU_main_ITEM_debug_TYPE=CHOICE
--MENU_main_ITEM_graphics_TYPE=CHOICE
--MENU_main_ITEM_sound_TYPE=CHOICE
--MENU_main_ITEM_ioformat_TYPE=CHOICE
--MENU_main_ITEM_link_TYPE=CHOICE
--MENU_main_ITEM_install_path_TYPE=MENU
--
--CHOICE_debug_OPTIONS="nodebug debug strictdebug"
--CHOICE_debug_TITLE="Include debugging information"
--CHOICE_debug_OPTION_nodebug_TITLE="No debugging information"
--CHOICE_debug_OPTION_nodebug_ACTION='nodebug_action'
--nodebug_action() {
-- CFLAGS="$CFLAGS -O3"
-- DEBUG=0
--}
--CHOICE_debug_OPTION_debug_TITLE="Debugging information"
--CHOICE_debug_OPTION_debug_ACTION='debug_action'
--debug_action() {
-- CFLAGS="$CFLAGS -g -O0 -W -Wall"
-- CFLAGS="$CFLAGS -DDEBUG_TRACK_SEM" # enable semaphore deugging
-- LDFLAGS="$LDFLAGS -O0"
-- DEBUG=1
--}
--CHOICE_debug_OPTION_strictdebug_TITLE="Debug info + strict compile checks"
--CHOICE_debug_OPTION_strictdebug_ACTION='strictdebug_action'
--strictdebug_action() {
-- CFLAGS="$CFLAGS -O1" # This is needed for -Wunitialized
-- CFLAGS="$CFLAGS -DDEBUG_TRACK_SEM" # enable semaphore debugging
-- CFLAGS="$CFLAGS -W -Wall \
-- -Wbad-function-cast -Wcast-qual -Wmissing-prototypes \
-- -Wstrict-prototypes -Wmissing-declarations \
-- -Wwrite-strings -Wimplicit -Wreturn-type -Wformat \
-- -Wswitch -Wcomment -Wchar-subscripts \
-- -Wparentheses -Wcast-align -Waggregate-return \
-- -Winline -Wuninitialized"
--# CFLAGS="$CFLAGS "-Wpointer-arith"
-- # Some standard header won't even compile with this on
--# CFLAGS="$CFLAGS -Wshadow"
-- # This gives absurd conflicts with standard files,
-- # like from 'y2'
--# CFLAGS="$CFLAGS -Werror"
-- # We shouldn't do this until we actually nail them
-- # all in the original code. Then we can enforce them
-- # on ourselves.
--# CFLAGS="$CFLAGS -pedantic-errors -ansi -trigraphs" # ANSI
--# CFLAGS="$CFLAGS -Wnested-externs"
-- # We know they're in the code, and though we'd like to get
-- # rid of them, they're not bugs.
-- CFLAGS=`echo $CFLAGS`
-- # Remove all the unnecessary spaces from $CFLAGS,
-- # for more readable messages.
-- DEBUG=0
--}
--CHOICE_debug_DEFAULT=debug
--
--CHOICE_graphics_OPTIONS="pure opengl"
--CHOICE_graphics_TITLE="OpenGL graphics support"
--CHOICE_graphics_OPTION_pure_TITLE="Don't include OpenGL graphics support"
--CHOICE_graphics_OPTION_pure_ACTION='graphics_pure_action'
--graphics_pure_action() {
-- CFLAGS="$CFLAGS -DGFXMODULE_SDL"
-- HAVE_OPENGL=0
--}
--CHOICE_graphics_OPTION_opengl_TITLE="Include OpenGL graphics support"
--CHOICE_graphics_OPTION_opengl_ACTION='graphics_opengl_action'
--CHOICE_graphics_OPTION_opengl_PRECOND="have_library opengl"
--graphics_opengl_action() {
-- CFLAGS="$CFLAGS -DGFXMODULE_SDL -DHAVE_OPENGL"
-- HAVE_OPENGL=1
-- use_library opengl
--}
--CHOICE_graphics_DEFAULT=opengl
--
--CHOICE_sound_OPTIONS="mixsdl openal"
--CHOICE_sound_TITLE="Sound backend"
--CHOICE_sound_OPTION_mixsdl_TITLE="Use MixSDL for sound (internal)"
--CHOICE_sound_OPTION_mixsdl_ACTION=sound_mixsdl_action
--sound_mixsdl_action() {
-- CFLAGS="$CFLAGS -DSOUNDMODULE_SDL"
-- SOUNDMODULE=mixsdl
-- use_library vorbisfile
--# use_library vorbis
--}
--CHOICE_sound_OPTION_openal_TITLE="Include OpenAL support (experimental)"
--CHOICE_sound_OPTION_openal_PRECOND="have_library openal"
--CHOICE_sound_OPTION_openal_ACTION=sound_openal_action
--sound_openal_action() {
-- CFLAGS="$CFLAGS -DHAVE_OPENAL -DSOUNDMODULE_SDL"
-- SOUNDMODULE=openal
-- use_library openal
-- use_library vorbisfile
--# use_library vorbis
--}
--CHOICE_sound_DEFAULT=mixsdl
--
--CHOICE_ioformat_OPTIONS="stdio stdio_zip"
--CHOICE_ioformat_TITLE="Supported file i/o methods"
--CHOICE_ioformat_OPTION_stdio_TITLE="Only direct file i/o"
--CHOICE_ioformat_OPTION_stdio_zip_TITLE="Direct & .zip file i/o"
--CHOICE_ioformat_OPTION_stdio_zip_PRECOND="have_library zlib"
--CHOICE_ioformat_OPTION_stdio_zip_ACTION="ioformat_stdio_zip_action"
--ioformat_stdio_zip_action() {
-- CFLAGS="$CFLAGS -DHAVE_ZIP=1"
-- USE_ZIP_IO=1
-- use_library zlib
--}
--CHOICE_ioformat_DEFAULT=stdio_zip
--
--# Making static binaries is more complicated than this.
--# For now, it will have to be done by hand.
--#CHOICE_link_OPTIONS="static dynamic"
--#CHOICE_link_TITLE="Linking"
--#CHOICE_link_OPTION_static_TITLE="Statically linked libraries"
--#CHOICE_link_OPTION_static_ACTION='eval LDFLAGS="$LDFLAGS -static"'
--#CHOICE_link_OPTION_dynamic_TITLE="Dynamically linked libraries"
--#CHOICE_link_DEFAULT=dynamic
--
--MENU_install_path_ITEMS="install_prefix install_bindir install_libdir \
-- install_sharedir"
--MENU_install_path_TITLE="Installation paths"
--MENU_install_path_ITEM_install_prefix_TYPE=INPUT
--MENU_install_path_ITEM_install_bindir_TYPE=INPUT
--MENU_install_path_ITEM_install_libdir_TYPE=INPUT
--MENU_install_path_ITEM_install_sharedir_TYPE=INPUT
--
--INPUT_install_prefix_DEFAULT="/usr/local/games"
--INPUT_install_prefix_TITLE="Installation prefix"
--INPUT_install_prefix_VALIDATOR=validate_path
--INPUT_install_prefix_ACTION='eval INSTALL_PREFIX=$MENU_install_prefix_VALUE'
--
--INPUT_install_bindir_DEFAULT='$prefix/bin'
--INPUT_install_bindir_TITLE="Location for binaries"
--INPUT_install_bindir_VALIDATOR=validate_path
--
--INPUT_install_libdir_DEFAULT='$prefix/lib'
--INPUT_install_libdir_TITLE="Location for non-sharable data"
--INPUT_install_libdir_VALIDATOR=validate_path
--
--INPUT_install_sharedir_DEFAULT='$prefix/share'
--INPUT_install_sharedir_TITLE="Location for sharable data"
--INPUT_install_sharedir_VALIDATOR=validate_path
--
--
--# Show the menu and let people set things
--do_menu MENU main config.state
--echo "Configuration complete."
--
--# Set INSTALL_LIBDIR, INSTALL_BINDIR, and INSTALL_SHAREDIR to the specified
--# values, replacing '$prefix' to the prefix set.
--prefix="$INPUT_install_prefix_VALUE" \
-- eval INSTALL_BINDIR="${INPUT_install_bindir_VALUE%/}/"
--prefix="$INPUT_install_prefix_VALUE" \
-- eval INSTALL_LIBDIR="${INPUT_install_libdir_VALUE%/}/"
--prefix="$INPUT_install_prefix_VALUE" \
-- eval INSTALL_SHAREDIR="${INPUT_install_sharedir_VALUE%/}/"
-+CFLAGS="$CFLAGS -O3"
-+DEBUG=0
-+CFLAGS="$CFLAGS -DGFXMODULE_SDL -DHAVE_OPENGL"
-+HAVE_OPENGL=1
-+use_library opengl
-+CFLAGS="$CFLAGS -DSOUNDMODULE_SDL"
-+SOUNDMODULE=mixsdl
-+use_library vorbisfile
-+CFLAGS="$CFLAGS -DHAVE_ZIP=1"
-+USE_ZIP_IO=1
-+use_library zlib
-+
-+INSTALL_BINDIR=${PREFIX}/bin/
-+INSTALL_LIBDIR=${PREFIX}/lib/
-+INSTALL_SHAREDIR=${PREFIX}/share/
-
- # Set the content dir
- CONTENTDIR="${INSTALL_SHAREDIR}uqm/content"
--
-
- # Export the HAVE_ symbols to config.h, using config.h.in as template
- SUBSTITUTE_VARS="$HAVE_SYMBOLS CONTENTDIR"
diff --git a/games/uqm/files/patch-build::unix::config_proginfo b/games/uqm/files/patch-build::unix::config_proginfo
deleted file mode 100644
index cf02eab72ede..000000000000
--- a/games/uqm/files/patch-build::unix::config_proginfo
+++ /dev/null
@@ -1,22 +0,0 @@
---- build/unix/config_proginfo.orig Sun Sep 28 05:11:09 2003
-+++ build/unix/config_proginfo Sun Sep 28 05:12:25 2003
-@@ -80,7 +80,7 @@
- LIB_openal_NAME="OpenAL"
- LIB_openal_CFLAGS=""
- case "$OSNAME" in
-- FreeBSD|OpenBSD) LIB_openal_LDFLAGS="-L/usr/local/lib -pthread -lopenal" ;;
-+ FreeBSD|OpenBSD) LIB_openal_LDFLAGS="-L${LOCALBASE}/lib -pthread -lopenal" ;;
- MINGW32*) LIB_openal_LDFLAGS="-lopenal32" ;;
- *) LIB_openal_LDFLAGS="-lopenal" ;;
- esac
-@@ -115,8 +115,8 @@
- LIB_vorbisfile_NAME="Vorbisfile"
- case "$OSNAME" in
- FreeBSD|OpenBSD)
-- LIB_vorbisfile_CFLAGS="-I/usr/local/include"
-- LIB_vorbisfile_LDFLAGS="-L/usr/local/lib -lvorbisfile -lvorbis"
-+ LIB_vorbisfile_CFLAGS="-I${LOCALBASE}/include"
-+ LIB_vorbisfile_LDFLAGS="-L${LOCALBASE}/lib -lvorbisfile -lvorbis"
- ;;
- QNX)
- LIB_vorbisfile_CFLAGS=""
diff --git a/games/uqm/pkg-plist b/games/uqm/pkg-plist
index b5f356c63e63..57c4e2be6ee1 100644
--- a/games/uqm/pkg-plist
+++ b/games/uqm/pkg-plist
@@ -1,12 +1,9 @@
bin/uqm
lib/uqm/uqm
-share/uqm/content/packages/uqm-0.3-content.zip
+share/uqm/content/packages/uqm-0.4.0-content.uqm
share/uqm/content/version
-%%VOICEADDON%%share/uqm/content/packages/addons/voice/uqm-0.3-voice.zip
-%%MUSICADDON%%share/uqm/content/packages/addons/3domusic/uqm-0.3-3domusic.zip
-%%VOICEADDON%%@dirrm share/uqm/content/packages/addons/voice
-%%MUSICADDON%%@dirrm share/uqm/content/packages/addons/3domusic
-@dirrm share/uqm/content/packages/addons
+%%VOICEADDON%%share/uqm/content/packages/uqm-0.4.0-voice.uqm
+%%MUSICADDON%%share/uqm/content/packages/uqm-0.4.0-3domusic.uqm
@dirrm share/uqm/content/packages
@dirrm share/uqm/content
@dirrm share/uqm