aboutsummaryrefslogtreecommitdiff
path: root/games/uqm
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-09-28 12:18:48 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-09-28 12:18:48 +0000
commitc8b6a7a73301c43f8d446bcfbc8a5a89847e3f20 (patch)
treedf124b9076bad0f0d0154f3cdc9c9b08ab552747 /games/uqm
parentba9ce94349b67e6287559b3449e72dc3c6b83715 (diff)
downloadports-c8b6a7a73301c43f8d446bcfbc8a5a89847e3f20.tar.gz
ports-c8b6a7a73301c43f8d446bcfbc8a5a89847e3f20.zip
New Port: games/uqm, Ur-Quan Masters
Ur-Quan Masters is a port of the original Star Control 2 for 3DO Consoles. WWW: http://sc2.sourceforge.net PR: ports/56763 Submitted by: Benjamin Lutz <benlutz@datacomm.ch>
Notes
Notes: svn path=/head/; revision=89664
Diffstat (limited to 'games/uqm')
-rw-r--r--games/uqm/Makefile48
-rw-r--r--games/uqm/distinfo2
-rw-r--r--games/uqm/files/patch-build::unix::build.config194
-rw-r--r--games/uqm/files/patch-build::unix::config_proginfo22
-rw-r--r--games/uqm/pkg-descr9
-rw-r--r--games/uqm/pkg-plist11
6 files changed, 286 insertions, 0 deletions
diff --git a/games/uqm/Makefile b/games/uqm/Makefile
new file mode 100644
index 000000000000..a2e4735283b8
--- /dev/null
+++ b/games/uqm/Makefile
@@ -0,0 +1,48 @@
+# Ports collection makefile for: uqm
+# Date created: 14 September 2003
+# Whom: asami
+#
+# $FreeBSD$
+#
+
+PORTNAME= uqm
+PORTVERSION= 0.3
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=sc2
+DISTFILES= ${PORTNAME}-${PORTVERSION}-source.tgz ${PORTNAME}-${PORTVERSION}-content.zip
+EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}-source.tgz
+
+MAINTAINER= benlutz@datacomm.ch
+COMMENT= A port of the original Star Control 2 for 3DO consoles
+
+LIB_DEPENDS= SDL_image:${PORTSDIR}/graphics/sdl_image \
+ SDL_mixer:${PORTSDIR}/audio/sdl_mixer \
+ vorbis:${PORTSDIR}/audio/libvorbis \
+ ogg:${PORTSDIR}/audio/libogg
+
+USE_XLIB= yes
+USE_GMAKE= yes
+USE_SDL= yes
+NO_INSTALL_MANPAGES=yes
+
+post-extract:
+ ${CP} ${DISTDIR}/${PORTNAME}-${PORTVERSION}-content.zip ${WRKSRC}/content/packages/
+
+do-configure:
+ cd ${WRKSRC} && ${SETENV} PREFIX=${PREFIX} ./build.sh uqm config
+
+do-build:
+ cd ${WRKSRC} && ./build.sh uqm
+
+do-install:
+ cd ${WRKSRC} && ./build.sh uqm install
+
+post-install:
+ ${STRIP_CMD} ${PREFIX}/lib/uqm/uqm
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/doc/users/manual.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/uqm/distinfo b/games/uqm/distinfo
new file mode 100644
index 000000000000..ec4cea216c55
--- /dev/null
+++ b/games/uqm/distinfo
@@ -0,0 +1,2 @@
+MD5 (uqm-0.3-source.tgz) = 6abcdc3caf7efd3bd978332743ee7568
+MD5 (uqm-0.3-content.zip) = b17bb7b54df03b2d0ae3a23b91382b27
diff --git a/games/uqm/files/patch-build::unix::build.config b/games/uqm/files/patch-build::unix::build.config
new file mode 100644
index 000000000000..b1b7ee165ff0
--- /dev/null
+++ b/games/uqm/files/patch-build::unix::build.config
@@ -0,0 +1,194 @@
+--- build/unix/build.config.orig Sat Sep 6 17:08:49 2003
++++ build/unix/build.config Sun Sep 14 06:19:47 2003
+@@ -2,7 +2,6 @@
+
+ # Include build functions used here
+ . build/unix/config_functions
+-. build/unix/menu_functions
+ . build/unix/ansi
+
+
+@@ -37,168 +36,24 @@
+ define_have_header getopt.h
+
+
+-# Describe the menu:
+-MENU_main_ITEMS="debug graphics sound ioformat install_path"
+-MENU_main_TITLE="Main menu"
+-MENU_main_ITEM_debug_TYPE=CHOICE
+-MENU_main_ITEM_graphics_TYPE=CHOICE
+-MENU_main_ITEM_sound_TYPE=CHOICE
+-MENU_main_ITEM_ioformat_TYPE=CHOICE
+-MENU_main_ITEM_link_TYPE=CHOICE
+-MENU_main_ITEM_install_path_TYPE=MENU
+-
+-CHOICE_debug_OPTIONS="nodebug debug strictdebug"
+-CHOICE_debug_TITLE="Include debugging information"
+-CHOICE_debug_OPTION_nodebug_TITLE="No debugging information"
+-CHOICE_debug_OPTION_nodebug_ACTION='nodebug_action'
+-nodebug_action() {
+- CFLAGS="$CFLAGS -O3"
+- DEBUG=0
+-}
+-CHOICE_debug_OPTION_debug_TITLE="Debugging information"
+-CHOICE_debug_OPTION_debug_ACTION='debug_action'
+-debug_action() {
+- CFLAGS="$CFLAGS -g -O0 -W -Wall"
+- CFLAGS="$CFLAGS -DDEBUG_TRACK_SEM" # enable semaphore deugging
+- LDFLAGS="$LDFLAGS -O0"
+- DEBUG=1
+-}
+-CHOICE_debug_OPTION_strictdebug_TITLE="Debug info + strict compile checks"
+-CHOICE_debug_OPTION_strictdebug_ACTION='strictdebug_action'
+-strictdebug_action() {
+- CFLAGS="$CFLAGS -O1" # This is needed for -Wunitialized
+- CFLAGS="$CFLAGS -DDEBUG_TRACK_SEM" # enable semaphore debugging
+- CFLAGS="$CFLAGS -W -Wall \
+- -Wbad-function-cast -Wcast-qual -Wmissing-prototypes \
+- -Wstrict-prototypes -Wmissing-declarations \
+- -Wwrite-strings -Wimplicit -Wreturn-type -Wformat \
+- -Wswitch -Wcomment -Wchar-subscripts \
+- -Wparentheses -Wcast-align -Waggregate-return \
+- -Winline -Wuninitialized"
+-# CFLAGS="$CFLAGS "-Wpointer-arith"
+- # Some standard header won't even compile with this on
+-# CFLAGS="$CFLAGS -Wshadow"
+- # This gives absurd conflicts with standard files,
+- # like from 'y2'
+-# CFLAGS="$CFLAGS -Werror"
+- # We shouldn't do this until we actually nail them
+- # all in the original code. Then we can enforce them
+- # on ourselves.
+-# CFLAGS="$CFLAGS -pedantic-errors -ansi -trigraphs" # ANSI
+-# CFLAGS="$CFLAGS -Wnested-externs"
+- # We know they're in the code, and though we'd like to get
+- # rid of them, they're not bugs.
+- CFLAGS=`echo $CFLAGS`
+- # Remove all the unnecessary spaces from $CFLAGS,
+- # for more readable messages.
+- DEBUG=0
+-}
+-CHOICE_debug_DEFAULT=debug
+-
+-CHOICE_graphics_OPTIONS="pure opengl"
+-CHOICE_graphics_TITLE="OpenGL graphics support"
+-CHOICE_graphics_OPTION_pure_TITLE="Don't include OpenGL graphics support"
+-CHOICE_graphics_OPTION_pure_ACTION='graphics_pure_action'
+-graphics_pure_action() {
+- CFLAGS="$CFLAGS -DGFXMODULE_SDL"
+- HAVE_OPENGL=0
+-}
+-CHOICE_graphics_OPTION_opengl_TITLE="Include OpenGL graphics support"
+-CHOICE_graphics_OPTION_opengl_ACTION='graphics_opengl_action'
+-CHOICE_graphics_OPTION_opengl_PRECOND="have_library opengl"
+-graphics_opengl_action() {
+- CFLAGS="$CFLAGS -DGFXMODULE_SDL -DHAVE_OPENGL"
+- HAVE_OPENGL=1
+- use_library opengl
+-}
+-CHOICE_graphics_DEFAULT=opengl
+-
+-CHOICE_sound_OPTIONS="mixsdl openal"
+-CHOICE_sound_TITLE="Sound backend"
+-CHOICE_sound_OPTION_mixsdl_TITLE="Use MixSDL for sound (internal)"
+-CHOICE_sound_OPTION_mixsdl_ACTION=sound_mixsdl_action
+-sound_mixsdl_action() {
+- CFLAGS="$CFLAGS -DSOUNDMODULE_SDL"
+- SOUNDMODULE=mixsdl
+- use_library vorbisfile
+-# use_library vorbis
+-}
+-CHOICE_sound_OPTION_openal_TITLE="Include OpenAL support (experimental)"
+-CHOICE_sound_OPTION_openal_PRECOND="have_library openal"
+-CHOICE_sound_OPTION_openal_ACTION=sound_openal_action
+-sound_openal_action() {
+- CFLAGS="$CFLAGS -DHAVE_OPENAL -DSOUNDMODULE_SDL"
+- SOUNDMODULE=openal
+- use_library openal
+- use_library vorbisfile
+-# use_library vorbis
+-}
+-CHOICE_sound_DEFAULT=mixsdl
+-
+-CHOICE_ioformat_OPTIONS="stdio stdio_zip"
+-CHOICE_ioformat_TITLE="Supported file i/o methods"
+-CHOICE_ioformat_OPTION_stdio_TITLE="Only direct file i/o"
+-CHOICE_ioformat_OPTION_stdio_zip_TITLE="Direct & .zip file i/o"
+-CHOICE_ioformat_OPTION_stdio_zip_PRECOND="have_library zlib"
+-CHOICE_ioformat_OPTION_stdio_zip_ACTION="ioformat_stdio_zip_action"
+-ioformat_stdio_zip_action() {
+- CFLAGS="$CFLAGS -DHAVE_ZIP=1"
+- USE_ZIP_IO=1
+- use_library zlib
+-}
+-CHOICE_ioformat_DEFAULT=stdio_zip
+-
+-# Making static binaries is more complicated than this.
+-# For now, it will have to be done by hand.
+-#CHOICE_link_OPTIONS="static dynamic"
+-#CHOICE_link_TITLE="Linking"
+-#CHOICE_link_OPTION_static_TITLE="Statically linked libraries"
+-#CHOICE_link_OPTION_static_ACTION='eval LDFLAGS="$LDFLAGS -static"'
+-#CHOICE_link_OPTION_dynamic_TITLE="Dynamically linked libraries"
+-#CHOICE_link_DEFAULT=dynamic
+-
+-MENU_install_path_ITEMS="install_prefix install_bindir install_libdir \
+- install_sharedir"
+-MENU_install_path_TITLE="Installation paths"
+-MENU_install_path_ITEM_install_prefix_TYPE=INPUT
+-MENU_install_path_ITEM_install_bindir_TYPE=INPUT
+-MENU_install_path_ITEM_install_libdir_TYPE=INPUT
+-MENU_install_path_ITEM_install_sharedir_TYPE=INPUT
+-
+-INPUT_install_prefix_DEFAULT="/usr/local/games"
+-INPUT_install_prefix_TITLE="Installation prefix"
+-INPUT_install_prefix_VALIDATOR=validate_path
+-INPUT_install_prefix_ACTION='eval INSTALL_PREFIX=$MENU_install_prefix_VALUE'
+-
+-INPUT_install_bindir_DEFAULT='$prefix/bin'
+-INPUT_install_bindir_TITLE="Location for binaries"
+-INPUT_install_bindir_VALIDATOR=validate_path
+-
+-INPUT_install_libdir_DEFAULT='$prefix/lib'
+-INPUT_install_libdir_TITLE="Location for non-sharable data"
+-INPUT_install_libdir_VALIDATOR=validate_path
+-
+-INPUT_install_sharedir_DEFAULT='$prefix/share'
+-INPUT_install_sharedir_TITLE="Location for sharable data"
+-INPUT_install_sharedir_VALIDATOR=validate_path
+-
+-
+-# Show the menu and let people set things
+-do_menu MENU main config.state
+-echo "Configuration complete."
+-
+-# Set INSTALL_LIBDIR, INSTALL_BINDIR, and INSTALL_SHAREDIR to the specified
+-# values, replacing '$prefix' to the prefix set.
+-prefix="$INPUT_install_prefix_VALUE" \
+- eval INSTALL_BINDIR="${INPUT_install_bindir_VALUE%/}/"
+-prefix="$INPUT_install_prefix_VALUE" \
+- eval INSTALL_LIBDIR="${INPUT_install_libdir_VALUE%/}/"
+-prefix="$INPUT_install_prefix_VALUE" \
+- eval INSTALL_SHAREDIR="${INPUT_install_sharedir_VALUE%/}/"
++CFLAGS="$CFLAGS -O3"
++DEBUG=0
++CFLAGS="$CFLAGS -DGFXMODULE_SDL -DHAVE_OPENGL"
++HAVE_OPENGL=1
++use_library opengl
++CFLAGS="$CFLAGS -DSOUNDMODULE_SDL"
++SOUNDMODULE=mixsdl
++use_library vorbisfile
++CFLAGS="$CFLAGS -DHAVE_ZIP=1"
++USE_ZIP_IO=1
++use_library zlib
++
++INSTALL_BINDIR=${PREFIX}/bin/
++INSTALL_LIBDIR=${PREFIX}/lib/
++INSTALL_SHAREDIR=${PREFIX}/share/
+
+ # Set the content dir
+ CONTENTDIR="${INSTALL_SHAREDIR}uqm/content"
+-
+
+ # Export the HAVE_ symbols to config.h, using config.h.in as template
+ SUBSTITUTE_VARS="$HAVE_SYMBOLS CONTENTDIR"
diff --git a/games/uqm/files/patch-build::unix::config_proginfo b/games/uqm/files/patch-build::unix::config_proginfo
new file mode 100644
index 000000000000..cf02eab72ede
--- /dev/null
+++ b/games/uqm/files/patch-build::unix::config_proginfo
@@ -0,0 +1,22 @@
+--- build/unix/config_proginfo.orig Sun Sep 28 05:11:09 2003
++++ build/unix/config_proginfo Sun Sep 28 05:12:25 2003
+@@ -80,7 +80,7 @@
+ LIB_openal_NAME="OpenAL"
+ LIB_openal_CFLAGS=""
+ case "$OSNAME" in
+- FreeBSD|OpenBSD) LIB_openal_LDFLAGS="-L/usr/local/lib -pthread -lopenal" ;;
++ FreeBSD|OpenBSD) LIB_openal_LDFLAGS="-L${LOCALBASE}/lib -pthread -lopenal" ;;
+ MINGW32*) LIB_openal_LDFLAGS="-lopenal32" ;;
+ *) LIB_openal_LDFLAGS="-lopenal" ;;
+ esac
+@@ -115,8 +115,8 @@
+ LIB_vorbisfile_NAME="Vorbisfile"
+ case "$OSNAME" in
+ FreeBSD|OpenBSD)
+- LIB_vorbisfile_CFLAGS="-I/usr/local/include"
+- LIB_vorbisfile_LDFLAGS="-L/usr/local/lib -lvorbisfile -lvorbis"
++ LIB_vorbisfile_CFLAGS="-I${LOCALBASE}/include"
++ LIB_vorbisfile_LDFLAGS="-L${LOCALBASE}/lib -lvorbisfile -lvorbis"
+ ;;
+ QNX)
+ LIB_vorbisfile_CFLAGS=""
diff --git a/games/uqm/pkg-descr b/games/uqm/pkg-descr
new file mode 100644
index 000000000000..ddc7224df106
--- /dev/null
+++ b/games/uqm/pkg-descr
@@ -0,0 +1,9 @@
+Ur-Quan Masters is a port of the original Star Control 2 for 3DO Consoles.
+
+The project started in August 2002, when Toys For Bob released the partially
+ported sources of Star Control 2 3DO version to the fan community. Our goal
+is to port this wonderful game to current personal computers and operating
+systems. It is and will remain 100% free of charge, and anyone can contribute
+to the project and thus help make it even better.
+
+WWW: http://sc2.sourceforge.net
diff --git a/games/uqm/pkg-plist b/games/uqm/pkg-plist
new file mode 100644
index 000000000000..b0664f04dea4
--- /dev/null
+++ b/games/uqm/pkg-plist
@@ -0,0 +1,11 @@
+bin/uqm
+lib/uqm/uqm
+share/uqm/content/packages/uqm-0.3-content.zip
+share/uqm/content/version
+@dirrm share/uqm/content/packages/addons
+@dirrm share/uqm/content/packages
+@dirrm share/uqm/content
+@dirrm share/uqm
+@dirrm lib/uqm
+%%PORTDOCS%%%%DOCSDIR%%/manual.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%