aboutsummaryrefslogtreecommitdiff
path: root/games/valyriatear
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2019-04-07 16:31:11 +0000
committerMark Linimon <linimon@FreeBSD.org>2019-04-07 16:31:11 +0000
commit51c01a81b78af3e8323121d9f4e713ec78cc071b (patch)
treed93bf5291432c38976c97edb19b8a75ce72b2709 /games/valyriatear
parentff478a51c648e963455cb159c1dcf8561221e9ff (diff)
downloadports-51c01a81b78af3e8323121d9f4e713ec78cc071b.tar.gz
ports-51c01a81b78af3e8323121d9f4e713ec78cc071b.zip
Fix build on GCC-based architectures by setting -Wno-reserved-user-defined-literal
only for clang. While here, pet portlint (add 'gl' to USES). Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=498288
Diffstat (limited to 'games/valyriatear')
-rw-r--r--games/valyriatear/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/games/valyriatear/Makefile b/games/valyriatear/Makefile
index 540b594b40b3..dfb6debff79b 100644
--- a/games/valyriatear/Makefile
+++ b/games/valyriatear/Makefile
@@ -23,7 +23,8 @@ GH_ACCOUNT= Bertram25
GH_PROJECT= ValyriaTear
GH_TAGNAME= ${PORTVERSION}-gcc5 # contains relevant tolua++ fixes
-USES= alias cmake gettext-tools iconv lua:51 openal
+USES= alias cmake compiler gettext-tools gl iconv lua:51 \
+ openal
CMAKE_ARGS= -DUSE_PCH_COMPILATION=OFF
USE_SDL= sdl image ttf
USE_GL= gl glu
@@ -31,7 +32,8 @@ USE_XORG= x11 xext sm ice
INSTALLS_ICONS= yes
LLD_UNSAFE= yes
-CXXFLAGS+= -Wno-reserved-user-defined-literal
+CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
+CXXFLAGS_clang= -Wno-reserved-user-defined-literal
PORTDOCS= *
PORTDATA= *