aboutsummaryrefslogtreecommitdiff
path: root/games/vavoom
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-03-19 14:36:54 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-03-19 14:36:54 +0000
commit0cb9c80bab8dd4b70ca3bb9500acf770de7faa85 (patch)
tree3d9fd5b19a9bec8b689333a48e66659e7e33ceb6 /games/vavoom
parent04e1309c57b0669b6c48185c8ca220c4ef96528b (diff)
downloadports-0cb9c80bab8dd4b70ca3bb9500acf770de7faa85.tar.gz
ports-0cb9c80bab8dd4b70ca3bb9500acf770de7faa85.zip
Add some patches to properly declare dependencies between targets.
The upcoming CMake 3.5.0 ends up generating Makefiles that cause much more problems in parallel builds when the dependencies are not declared correctly. This also allows us to get rid of MAKE_JOBS_UNSAFE. PR: 208033
Notes
Notes: svn path=/head/; revision=411404
Diffstat (limited to 'games/vavoom')
-rw-r--r--games/vavoom/Makefile2
-rw-r--r--games/vavoom/files/patch-progs_common_CMakeLists.txt8
-rw-r--r--games/vavoom/files/patch-source_CMakeLists.txt20
3 files changed, 28 insertions, 2 deletions
diff --git a/games/vavoom/Makefile b/games/vavoom/Makefile
index 8018594464c3..ceedd9b77b5f 100644
--- a/games/vavoom/Makefile
+++ b/games/vavoom/Makefile
@@ -17,8 +17,6 @@ LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
USES= cmake dos2unix jpeg tar:bzip2
DOS2UNIX_REGEX= ((.*\.(c|cpp|h|s|asm|inc|vc|ls|acs|cfg|txt|vs|mak|mgw"))$$|\/(makefile\..*|makefile|Makefile)$$)
-MAKE_JOBS_UNSAFE= yes
-
OPTIONS_DEFINE= FLAC LAUNCHER MAD MIKMOD OPENAL OPTIMIZED_CFLAGS VORBIS SDL DOCS
OPTIONS_DEFAULT= OPENGL SDL
LAUNCHER_DESC= Build GUI launcher
diff --git a/games/vavoom/files/patch-progs_common_CMakeLists.txt b/games/vavoom/files/patch-progs_common_CMakeLists.txt
new file mode 100644
index 000000000000..bc3a96e167e0
--- /dev/null
+++ b/games/vavoom/files/patch-progs_common_CMakeLists.txt
@@ -0,0 +1,8 @@
+--- progs/common/CMakeLists.txt.orig 2016-03-16 16:45:41 UTC
++++ progs/common/CMakeLists.txt
+@@ -17,4 +17,4 @@ add_custom_command(OUTPUT ${OUTDIR}/uiba
+ COMMAND ${VCC} ARGS -P${OUTDIR} ${CMAKE_CURRENT_SOURCE_DIR}/uibase/classes.vc ${OUTDIR}/uibase.dat
+ DEPENDS vcc uibase/*.vc ${OUTDIR}/engine.dat)
+ add_custom_target(uibase ALL DEPENDS ${OUTDIR}/uibase.dat)
+-add_dependencies(uibase vcc engine)
++add_dependencies(uibase vcc engine linespec)
diff --git a/games/vavoom/files/patch-source_CMakeLists.txt b/games/vavoom/files/patch-source_CMakeLists.txt
new file mode 100644
index 000000000000..bc3fdde4b344
--- /dev/null
+++ b/games/vavoom/files/patch-source_CMakeLists.txt
@@ -0,0 +1,20 @@
+--- source/CMakeLists.txt.orig 2016-03-16 16:43:57 UTC
++++ source/CMakeLists.txt
+@@ -790,7 +790,7 @@ if (MAIN_COMPILE_FLAGS)
+ set_target_properties(vavoom PROPERTIES COMPILE_FLAGS ${MAIN_COMPILE_FLAGS})
+ endif (MAIN_COMPILE_FLAGS)
+ target_link_libraries(vavoom ${MAIN_LIBS})
+-add_dependencies(vavoom core timidity glbsp libglvis)
++add_dependencies(vavoom core timidity glbsp libglvis revision_check)
+
+ install(TARGETS vavoom DESTINATION ${BINDIR})
+
+@@ -845,7 +845,7 @@ else(ENABLE_WRAPPERS)
+ endif(ENABLE_WRAPPERS)
+ set_target_properties(vavoom-dedicated PROPERTIES COMPILE_FLAGS -DSERVER)
+ target_link_libraries(vavoom-dedicated glbsp core ${ZLIB_LIBRARY} ${NET_LIBRARIES})
+-add_dependencies(vavoom-dedicated core glbsp)
++add_dependencies(vavoom-dedicated core glbsp revision_check)
+
+ install(TARGETS vavoom-dedicated DESTINATION ${BINDIR})
+