aboutsummaryrefslogtreecommitdiff
path: root/games/vavoom
diff options
context:
space:
mode:
authorBarbara Guida <bar@FreeBSD.org>2017-04-06 20:14:21 +0000
committerBarbara Guida <bar@FreeBSD.org>2017-04-06 20:14:21 +0000
commit1e8d0f91a6a5559f26f154730092fce8a7d43919 (patch)
treeaac28a7879e1a099ff70df513453fd4b3be8788b /games/vavoom
parent9cc5b64688e960ee402f8d9f657d094e90cc12f5 (diff)
downloadports-1e8d0f91a6a5559f26f154730092fce8a7d43919.tar.gz
ports-1e8d0f91a6a5559f26f154730092fce8a7d43919.zip
- USE_GCC because llvm (starting from llvm40) generates not working binary for vcc causing failure during the build
- Remove the LAUNCHER option because current GCC generates not working binary for vlaunch - Modernize OPTIONS
Notes
Notes: svn path=/head/; revision=437875
Diffstat (limited to 'games/vavoom')
-rw-r--r--games/vavoom/Makefile96
-rw-r--r--games/vavoom/files/patch-utils_vlaunch_vlaunch.cpp (renamed from games/vavoom/files/patch-utils__vlaunch__vlaunch.cpp)2
-rw-r--r--games/vavoom/files/pkg-message.in5
-rw-r--r--games/vavoom/pkg-plist2
4 files changed, 43 insertions, 62 deletions
diff --git a/games/vavoom/Makefile b/games/vavoom/Makefile
index e491a34febe7..79e1ca325781 100644
--- a/games/vavoom/Makefile
+++ b/games/vavoom/Makefile
@@ -3,7 +3,7 @@
PORTNAME= vavoom
PORTVERSION= 1.33
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/Vavoom-source/${PORTVERSION}
@@ -15,85 +15,63 @@ LICENSE= GPLv2
LIB_DEPENDS= libpng.so:graphics/png
USES= cmake dos2unix jpeg tar:bzip2
+# Force GCC because llvm (starting from 4.0) generates
+# non working binary for vcc
+USE_GCC= yes
DOS2UNIX_REGEX= ((.*\.(c|cpp|h|s|asm|inc|vc|ls|acs|cfg|txt|vs|mak|mgw"))$$|\/(makefile\..*|makefile|Makefile)$$)
-OPTIONS_DEFINE= FLAC LAUNCHER MAD MIKMOD OPENAL OPTIMIZED_CFLAGS VORBIS SDL DOCS
+# Removed LAUNCHER because it segfaults
+#OPTIONS_DEFINE= FLAC LAUNCHER MAD MIKMOD OPENAL OPTIMIZED_CFLAGS VORBIS SDL DOCS
+OPTIONS_DEFINE= FLAC MAD MIKMOD OPENAL OPTIMIZED_CFLAGS VORBIS SDL DOCS
OPTIONS_DEFAULT= OPENGL SDL
-LAUNCHER_DESC= Build GUI launcher
+#LAUNCHER_DESC= Build GUI launcher
OPENAL_DESC= Enable OpenAL support
SDL_DESC= Use SDL for OpenGL support
SUB_FILES= pkg-message
-.include <bsd.port.options.mk>
-
# The `-fno-strict-aliasing' flag (default on FreeBSD 6.0+) produces
# non-working code for `vcc', so we remove it here if present.
CFLAGS:= ${CFLAGS:N-fno-strict-aliasing}
CXXFLAGS:= ${CFLAGS:N-fno-strict-aliasing}
-.if ${PORT_OPTIONS:MFLAC}
-LIB_DEPENDS+= libFLAC.so:audio/flac
-CMAKE_ARGS+= -DWITH_FLAC=Y
-.else
-CMAKE_ARGS+= -DWITH_FLAC=N
-.endif
+OPTIONS_SUB= yes
-.if ${PORT_OPTIONS:MLAUNCHER}
-USE_WX= 2.8+
-WX_UNICODE= yes
-CMAKE_ARGS+= -DENABLE_LAUNCHER=Y \
- -DwxWidgets_CONFIG_EXECUTABLE="${WX_CONFIG}"
-PLIST_SUB+= LAUNCHER=""
-.else
-CMAKE_ARGS+= -DENABLE_LAUNCHER=N
-PLIST_SUB+= LAUNCHER="@comment "
-.endif
+FLAC_LIB_DEPENDS= libFLAC.so:audio/flac
+FLAC_CMAKE_ON= -DWITH_FLAC:BOOL=ON
+FLAC_CMAKE_OFF= -DWITH_FLAC:BOOL=OFF
-.if ${PORT_OPTIONS:MMAD}
-LIB_DEPENDS+= libmad.so:audio/libmad
-CMAKE_ARGS+= -DWITH_LIBMAD=Y
-.else
-CMAKE_ARGS+= -DWITH_LIBMAD=N
-.endif
+# Removed LAUNCHER because it segfaults - check also pkg-plist
+#LAUNCHER_USE= WX=2.8+
+#LAUNCHER_CMAKE_ON= -DENABLE_LAUNCHER:BOOL=ON \
+# -DwxWidgets_CONFIG_EXECUTABLE="${WX_CONFIG}"
+#LAUNCHER_CMAKE_OFF= -DENABLE_LAUNCHER:BOOL=OFF
+# Force disable LAUNCHER
+CMAKE_ARGS+= -DENABLE_LAUNCHER:BOOL=OFF
-.if ${PORT_OPTIONS:MMIKMOD}
-LIB_DEPENDS+= libmikmod.so:audio/libmikmod
-CMAKE_ARGS+= -DWITH_MIKMOD=Y
-.else
-CMAKE_ARGS+= -DWITH_MIKMOD=N
-.endif
+MAD_LIB_DEPENDS= libmad.so:audio/libmad
+MAD_CMAKE_ON= -DWITH_LIBMAD:BOOL=ON
+MAD_CMAKE_OFF= -DWITH_LIBMAD:BOOL=OFF
-.if ${PORT_OPTIONS:MOPENAL}
-USES+= openal:al
-CMAKE_ARGS+= -DWITH_OPENAL=Y
-.else
-CMAKE_ARGS+= -DWITH_OPENAL=N
-.endif
+MIKMOD_LIB_DEPENDS= libmikmod.so:audio/libmikmod
+MIKMOD_CMAKE_ON= -DWITH_MIKMOD:BOOL=ON
+MIKMOD_CMAKE_OFF= -DWITH_MIKMOD:BOOL=OFF
-.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
-CFLAGS+= -O3 -ffast-math -fomit-frame-pointer
-.endif
+OPENAL_USES= openal:al
+OPENAL_CMAKE_ON= -DWITH_OPENAL:BOOL=ON
+OPENAL_CMAKE_OFF= -DWITH_OPENAL:BOOL=OFF
-.if ${PORT_OPTIONS:MVORBIS}
-LIB_DEPENDS+= libvorbis.so:audio/libvorbis
-CMAKE_ARGS+= -DWITH_VORBIS=Y
-.else
-CMAKE_ARGS+= -DWITH_VORBIS=N
-.endif
+VORBIS_LIB_DEPENDS= libvorbis.so:audio/libvorbis
+VORBIS_CMAKE_ON= -DWITH_VORBIS:BOOL=ON
+VORBIS_CMAKE_OFF= -DWITH_VORBIS:BOOL=OFF
-.if ${PORT_OPTIONS:MSDL}
-USE_SDL= mixer sdl
-CMAKE_ARGS+= -DWITH_SDL=Y
-USE_GL= yes
-CMAKE_ARGS+= -DWITH_OPENGL=Y
-.else
-CMAKE_ARGS+= -DWITH_SDL=N
-CMAKE_ARGS+= -DWITH_OPENGL=N
-.endif
+SDL_USE= SDL=mixer,sdl GL=yes
+SDL_CMAKE_ON= -DWITH_SDL:BOOL=ON -DWITH_OPENGL:BOOL=ON
+SDL_CMAKE_OFF= -DWITH_SDL:BOOL=OFF -DWITH_OPENGL:BOOL=OFF
-.if ${PORT_OPTIONS:MWXUNICODE}
-.endif
+OPTIMIZED_CFLAGS_CFLAGS= -O3 -ffast-math -fomit-frame-pointer
+
+.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} -e 's|$$\* ||; s|$${IWADDIR}|-iwaddir ${DMDIR} $$*|' \
diff --git a/games/vavoom/files/patch-utils__vlaunch__vlaunch.cpp b/games/vavoom/files/patch-utils_vlaunch_vlaunch.cpp
index dd4c3941e41b..01600cf8d144 100644
--- a/games/vavoom/files/patch-utils__vlaunch__vlaunch.cpp
+++ b/games/vavoom/files/patch-utils_vlaunch_vlaunch.cpp
@@ -1,5 +1,5 @@
--- utils/vlaunch/vlaunch.cpp.orig 2011-01-01 12:51:56.000000000 +0100
-+++ utils/vlaunch/vlaunch.cpp 2012-12-24 00:17:28.000000000 +0100
++++ utils/vlaunch/vlaunch.cpp 2017-04-06 16:15:41.198381000 +0200
@@ -145,7 +145,7 @@
wxNotebook* nbook = new wxNotebook(panel, -1, wxPoint(0, 105), wxSize(447, 270));
mainsizer->Add(nbook);
diff --git a/games/vavoom/files/pkg-message.in b/games/vavoom/files/pkg-message.in
index c0c686d440d7..dae4d5f59f8b 100644
--- a/games/vavoom/files/pkg-message.in
+++ b/games/vavoom/files/pkg-message.in
@@ -5,6 +5,8 @@ Vavoom has been installed.
There are 2 wrapper scripts: "vavoom" and "vavoom-dedicated", calling the real
executables (suffixed with ".bin") from the data directory, and using the
common WAD directory.
+If you have extra WAD files, specify the full path of the containing directory
+as the first argument of the wrapper script.
To run in OpenGL mode add the "-opengl" parameter, and "-openal" for OpenAL.
@@ -12,6 +14,7 @@ If you want to install enhanced textures, models or soundtracks use the
"games/vavoom-extras" port. Note that textures require OPENGL and soundtracks
need VORBIS (build options).
-If you enabled LAUNCHER (build option), run "vlaunch" for a launcher GUI.
+Refer to %%DOCSDIR%%/vavoom.txt for other options such as
+game selection, network options and so on.
==============================================================================
diff --git a/games/vavoom/pkg-plist b/games/vavoom/pkg-plist
index e5dc8faeec68..7f4b7c82ef1e 100644
--- a/games/vavoom/pkg-plist
+++ b/games/vavoom/pkg-plist
@@ -2,7 +2,7 @@ bin/vavoom
bin/vavoom.bin
bin/vavoom-dedicated
bin/vavoom-dedicated.bin
-%%LAUNCHER%%bin/vlaunch
+@comment %%LAUNCHER%%bin/vlaunch
%%PORTDOCS%%%%DOCSDIR%%/vavoom.txt
%%DATADIR%%/basev/common/basepak.pk3
%%DATADIR%%/basev/doom/basepak.pk3