aboutsummaryrefslogtreecommitdiff
path: root/games/vavoom
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-04-01 14:00:51 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-04-01 14:00:51 +0000
commit4e1b79a0a61f4973df8b4b0864d22086c769e219 (patch)
tree78ceaf1b099c56a40c240ab46278cdf4ae9e7c01 /games/vavoom
parent7f4572eae4327c4403d9ef714cb6de917650662a (diff)
downloadports-4e1b79a0a61f4973df8b4b0864d22086c769e219.tar.gz
ports-4e1b79a0a61f4973df8b4b0864d22086c769e219.zip
Remove ${PORTSDIR}/ from dependencies, categories d, e, f, and g.
With hat: portmgr Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=412346
Diffstat (limited to 'games/vavoom')
-rw-r--r--games/vavoom/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/games/vavoom/Makefile b/games/vavoom/Makefile
index ceedd9b77b5f..e491a34febe7 100644
--- a/games/vavoom/Makefile
+++ b/games/vavoom/Makefile
@@ -12,7 +12,7 @@ COMMENT= Doom, Doom II, Heretic, Hexen, and Strife source port
LICENSE= GPLv2
-LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libpng.so:graphics/png
USES= cmake dos2unix jpeg tar:bzip2
DOS2UNIX_REGEX= ((.*\.(c|cpp|h|s|asm|inc|vc|ls|acs|cfg|txt|vs|mak|mgw"))$$|\/(makefile\..*|makefile|Makefile)$$)
@@ -33,7 +33,7 @@ CFLAGS:= ${CFLAGS:N-fno-strict-aliasing}
CXXFLAGS:= ${CFLAGS:N-fno-strict-aliasing}
.if ${PORT_OPTIONS:MFLAC}
-LIB_DEPENDS+= libFLAC.so:${PORTSDIR}/audio/flac
+LIB_DEPENDS+= libFLAC.so:audio/flac
CMAKE_ARGS+= -DWITH_FLAC=Y
.else
CMAKE_ARGS+= -DWITH_FLAC=N
@@ -51,14 +51,14 @@ PLIST_SUB+= LAUNCHER="@comment "
.endif
.if ${PORT_OPTIONS:MMAD}
-LIB_DEPENDS+= libmad.so:${PORTSDIR}/audio/libmad
+LIB_DEPENDS+= libmad.so:audio/libmad
CMAKE_ARGS+= -DWITH_LIBMAD=Y
.else
CMAKE_ARGS+= -DWITH_LIBMAD=N
.endif
.if ${PORT_OPTIONS:MMIKMOD}
-LIB_DEPENDS+= libmikmod.so:${PORTSDIR}/audio/libmikmod
+LIB_DEPENDS+= libmikmod.so:audio/libmikmod
CMAKE_ARGS+= -DWITH_MIKMOD=Y
.else
CMAKE_ARGS+= -DWITH_MIKMOD=N
@@ -76,7 +76,7 @@ CFLAGS+= -O3 -ffast-math -fomit-frame-pointer
.endif
.if ${PORT_OPTIONS:MVORBIS}
-LIB_DEPENDS+= libvorbis.so:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS+= libvorbis.so:audio/libvorbis
CMAKE_ARGS+= -DWITH_VORBIS=Y
.else
CMAKE_ARGS+= -DWITH_VORBIS=N