aboutsummaryrefslogtreecommitdiff
path: root/games/vectoroids
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-08-27 19:10:39 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-08-27 19:10:39 +0000
commit329a9a2ff806288e71e7b18f814d41dede5ffe2a (patch)
treef018747fc2609974be6159848b1d20a7ffbfd93f /games/vectoroids
parent6a2386d9582d613a32968b47812880f93588d29d (diff)
downloadports-329a9a2ff806288e71e7b18f814d41dede5ffe2a.tar.gz
ports-329a9a2ff806288e71e7b18f814d41dede5ffe2a.zip
- Fix MASTER_SITES
- Support CFLAGS properly - Utilize USE_SDL PR: 56038 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=87811
Diffstat (limited to 'games/vectoroids')
-rw-r--r--games/vectoroids/Makefile29
-rw-r--r--games/vectoroids/files/patch-Makefile11
-rw-r--r--games/vectoroids/pkg-plist40
3 files changed, 41 insertions, 39 deletions
diff --git a/games/vectoroids/Makefile b/games/vectoroids/Makefile
index 07e5aa222dcc..3b246f9e0d96 100644
--- a/games/vectoroids/Makefile
+++ b/games/vectoroids/Makefile
@@ -7,30 +7,31 @@
PORTNAME= vectoroids
PORTVERSION= 1.1.0
+PORTREVISION= 1
CATEGORIES= games
-MASTER_SITES= ftp://ftp.sonic.net/pub/users/nbs/unix/x/vectoroids/
+MASTER_SITES= ftp://ftp.sonic.net/pub/users/nbs/unix/x/vectoroids/src/
MAINTAINER= ports@FreeBSD.org
-COMMENT= "vector-based, pretty, Asteroids clone"
+COMMENT= A vector-based, pretty, Asteroids clone
-LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12 \
- SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer \
+LIB_DEPENDS= SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer \
SDL_image.10:${PORTSDIR}/graphics/sdl_image
-USE_X_PREFIX= YES
-USE_GMAKE= YES
+USE_X_PREFIX= yes
+USE_SDL= yes
+USE_GMAKE= yes
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/vectoroids ${PREFIX}/bin
- ${MKDIR} ${PREFIX}/share/vectoroids/images
- ${INSTALL_DATA} ${WRKSRC}/data/images/* ${PREFIX}/share/vectoroids/images
- ${MKDIR} ${PREFIX}/share/vectoroids/music
- ${INSTALL_DATA} ${WRKSRC}/data/music/* ${PREFIX}/share/vectoroids/music
- ${MKDIR} ${PREFIX}/share/vectoroids/sounds
- ${INSTALL_DATA} ${WRKSRC}/data/sounds/* ${PREFIX}/share/vectoroids/sounds
+ @${MKDIR} ${DATADIR}/images
+ ${INSTALL_DATA} ${WRKSRC}/data/images/* ${DATADIR}/images
+ @${MKDIR} ${DATADIR}/music
+ ${INSTALL_DATA} ${WRKSRC}/data/music/* ${DATADIR}/music
+ @${MKDIR} ${DATADIR}/sounds
+ ${INSTALL_DATA} ${WRKSRC}/data/sounds/* ${DATADIR}/sounds
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/vectoroids
- ${INSTALL_DATA} ${WRKSRC}/README.txt ${PREFIX}/share/doc/vectoroids/README
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}/README
.endif
.include <bsd.port.mk>
diff --git a/games/vectoroids/files/patch-Makefile b/games/vectoroids/files/patch-Makefile
index c7b53bcade84..bf03fa628b3d 100644
--- a/games/vectoroids/files/patch-Makefile
+++ b/games/vectoroids/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Sat Apr 13 17:51:14 2002
-+++ Makefile Fri Jun 27 02:02:00 2003
+--- Makefile.orig Sun Apr 14 09:51:14 2002
++++ Makefile Wed Aug 27 22:16:03 2003
@@ -9,19 +9,18 @@
# November 30, 2001 - April 13, 2002
@@ -11,14 +11,15 @@
JOY=YES
TARGET_DEF=LINUX
-SDL_LIB=$(shell sdl-config --libs) $(MIXER) -lSDL_image
-+SDL_LIB=$(shell sdl11-config --libs) $(MIXER) -lSDL_image
++SDL_LIB=$(shell $(SDL_CONFIG) --libs) $(MIXER) -lSDL_image
NOSOUNDFLAG=__SOUND
MIXER=-lSDL_mixer
- CFLAGS=-Wall -Wno-long-long -pedantic -ansi -O2 \
+-CFLAGS=-Wall -Wno-long-long -pedantic -ansi -O2 \
- $(shell sdl-config --cflags) -D$(NOSOUNDFLAG) \
-+ $(shell sdl11-config --cflags) -D$(NOSOUNDFLAG) \
++CFLAGS+= \
++ $(shell $(SDL_CONFIG) --cflags) -D$(NOSOUNDFLAG) \
-DDATA_PREFIX=\"$(DATA_PREFIX)\" -DJOY_$(JOY) -D$(TARGET_DEF)
diff --git a/games/vectoroids/pkg-plist b/games/vectoroids/pkg-plist
index 723ea5ac1752..8e236080f4da 100644
--- a/games/vectoroids/pkg-plist
+++ b/games/vectoroids/pkg-plist
@@ -1,21 +1,21 @@
bin/vectoroids
-%%PORTDOCS%%share/doc/vectoroids/README
-share/vectoroids/images/icon.png
-share/vectoroids/images/redspot-e.bmp
-share/vectoroids/images/redspot.jpg
-share/vectoroids/music/decision.s3m
-share/vectoroids/music/decision.txt
-share/vectoroids/sounds/ast1.wav
-share/vectoroids/sounds/ast2.wav
-share/vectoroids/sounds/ast3.wav
-share/vectoroids/sounds/ast4.wav
-share/vectoroids/sounds/bullet.wav
-share/vectoroids/sounds/explode.wav
-share/vectoroids/sounds/extralife.wav
-share/vectoroids/sounds/gameover.wav
-share/vectoroids/sounds/thrust.wav
-@dirrm share/vectoroids/sounds
-@dirrm share/vectoroids/music
-@dirrm share/vectoroids/images
-@dirrm share/vectoroids
-%%PORTDOCS%%@dirrm share/doc/vectoroids
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%DATADIR%%/images/icon.png
+%%DATADIR%%/images/redspot-e.bmp
+%%DATADIR%%/images/redspot.jpg
+%%DATADIR%%/music/decision.s3m
+%%DATADIR%%/music/decision.txt
+%%DATADIR%%/sounds/ast1.wav
+%%DATADIR%%/sounds/ast2.wav
+%%DATADIR%%/sounds/ast3.wav
+%%DATADIR%%/sounds/ast4.wav
+%%DATADIR%%/sounds/bullet.wav
+%%DATADIR%%/sounds/explode.wav
+%%DATADIR%%/sounds/extralife.wav
+%%DATADIR%%/sounds/gameover.wav
+%%DATADIR%%/sounds/thrust.wav
+@dirrm %%DATADIR%%/sounds
+@dirrm %%DATADIR%%/music
+@dirrm %%DATADIR%%/images
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%