aboutsummaryrefslogtreecommitdiff
path: root/games/volleyball
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-08-26 14:06:08 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-08-26 14:06:08 +0000
commit216b5a285fdcc1456a307fcc60f3507c20d613eb (patch)
treed0c8617b772b8f0a175d436d938b8d844590b41f /games/volleyball
parentb829518a7d432b7cc2546fde7f032238d1db13dc (diff)
downloadports-216b5a285fdcc1456a307fcc60f3507c20d613eb.tar.gz
ports-216b5a285fdcc1456a307fcc60f3507c20d613eb.zip
- Fix missing library problems when the linker enforces explicit linking
PR: 192062 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=366215
Diffstat (limited to 'games/volleyball')
-rw-r--r--games/volleyball/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/games/volleyball/Makefile b/games/volleyball/Makefile
index d1765263c5ac..d076ffed9453 100644
--- a/games/volleyball/Makefile
+++ b/games/volleyball/Makefile
@@ -13,11 +13,12 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Game similar to GNU Arcade Volleyball
+USES= gmake
USE_SDL= sdl image mixer
GNU_CONFIGURE= yes
-USES= gettext gmake
-LDFLAGS+= -L${LOCALBASE}/lib -lintl
CONFIGURE_ARGS= --mandir="${MANPREFIX}/man" --disable-nls # strangeness in nls support
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib -lm
PLIST_FILES= bin/${PORTNAME} \
man/man6/volleyball.6.gz
@@ -33,6 +34,11 @@ DESKTOP_ENTRIES="Pocket Volleyball" \
"Game;SportsGame;ArcadeGame;" \
false
+post-patch:
+ @${REINPLACE_CMD} '/libintl\.h/d' ${WRKSRC}/src/common.h
+ @${REINPLACE_CMD} -e '/setlocale/d' -e '/textdomain/d' \
+ ${WRKSRC}/src/volleyball.c
+
post-configure:
cd ${WRKDIR}/${PORTNAME}-data-${DATAVERSION} && \
${SETENV} ${CONFIGURE_ENV} ./${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS}