aboutsummaryrefslogtreecommitdiff
path: root/games/warzone2100
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2021-07-13 14:16:56 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2022-03-03 19:35:38 +0000
commit6979dc04a30ce74e1f02c44c3c1a3ca2eaf3f124 (patch)
treebddbe55c9e47b04e99d42b1d2005aba4a467a3cd /games/warzone2100
parentae66cffc19f357cbd51d5841c9b110a9ffd63e32 (diff)
downloadports-6979dc04a30ce74e1f02c44c3c1a3ca2eaf3f124.tar.gz
ports-6979dc04a30ce74e1f02c44c3c1a3ca2eaf3f124.zip
Diffstat (limited to 'games/warzone2100')
-rw-r--r--games/warzone2100/Makefile3
-rw-r--r--games/warzone2100/distinfo6
-rw-r--r--games/warzone2100/files/patch-5e6fdab49
-rw-r--r--games/warzone2100/files/patch-src_CMakeLists.txt12
-rw-r--r--games/warzone2100/pkg-plist3
5 files changed, 19 insertions, 54 deletions
diff --git a/games/warzone2100/Makefile b/games/warzone2100/Makefile
index 2b189d8791b9..ee6836b4a118 100644
--- a/games/warzone2100/Makefile
+++ b/games/warzone2100/Makefile
@@ -1,6 +1,5 @@
PORTNAME= warzone2100
-PORTVERSION= 4.0.1
-PORTREVISION= 1
+PORTVERSION= 4.2.6
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/releases/${PORTVERSION}/
DISTNAME= ${PORTNAME}_src
diff --git a/games/warzone2100/distinfo b/games/warzone2100/distinfo
index ea2ee87491e0..c28f363efa50 100644
--- a/games/warzone2100/distinfo
+++ b/games/warzone2100/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1618939913
-SHA256 (warzone2100-4.0.1/warzone2100_src.tar.xz) = 337622d5f813bbc1f9a3b4fee0874fcc074806781cfa9c25a252534ddd240ab9
-SIZE (warzone2100-4.0.1/warzone2100_src.tar.xz) = 337713608
+TIMESTAMP = 1646312222
+SHA256 (warzone2100-4.2.6/warzone2100_src.tar.xz) = b1d1dcfe2d5f7db4c063b7a13ba2ec21afa597e2c792e5c8c1cc13204398dbc8
+SIZE (warzone2100-4.2.6/warzone2100_src.tar.xz) = 338691628
diff --git a/games/warzone2100/files/patch-5e6fdab b/games/warzone2100/files/patch-5e6fdab
deleted file mode 100644
index 4b9e4fb8ed99..000000000000
--- a/games/warzone2100/files/patch-5e6fdab
+++ /dev/null
@@ -1,49 +0,0 @@
-From 5e6fdab3feac55357bcaedcb03ef619d23d3277f Mon Sep 17 00:00:00 2001
-From: past-due <30942300+past-due@users.noreply.github.com>
-Date: Sat, 4 Dec 2021 11:22:24 -0500
-Subject: [PATCH] [Vulkan] Add missing vk:: namespace to `throwResultException`
-
----
- lib/ivis_opengl/gfx_api_vk.cpp | 8 ++++----
- 1 file changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/lib/ivis_opengl/gfx_api_vk.cpp b/lib/ivis_opengl/gfx_api_vk.cpp
-index 594d127f70..419b8a7644 100644
---- lib/ivis_opengl/gfx_api_vk.cpp
-+++ lib/ivis_opengl/gfx_api_vk.cpp
-@@ -477,7 +477,7 @@ void BlockBufferAllocator::allocateNewBlock(uint32_t minimumSize)
- if (result != vk::Result::eSuccess)
- {
- // Failed to allocate memory!
-- throwResultException( result, "vmaCreateBuffer" );
-+ vk::throwResultException( result, "vmaCreateBuffer" );
- }
-
- if (autoMap)
-@@ -1304,7 +1304,7 @@ VkPSO::VkPSO(vk::Device _dev,
- object = std::move(result.value);
- break;
- default:
-- throwResultException(result.result, "createGraphicsPipeline");
-+ vk::throwResultException(result.result, "createGraphicsPipeline");
- }
- }
-
-@@ -1368,7 +1368,7 @@ void VkBuf::allocateBufferObject(const std::size_t& size)
- if (result != vk::Result::eSuccess)
- {
- // Failed to allocate memory!
-- throwResultException( result, "vmaCreateBuffer" );
-+ vk::throwResultException( result, "vmaCreateBuffer" );
- }
-
- buffer_size = size;
-@@ -1486,7 +1486,7 @@ VkTexture::VkTexture(const VkRoot& root, const std::size_t& mipmap_count, const
- if (result != vk::Result::eSuccess)
- {
- // Failed to allocate memory!
-- throwResultException( result, "vmaCreateImage" );
-+ vk::throwResultException( result, "vmaCreateImage" );
- }
-
- const auto imageViewCreateInfo = vk::ImageViewCreateInfo()
diff --git a/games/warzone2100/files/patch-src_CMakeLists.txt b/games/warzone2100/files/patch-src_CMakeLists.txt
new file mode 100644
index 000000000000..6b218103529a
--- /dev/null
+++ b/games/warzone2100/files/patch-src_CMakeLists.txt
@@ -0,0 +1,12 @@
+--- src/CMakeLists.txt.orig 2021-07-12 15:03:29 UTC
++++ src/CMakeLists.txt
+@@ -611,9 +611,6 @@ endif()
+ # Install
+ install(TARGETS warzone2100 COMPONENT Core DESTINATION "${WZ_APP_INSTALL_DEST}")
+
+-# For Portable packages only, copy the ".portable" file that triggers portable mode (Windows-only)
+-install(FILES "${CMAKE_SOURCE_DIR}/pkg/portable.in" COMPONENT PortableConfig DESTINATION "${WZ_APP_INSTALL_DEST}" RENAME ".portable")
+-
+ #####################
+ # Installing Required Runtime Dependencies
+
diff --git a/games/warzone2100/pkg-plist b/games/warzone2100/pkg-plist
index 281bd7978d5d..3a9a0b1aa27a 100644
--- a/games/warzone2100/pkg-plist
+++ b/games/warzone2100/pkg-plist
@@ -3,6 +3,7 @@ man/man6/warzone2100.6.gz
share/applications/warzone2100.desktop
share/icons/warzone2100.png
%%NLS%%share/locale/af_ZA/LC_MESSAGES/warzone2100.mo
+%%NLS%%share/locale/ar_SA/LC_MESSAGES/warzone2100.mo
%%NLS%%share/locale/bg_BG/LC_MESSAGES/warzone2100.mo
%%NLS%%share/locale/ca_ES/LC_MESSAGES/warzone2100.mo
%%NLS%%share/locale/cs/LC_MESSAGES/warzone2100.mo
@@ -13,6 +14,7 @@ share/icons/warzone2100.png
%%NLS%%share/locale/eo/LC_MESSAGES/warzone2100.mo
%%NLS%%share/locale/es/LC_MESSAGES/warzone2100.mo
%%NLS%%share/locale/et_EE/LC_MESSAGES/warzone2100.mo
+%%NLS%%share/locale/fa_IR/LC_MESSAGES/warzone2100.mo
%%NLS%%share/locale/fi/LC_MESSAGES/warzone2100.mo
%%NLS%%share/locale/fr/LC_MESSAGES/warzone2100.mo
%%NLS%%share/locale/fy/LC_MESSAGES/warzone2100.mo
@@ -26,6 +28,7 @@ share/icons/warzone2100.png
%%NLS%%share/locale/ko/LC_MESSAGES/warzone2100.mo
%%NLS%%share/locale/la/LC_MESSAGES/warzone2100.mo
%%NLS%%share/locale/lt/LC_MESSAGES/warzone2100.mo
+%%NLS%%share/locale/my_MM/LC_MESSAGES/warzone2100.mo
%%NLS%%share/locale/nb/LC_MESSAGES/warzone2100.mo
%%NLS%%share/locale/nl/LC_MESSAGES/warzone2100.mo
%%NLS%%share/locale/pl/LC_MESSAGES/warzone2100.mo