aboutsummaryrefslogtreecommitdiff
path: root/games/warzone2100
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2020-07-14 22:47:04 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2020-07-14 22:47:04 +0000
commitd11d2b1453c457ea66159a9ba785b0654bf8adfb (patch)
treebed0d2739299bd6138f74cab971855c24f482d88 /games/warzone2100
parentcfea09dc4e30e6a0045734bce4baab3fdaa62310 (diff)
downloadports-d11d2b1453c457ea66159a9ba785b0654bf8adfb.tar.gz
ports-d11d2b1453c457ea66159a9ba785b0654bf8adfb.zip
- Update to 3.4.0
Notes
Notes: svn path=/head/; revision=542239
Diffstat (limited to 'games/warzone2100')
-rw-r--r--games/warzone2100/Makefile43
-rw-r--r--games/warzone2100/distinfo6
-rw-r--r--games/warzone2100/files/patch-po_Makevars11
-rw-r--r--games/warzone2100/pkg-descr2
-rw-r--r--games/warzone2100/pkg-plist2
5 files changed, 23 insertions, 41 deletions
diff --git a/games/warzone2100/Makefile b/games/warzone2100/Makefile
index e129754ade05..e4d851eb9232 100644
--- a/games/warzone2100/Makefile
+++ b/games/warzone2100/Makefile
@@ -1,10 +1,11 @@
# $FreeBSD$
PORTNAME= warzone2100
-PORTVERSION= 3.3.0
+PORTVERSION= 3.4.0
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/releases/${PORTVERSION}/
-DISTNAME= ${PORTNAME}-${PORTVERSION}_src
+DISTNAME= ${PORTNAME}_src
+DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Innovative 3D real-time strategy game
@@ -12,46 +13,38 @@ COMMENT= Innovative 3D real-time strategy game
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= zip:archivers/zip
+BUILD_DEPENDS= 7z:archivers/p7zip \
+ a2x:textproc/asciidoc
LIB_DEPENDS= libphysfs.so:devel/physfs \
libpng.so:graphics/png \
libvorbis.so:audio/libvorbis \
libogg.so:audio/libogg \
libtheora.so:multimedia/libtheora \
- libfribidi.so:converters/fribidi \
libfreetype.so:print/freetype2 \
- libfontconfig.so:x11-fonts/fontconfig \
- libharfbuzz.so:print/harfbuzz
+ libharfbuzz.so:print/harfbuzz \
+ libsodium.so:security/libsodium \
+ libcurl.so:ftp/curl
RUN_DEPENDS= ${LOCALBASE}/share/fonts/dejavu/DejaVuSans.ttf:x11-fonts/dejavu
-USES= autoreconf bison compiler:c++11-lib gl gmake localbase openal:al pkgconfig \
- qmake:no_env qt:5 sdl ssl tar:xz xorg
-GNU_CONFIGURE= yes
+USES= cmake bison compiler:c++11-lib gl openal:al pkgconfig \
+ qmake:no_env qt:5 sdl tar:xz
USE_GL= gl glu glew
USE_SDL= sdl2
-USE_XORG= x11 xrandr
-USE_QT= core gui widgets script buildtools_build
-CONFIGURE_ARGS= --program-transform-name="" --with-distributor="FreeBSD ports"
-CONFIGURE_ENV= LIBCRYPTO_CFLAGS="-I${OPENSSLINC}" \
- LIBCRYPTO_LIBS="-L${OPENSSLLIB} -lcrypto" \
- CCOMPILER="${CC}" CXXCOMPILER="${CXX}"
+USE_QT= core gui widgets script buildtools_build qmake_build
+CMAKE_ARGS= -DWZ_DISTRIBUTOR="FreeBSD ports" \
+ -DCMAKE_DISABLE_FIND_PACKAGE_Asciidoctor=TRUE \
+ -DCMAKE_DISABLE_FIND_PACKAGE_Git=TRUE \
+ -DWZ_ENABLE_WARNINGS_AS_ERRORS=FALSE
WRKSRC= ${WRKDIR}/${PORTNAME}
PORTDOCS= *
PORTDATA= *
-OPTIONS_DEFINE= DOCS NLS MANPAGES
-OPTIONS_DEFAULT=MANPAGES
+OPTIONS_DEFINE= DOCS NLS
OPTIONS_SUB= yes
-NLS_USES= gettext
-NLS_USES_OFF= gettext-tools
-NLS_CONFIGURE_ENABLE= nls
-
-MANPAGES_BUILD_DEPENDS= a2x:textproc/asciidoc
-
-post-patch:
- @${REINPLACE_CMD} -e 's|./build_tools/autorevision|& -f|g' ${WRKSRC}/src/Makefile.am
+NLS_USES= gettext
+NLS_CMAKE_BOOL= ENABLE_NLS
.include <bsd.port.mk>
diff --git a/games/warzone2100/distinfo b/games/warzone2100/distinfo
index 39aef6248b7b..a17011b10b2c 100644
--- a/games/warzone2100/distinfo
+++ b/games/warzone2100/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1568381470
-SHA256 (warzone2100-3.3.0_src.tar.xz) = cc48c8128d17a499e833996470d843855389d9fc985c71f05be08901f33116e8
-SIZE (warzone2100-3.3.0_src.tar.xz) = 86605304
+TIMESTAMP = 1594156268
+SHA256 (warzone2100-3.4.0/warzone2100_src.tar.xz) = fe0128b4fe590d29d6f03fc1bc72016448fdb282dd8d9f9fbb4403fe53e4983c
+SIZE (warzone2100-3.4.0/warzone2100_src.tar.xz) = 89178604
diff --git a/games/warzone2100/files/patch-po_Makevars b/games/warzone2100/files/patch-po_Makevars
deleted file mode 100644
index ece8ef8fa9aa..000000000000
--- a/games/warzone2100/files/patch-po_Makevars
+++ /dev/null
@@ -1,11 +0,0 @@
---- po/Makevars.orig 2019-08-31 18:17:22 UTC
-+++ po/Makevars
-@@ -5,7 +5,7 @@ DOMAIN = $(PACKAGE)
-
- # These two variables depend on the location of this directory.
- subdir = po
--#top_builddir = ..
-+top_builddir = ..
-
- # These options get passed to xgettext.
- XGETTEXT_OPTIONS = --language=C++ --from-code=UTF-8 --no-wrap --width=1 --keyword=_ --keyword=N_ --keyword=P_:1c,2 --keyword=NP_:1c,2
diff --git a/games/warzone2100/pkg-descr b/games/warzone2100/pkg-descr
index df56d1d757c2..a952b7701bb0 100644
--- a/games/warzone2100/pkg-descr
+++ b/games/warzone2100/pkg-descr
@@ -10,4 +10,4 @@ In late 2004 warzone was released by its copyright holders, Eidos-Interactive,
to the public under the GNU General Public License (GPL), and the Warzone 2100
Resurrection Project was born.
-WWW: http://wz2100.net/
+WWW: https://wz2100.net/
diff --git a/games/warzone2100/pkg-plist b/games/warzone2100/pkg-plist
index 8ffcad06103f..8354e9c59978 100644
--- a/games/warzone2100/pkg-plist
+++ b/games/warzone2100/pkg-plist
@@ -1,5 +1,5 @@
bin/warzone2100
-%%MANPAGES%%man/man6/warzone2100.6.gz
+man/man6/warzone2100.6.gz
share/applications/warzone2100.desktop
share/icons/warzone2100.png
%%NLS%%share/locale/ca_ES/LC_MESSAGES/warzone2100.mo