aboutsummaryrefslogtreecommitdiff
path: root/games/wesnoth/Makefile
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2005-01-31 20:23:38 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2005-01-31 20:23:38 +0000
commit1b90228615f87283fee69ef48021d57e009c7c71 (patch)
treed74bec9f464df305af9ebd8f57288b48e67f6624 /games/wesnoth/Makefile
parentf02c7229d52d7886cd170bb6f39f794556cb8b5d (diff)
downloadports-1b90228615f87283fee69ef48021d57e009c7c71.tar.gz
ports-1b90228615f87283fee69ef48021d57e009c7c71.zip
Notes
Diffstat (limited to 'games/wesnoth/Makefile')
-rw-r--r--games/wesnoth/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/games/wesnoth/Makefile b/games/wesnoth/Makefile
index 3a486b0a1ba0..08c85c6fda65 100644
--- a/games/wesnoth/Makefile
+++ b/games/wesnoth/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= wesnoth
-PORTVERSION= 0.8.8
+PORTVERSION= 0.8.9
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.wesnoth.org/files/
@@ -19,6 +19,8 @@ DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
MAINTAINER= mezz@FreeBSD.org
COMMENT= A fantasy turn-based strategy game
+LIB_DEPENDS= zipios.0:${PORTSDIR}/archivers/zipios++
+
USE_GCC= 3.4
USE_SDL= image mixer net
USE_GNOME= gnometarget
@@ -28,15 +30,16 @@ USE_GETTEXT= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-sdltest \
- --with-libiconv-prefix=${LOCALBASE} \
+CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE} \
--with-libintl-prefix=${LOCALBASE} \
--with-freetype-prefix=${LOCALBASE} \
--with-localedir=${PREFIX}/share/locale
-CONFIGURE_ENV= CPPFLAGS="-ftemplate-depth-45" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ CXXFLAGS="-I${LOCALBASE}/include ${CXXFLAGS} -ftemplate-depth-45" \
LDFLAGS="-L${LOCALBASE}/lib -lintl"
MAN6= wesnoth.6 wesnoth_editor.6 wesnothd.6
+MANLANG= "" de
.if defined(LITE)
CONFIGURE_ARGS+= --enable-lite
@@ -121,5 +124,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|[$$][(]datadir[)]/applications|${X11BASE}/share/gnome/apps/Games|g ; \
s|[$$][(]datadir[)]/icons|${X11BASE}/share/gnome/pixmaps|g' \
${WRKSRC}/icons/Makefile.in
+ @${REINPLACE_CMD} -e 's|@SDL_CFLAGS@|@SDL_CFLAGS@ -I../sdl_ttf|g' \
+ ${WRKSRC}/src/tools/Makefile.in
.include <bsd.port.post.mk>