aboutsummaryrefslogtreecommitdiff
path: root/games/widelands
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-07-03 15:00:46 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-07-03 15:00:46 +0000
commit98b66ed31f965addadea67050d0e6f426887467d (patch)
tree3253b768a48546384ae625ac205e896c19abfa57 /games/widelands
parentf1e7b1cd165070b3069ca805dfadf547c214360b (diff)
downloadports-98b66ed31f965addadea67050d0e6f426887467d.tar.gz
ports-98b66ed31f965addadea67050d0e6f426887467d.zip
- Add missing depends after update to b19
- Drop unneeded lua dependency PR: 216457
Notes
Notes: svn path=/head/; revision=444961
Diffstat (limited to 'games/widelands')
-rw-r--r--games/widelands/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/games/widelands/Makefile b/games/widelands/Makefile
index ace8b09f8089..249e5395bea8 100644
--- a/games/widelands/Makefile
+++ b/games/widelands/Makefile
@@ -14,18 +14,18 @@ COMMENT= Realtime strategy game inspired by Settlers II
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libpng.so:graphics/png
-BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs
+LIB_DEPENDS= libpng.so:graphics/png \
+ libicuuc.so:devel/icu \
+ libboost_regex.so:devel/boost-libs
USES= cmake:outsource compiler:c++11-lib execinfo gettext \
- lua:52 tar:bzip2 python:build
+ tar:bzip2 python:build
CMAKE_ARGS= -DWL_INSTALL_BASEDIR="${PREFIX}" \
-DWL_INSTALL_DATADIR="${DATADIR}" \
-DWL_INSTALL_DOCDIR="${DOCSDIR}" \
- -DWL_INSTALL_BINDIR="bin" \
-DWL_VERSION="${DISTVERSION}" \
-DWL_OPTIMIZE_FLAGS=""
-USE_GL= glew
+USE_GL= gl glew
USE_SDL= sdl2 mixer2 image2 net2 ttf2
PORTDATA= *