aboutsummaryrefslogtreecommitdiff
path: root/games/wmpuzzle
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-10-28 16:55:22 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-10-28 16:55:22 +0000
commit8e89a2b09cf469a098f296215bac08f9a9b54c39 (patch)
tree994c80675e75769cbbca3d3ab78c9d15ceaafcd2 /games/wmpuzzle
parent3226f64d04ddf66c8ded8d6ed3d468f1e9a9e5f2 (diff)
downloadports-8e89a2b09cf469a098f296215bac08f9a9b54c39.tar.gz
ports-8e89a2b09cf469a098f296215bac08f9a9b54c39.zip
upgrade to 0.2.0
PR: 44556 Submitted by: Erwin Lansing <erwin@lansing.dk>
Notes
Notes: svn path=/head/; revision=69040
Diffstat (limited to 'games/wmpuzzle')
-rw-r--r--games/wmpuzzle/Makefile13
-rw-r--r--games/wmpuzzle/distinfo3
-rw-r--r--games/wmpuzzle/files/patch-Makefile61
-rw-r--r--games/wmpuzzle/files/patch-wmpuzzle.614
-rw-r--r--games/wmpuzzle/files/patch-wmpuzzle.c41
-rw-r--r--games/wmpuzzle/files/patch-wmpuzzle.h11
-rw-r--r--games/wmpuzzle/pkg-descr2
7 files changed, 33 insertions, 112 deletions
diff --git a/games/wmpuzzle/Makefile b/games/wmpuzzle/Makefile
index 4f4c57f1dc57..d835a0dcc480 100644
--- a/games/wmpuzzle/Makefile
+++ b/games/wmpuzzle/Makefile
@@ -6,13 +6,13 @@
#
PORTNAME= wmpuzzle
-PORTVERSION= 0.1.1
+PORTVERSION= 0.2.0
CATEGORIES= games windowmaker afterstep
-MASTER_SITES= http://wwwtcs.inf.tu-dresden.de/~godisch/debian/wmpuzzle/ \
+MASTER_SITES= http://www.godisch.de/debian/wmpuzzle/ \
${MASTER_SITE_LOCAL:S/$/:bsdpics/}
MASTER_SITE_SUBDIR= petef/:bsdpics
DISTFILES= wmpuzzle_${PORTVERSION}.orig${EXTRACT_SUFX} \
- daemon.gif:bsdpics daemon.xpm:bsdpics
+ daemon.xpm:bsdpics
DIST_SUBDIR= wmpuzzle
EXTRACT_ONLY= wmpuzzle_${PORTVERSION}.orig${EXTRACT_SUFX}
@@ -20,6 +20,9 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib -lgnugetopt"
USE_GMAKE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
USE_X_PREFIX= yes
@@ -27,11 +30,11 @@ USE_XPM= yes
MAN6= wmpuzzle.6
-BSDIMAGES= daemon.gif daemon.xpm
+BSDIMAGES= daemon.xpm
post-extract:
.for i in ${BSDIMAGES}
- ${CP} ${DISTDIR}/${DIST_SUBDIR}/$i ${WRKSRC}/xpm
+ ${CP} ${DISTDIR}/${DIST_SUBDIR}/$i ${WRKSRC}/
.endfor
do-install:
diff --git a/games/wmpuzzle/distinfo b/games/wmpuzzle/distinfo
index d5450010077b..dcbb1a306019 100644
--- a/games/wmpuzzle/distinfo
+++ b/games/wmpuzzle/distinfo
@@ -1,3 +1,2 @@
-MD5 (wmpuzzle/wmpuzzle_0.1.1.orig.tar.gz) = 9d3ce8638068ecb7202e77429c9b3867
-MD5 (wmpuzzle/daemon.gif) = 08659de4c16b7f0e4e874eece1ef56fa
+MD5 (wmpuzzle/wmpuzzle_0.2.0.orig.tar.gz) = 09605c3d33ba04c019b0ddc2c4bb86d4
MD5 (wmpuzzle/daemon.xpm) = 2822c63820f67a68702fe8627b0ae688
diff --git a/games/wmpuzzle/files/patch-Makefile b/games/wmpuzzle/files/patch-Makefile
deleted file mode 100644
index b5f77e78a1eb..000000000000
--- a/games/wmpuzzle/files/patch-Makefile
+++ /dev/null
@@ -1,61 +0,0 @@
-$FreeBSD$
-
---- Makefile.orig Wed Mar 13 23:09:33 2002
-+++ Makefile Wed May 15 20:32:38 2002
-@@ -1,45 +1,18 @@
--# $Id: Makefile,v 1.11 2002/03/13 17:09:33 godisch Exp $
-+CC ?= gcc
-+CFLAGS += -c -Wall -pedantic
-+INCDIR = -I${X11BASE}/include -I/usr/local/include
-+LIBDIR = -L${X11BASE}/lib -L/usr/local/lib
-+LIBS = -lXpm -lXext -lX11 -lgnugetopt
-+OBJS = wmpuzzle.o wmgeneral.o
-
--prefix = /usr/local
--exec_prefix = ${prefix}
--bindir = ${exec_prefix}/bin
--mandir = ${prefix}/share/man
-+.c.o:
-+ ${CC} ${CFLAGS} ${INCDIR} $< -o $*.o
-
--DESTDIR =
--
--CFLAGS = -O2 -Wall -pedantic
--LIBS = -L/usr/X11R6/lib -lX11 -lXpm -lXext
--XPMS = xpm/debian.xpm xpm/eagle.xpm xpm/earth.xpm xpm/linux.xpm
-+wmpuzzle: $(OBJS)
-+ ${CC} -o wmpuzzle $^ ${LIBDIR} ${LIBS}
-
- all: wmpuzzle
-
--wmpuzzle: wmpuzzle.o wmgeneral.o
-- $(CC) $(LIBS) -o $@ $^
--
--wmpuzzle.o: wmpuzzle.c wmpuzzle.h $(XPMS)
--wmgeneral.o: wmgeneral.c wmgeneral.h
--
--install: install-bin install-doc
--
--install-bin: wmpuzzle
-- install -D -s -m 755 $< $(DESTDIR)$(bindir)/wmpuzzle
--
--install-doc: wmpuzzle.6
-- install -D -m 644 $< $(DESTDIR)$(mandir)/man6/wmpuzzle.6
--
--uninstall: uninstall-bin uninstall-doc
--
--uninstall-bin:
-- rm -f $(DESTDIR)$(bindir)/wmpuzzle
--
--uninstall-doc:
-- rm -f $(DESTDIR)$(mandir)/man6/wmpuzzle.6
--
- clean:
- rm -f *.o
--
--distclean: clean
-- rm -f wmpuzzle
--
--.PHONY: all clean dist-clean install install-bin install-doc \
-- uninstall uninstall-bin uninstall-doc
-+ rm -f wmpuzzle core
diff --git a/games/wmpuzzle/files/patch-wmpuzzle.6 b/games/wmpuzzle/files/patch-wmpuzzle.6
deleted file mode 100644
index ced79ca91983..000000000000
--- a/games/wmpuzzle/files/patch-wmpuzzle.6
+++ /dev/null
@@ -1,14 +0,0 @@
-$FreeBSD$
-
---- wmpuzzle.6.orig Wed Mar 13 23:09:33 2002
-+++ wmpuzzle.6 Wed May 15 21:22:41 2002
-@@ -26,7 +26,8 @@
- .TP
- \fB\-i\fP, \fB\-\-image=\fIimage\fP
- the image which shall be shown.
--Valid images are \fIdebian\fP, \fIeagle\fP, \fIearth\fP, and \fIlinux\fP.
-+Valid images are \fIdebian\fP, \fIeagle\fP, \fIearth\fP, \fIlinux\fP,
-+and \fIdaemon\fP.
- Other images will be included on request.
- .TP
- \fB\-k\fP, \fB\-\-keyboard\fP
diff --git a/games/wmpuzzle/files/patch-wmpuzzle.c b/games/wmpuzzle/files/patch-wmpuzzle.c
index e5afbe286733..d48ae9e0e8b9 100644
--- a/games/wmpuzzle/files/patch-wmpuzzle.c
+++ b/games/wmpuzzle/files/patch-wmpuzzle.c
@@ -1,30 +1,13 @@
-$FreeBSD$
-
---- wmpuzzle.c.orig Thu Apr 18 00:13:52 2002
-+++ wmpuzzle.c Wed May 15 21:21:20 2002
-@@ -22,6 +22,7 @@
- #include "xpm/eagle.xpm"
- #include "xpm/earth.xpm"
- #include "xpm/linux.xpm"
-+#include "xpm/daemon.xpm"
+--- wmpuzzle.c.orig Mon Oct 21 22:26:35 2002
++++ wmpuzzle.c Sun Oct 27 17:28:07 2002
+@@ -254,8 +254,8 @@
+ }
+ }
+ if (image == NULL) {
+- image = strdup("linux");
+- *wmpuzzle = linux_xpm;
++ image = strdup("daemon");
++ *wmpuzzle = daemon_xpm;
+ }
+ }
- #define PROGRAM_NAME "wmpuzzle"
- #define PROGRAM_VERSION "0.1.1"
-@@ -203,6 +204,8 @@
- *wmpuzzle = earth_xpm;
- else if (!strcmp(optarg, "linux"))
- *wmpuzzle = linux_xpm;
-+ else if (!strcmp(optarg, "daemon"))
-+ *wmpuzzle = daemon_xpm;
- else {
- fprintf(stderr, "%s: invalid image `%s'\n", PROGRAM_NAME, optarg);
- exit(1);
-@@ -224,7 +227,7 @@
- printf("Usage: %s [-h] [-i <image>] [-k] [-s <count>] [-v]\n", PROGRAM_NAME);
- printf(" -h, --help displays this command line summary.\n");
- printf(" -i, --image <image> uses <image>, valid images are `debian', `eagle',\n");
-- printf(" `earth', and `linux'.\n");
-+ printf(" `earth', `linux', and `daemon'.\n");
- printf(" -k, --keyboard enables the arrow keys on the keyboard.\n");
- printf(" -s, --shuffle <count> shuffles the image <count> times.\n");
- printf(" -v, --version displays the version number.\n");
diff --git a/games/wmpuzzle/files/patch-wmpuzzle.h b/games/wmpuzzle/files/patch-wmpuzzle.h
new file mode 100644
index 000000000000..e9c147348c11
--- /dev/null
+++ b/games/wmpuzzle/files/patch-wmpuzzle.h
@@ -0,0 +1,11 @@
+--- wmpuzzle.h.orig Mon Oct 21 21:20:19 2002
++++ wmpuzzle.h Sun Oct 27 17:28:09 2002
+@@ -8,7 +8,7 @@
+ #define WMPUZZLE_H_INCLUDED
+
+ #include <config.h>
+-#include <linux.xpm>
++#include <daemon.xpm>
+
+ #define EINTERNAL 200
+ #define EINVALXPM 201
diff --git a/games/wmpuzzle/pkg-descr b/games/wmpuzzle/pkg-descr
index fe460a716525..1d4f2504b775 100644
--- a/games/wmpuzzle/pkg-descr
+++ b/games/wmpuzzle/pkg-descr
@@ -3,4 +3,4 @@ WindowMaker Dock or AfterStep Wharf.
Now includes special BSD Daemon skin not present in original
distribution!
-WWW: http://wwwtcs.inf.tu-dresden.de/~godisch/debian/wmpuzzle/
+WWW: http://www.godisch.de/debian/wmpuzzle/