aboutsummaryrefslogtreecommitdiff
path: root/games/wmtictactoe
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-12 20:38:47 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-12 20:38:47 +0000
commita97a447648b01395f93565f88f2f074826ba3818 (patch)
tree2648b67b42f5fa934c0740cab5ccc47f30268817 /games/wmtictactoe
parent277f894976889d594bddbf4df216de9a96c70e50 (diff)
downloadports-a97a447648b01395f93565f88f2f074826ba3818.tar.gz
ports-a97a447648b01395f93565f88f2f074826ba3818.zip
- Convert USE_GMAKE to USES
- Add stage support
Notes
Notes: svn path=/head/; revision=333618
Diffstat (limited to 'games/wmtictactoe')
-rw-r--r--games/wmtictactoe/Makefile3
-rw-r--r--games/wmtictactoe/files/patch-aa2
2 files changed, 2 insertions, 3 deletions
diff --git a/games/wmtictactoe/Makefile b/games/wmtictactoe/Makefile
index 30e41b988cc0..976b63f17a29 100644
--- a/games/wmtictactoe/Makefile
+++ b/games/wmtictactoe/Makefile
@@ -14,11 +14,10 @@ COMMENT= Dockable TicTacToe game for WindowMaker and AfterStep
WRKSRC= ${WRKDIR}/wmtictactoe.app/wmtictactoe
USE_XORG= xpm
-USE_GMAKE= yes
+USES= gmake
PLIST_FILES= bin/wmtictactoe
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e \
's|^void .*main|int main|' ${WRKSRC}/wmtictactoe.c
diff --git a/games/wmtictactoe/files/patch-aa b/games/wmtictactoe/files/patch-aa
index 9a25147bab6f..93830cb72361 100644
--- a/games/wmtictactoe/files/patch-aa
+++ b/games/wmtictactoe/files/patch-aa
@@ -27,4 +27,4 @@
install:
- /usr/bin/install -c -o 0 -g 0 -s -m 755 wmtictactoe /usr/local/bin/wmtictactoe
-
-+ @/usr/bin/install -c -o 0 -g 0 -s -m 755 wmtictactoe ${PREFIX}/bin/wmtictactoe
++ @/usr/bin/install -c -s -m 755 wmtictactoe ${DESTDIR}${PREFIX}/bin/wmtictactoe