aboutsummaryrefslogtreecommitdiff
path: root/games/worldofpadman
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-03-16 17:17:37 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-03-16 17:17:37 +0000
commitc930fb9f430a9251b8191baccb95e26c12bb3563 (patch)
tree839021fa66350c3863e5da72c6e5c091f7bce315 /games/worldofpadman
parent4d825bdd14c5917fbe4095461cf09a0a5ca4823d (diff)
downloadports-c930fb9f430a9251b8191baccb95e26c12bb3563.tar.gz
ports-c930fb9f430a9251b8191baccb95e26c12bb3563.zip
Notes
Diffstat (limited to 'games/worldofpadman')
-rw-r--r--games/worldofpadman/Makefile107
-rw-r--r--games/worldofpadman/pkg-descr37
-rw-r--r--games/worldofpadman/pkg-message8
3 files changed, 75 insertions, 77 deletions
diff --git a/games/worldofpadman/Makefile b/games/worldofpadman/Makefile
index 33378da3090a..59f19b060340 100644
--- a/games/worldofpadman/Makefile
+++ b/games/worldofpadman/Makefile
@@ -1,19 +1,11 @@
-# New ports collection makefile for: worldofpadman
-# Date created: 2008-01-12
-# Whom: alepulver
-#
+# Created by: Alejandro Pulver <alepulver@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= worldofpadman
PORTVERSION= 1.2.20080621
PORTREVISION= 8
CATEGORIES= games
-MASTER_SITES= http://thilo.kickchat.com/download/:full \
- http://btc3x6.che.uni-bayreuth.de/~tl/wop_final/:full \
- ftp://ftp.snt.utwente.nl/pub/games/worldofpadman/linux/:full,update \
- ftp://ftp.kickchat.com/wop/:update \
- http://www.hessenfragger.de/uploads/:update \
+MASTER_SITES= ftp://ftp.snt.utwente.nl/pub/games/worldofpadman/linux/:full,update \
${MASTER_SITE_LOCAL:S|$|alepulver/:source|}
DISTFILES= worldofpadman.run:full \
wop_patch_1_2.run:update \
@@ -22,72 +14,73 @@ EXTRACT_ONLY= worldofpadman.run \
wop_patch_1_2.run
MAINTAINER= ports@FreeBSD.org
-COMMENT= World of Padman (WoP) is an open source FPS game
+COMMENT= Open source FPS game inspired by the Padman comic strip
USE_MAKESELF= yes
USE_GMAKE= yes
+MAKE_ENV= DEFAULT_BASEDIR="${DATADIR}" PTHREAD_LIBS="${PTHREAD_LIBS}"
ALL_TARGET= release
NO_PACKAGE= package will be ~600MB; set FORCE_PACKAGE if you really want it
-OPTIONS_DEFINE= CURL CURL_DLOPEN GAMELIBS MP3 OPENAL OPENAL_DLOPEN OPTIMIZED_CFLAGS VORBIS
-OPTIONS_DEFAULT= CLIENT CURL CURL_DLOPEN DEDICATED OPTIMIZED_CFLAGS VORBIS SMP
-OPTIONS_MULTI= MODE
-OPTIONS_MULTI_MODE= CLIENT DEDICATED SMP
-
-CLIENT_DESC= Build client
-CURL_DLOPEN_DESC= Enable dynamic loading of curl
-DEDICATED_DESC= Build dedicated server
-GAMELIBS_DESC= Build game libraries (when not mandatory)
+OPTIONS_DEFINE= CURL CURL_DLOPEN GAMELIBS MP3 OPENAL OPENAL_DLOPEN \
+ OPTIMIZED_CFLAGS VORBIS
+OPTIONS_MULTI= TYPE
+OPTIONS_MULTI_TYPE= CLIENT DEDICATED SMP_CLIENT
+OPTIONS_DEFAULT= CLIENT CURL CURL_DLOPEN DEDICATED OPTIMIZED_CFLAGS \
+ VORBIS SMP_CLIENT
+
+CLIENT_DESC= Build client
+CURL_DLOPEN_DESC= Enable dynamic loading of cURL
+DEDICATED_DESC= Build dedicated server
+GAMELIBS_DESC= Force building game libraries
OPENAL_DLOPEN_DESC= Enable dynamic loading of OpenAL
-SMP_DESC= Build SMP (threaded) client
-
-MAKE_ENV= DEFAULT_BASEDIR="${DATADIR}" PTHREAD_LIBS="${PTHREAD_LIBS}"
+SMP_CLIENT_DESC= Build SMP (threaded) client
-VM_ARCHS= amd64 i386 powerpc
SRC_FILE= ${PORTNAME}-${PORTVERSION}
+VM_ARCHS= amd64 i386 powerpc
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.for i in ${ARCH}
-. if ${VM_ARCHS:M${i}} != ""
+.for arch in ${ARCH}
+. if ${VM_ARCHS:M${arch}} != ""
HAVE_VM_COMPILED= yes
-. endif
+. endif
.endfor
.if defined(HAVE_VM_COMPILED)
MAKE_ENV+= HAVE_VM_COMPILED=true
.endif
-.if empty(${PORT_OPTIONS:MCLIENT}) || !${PORT_OPTIONS:MSMP}
-# curl
-.if ${PORT_OPTIONS:MCURL}
-LIB_DEPENDS+= curl.6:${PORTSDIR}/ftp/curl
+.if ${PORT_OPTIONS:MCLIENT} || ${PORT_OPTIONS:MSMP_CLIENT}
+# cURL
+. if ${PORT_OPTIONS:MCURL}
+LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
MAKE_ENV+= USE_CURL=1
-. if ${PORT_OPTIONS:MCURL_DLOPEN}
+. if ${PORT_OPTIONS:MCURL_DLOPEN}
MAKE_ENV+= USE_CURL_DLOPEN=1
-. endif
-. endif
+. endif
+. endif
# OpenAL
-. if ${PORT_OPTIONS:MOPENAL}
+. if ${PORT_OPTIONS:MOPENAL}
USE_OPENAL= al
MAKE_ENV+= USE_OPENAL=1
-. if ${PORT_OPTIONS:MOPENAL_DLOPEN}
+. if ${PORT_OPTIONS:MOPENAL_DLOPEN}
MAKE_ENV+= USE_OPENAL_DLOPEN=1
-. endif
-. endif
+. endif
+. endif
# SDL
USE_SDL= sdl
# Vorbis
-. if ${PORT_OPTIONS:MVORBIS}
-LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
+. if ${PORT_OPTIONS:MVORBIS}
+LIB_DEPENDS+= vorbis:${PORTSDIR}/audio/libvorbis
MAKE_ENV+= USE_CODEC_VORBIS=1
-. endif
+. endif
.endif
.if ${PORT_OPTIONS:MCLIENT}
MAKE_ENV+= BUILD_CLIENT=1
PLIST_SUB+= CLIENT=""
-Q3BIN+= wop
+WOPBIN+= wop
.else
PLIST_SUB+= CLIENT="@comment "
.endif
@@ -95,12 +88,12 @@ PLIST_SUB+= CLIENT="@comment "
.if ${PORT_OPTIONS:MDEDICATED}
MAKE_ENV+= BUILD_SERVER=1
PLIST_SUB+= DEDICATED=""
-Q3BIN+= wopded
+WOPBIN+= wopded
.else
PLIST_SUB+= DEDICATED="@comment "
.endif
-.if ${PORT_OPTIONS:MGAMELIBSA} || !defined(HAVE_VM_COMPILED)
+.if ${PORT_OPTIONS:MGAMELIBS} || !defined(HAVE_VM_COMPILED)
MAKE_ENV+= BUILD_GAME_SO=1
PLIST_SUB+= GAMELIBS=""
.else
@@ -108,7 +101,7 @@ PLIST_SUB+= GAMELIBS="@comment "
.endif
.if ${PORT_OPTIONS:MMP3}
-LIB_DEPENDS+= mad.2:${PORTSDIR}/audio/libmad
+LIB_DEPENDS+= mad:${PORTSDIR}/audio/libmad
MAKE_ENV+= USE_CODEC_MP3=1
.endif
@@ -116,10 +109,10 @@ MAKE_ENV+= USE_CODEC_MP3=1
MAKE_ENV+= USE_OPTIMIZED_CFLAGS=1
.endif
-.if ${PORT_OPTIONS:MSMP}
+.if ${PORT_OPTIONS:MSMP_CLIENT}
MAKE_ENV+= BUILD_CLIENT_SMP=1
PLIST_SUB+= SMP=""
-Q3BIN+= wop-smp
+WOPBIN+= wop-smp
.else
PLIST_SUB+= SMP="@comment "
.endif
@@ -133,17 +126,17 @@ post-extract:
@cd ${WRKDIR} && ${TAR} xf readme.tar
post-patch:
-# Do not log debug output of bots (can be enabled with "homedir"/"gamedir").
+# Do not log debug output of bots (can be enabled with "homedir"/"gamedir")
@${REINPLACE_CMD} -e 's|"botlib\.log"|"/dev/null"|' \
${WRKSRC}/code/botlib/be_interface.c
do-install:
- ${MKDIR} ${DATADIR}/wop
- ${CP} -r ${WRKDIR}/wop/* ${DATADIR}/wop
+ @${MKDIR} ${DATADIR}/wop
+ ${CP} -a ${WRKDIR}/wop/* ${DATADIR}/wop
${INSTALL_DATA} ${WRKDIR}/wop.png \
${PREFIX}/share/pixmaps/${PORTNAME}.png
-.for bin in ${Q3BIN}
-# Rename wop* -> worldofpadman* to avoid conflicts with games/wop.
+.for bin in ${WOPBIN}
+# Rename wop* -> worldofpadman* to avoid conflicts with `games/wop'
${INSTALL_PROGRAM} ${WRKSRC}/build/release/${bin} \
${PREFIX}/bin/${bin:S/wop/${PORTNAME}/}
.endfor
@@ -151,12 +144,12 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/build/release/baseq3/*.so ${DATADIR}/wop
.endif
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${CP} -r ${WRKDIR}/readme/* ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
+ ${CP} -a ${WRKDIR}/readme/* ${DOCSDIR}
.endif
@${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
-maint-gen-distfile:
+generate-distfile:
@if [ -f ${DISTDIR}/${SRC_FILE}.tar.bz2 ]; then \
${ECHO_CMD} "ERROR: the distfile already exists."; \
${FALSE}; \
@@ -165,4 +158,4 @@ maint-gen-distfile:
tar cjf ${DISTDIR}/${SRC_FILE}.tar.bz2 ${SRC_FILE}
${RM} -rf ${SRC_FILE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/worldofpadman/pkg-descr b/games/worldofpadman/pkg-descr
index 7a2a30c272db..f210b41f3ee1 100644
--- a/games/worldofpadman/pkg-descr
+++ b/games/worldofpadman/pkg-descr
@@ -1,18 +1,23 @@
World of Padman (WoP) is an open source first-person shooter computer game
-available in both English and German. Originally it was a modification for the
-game Quake III Arena titled PadMod created in the year 2004. After the source
-code for Quake III Arena was released, the game became standalone. The idea is
-based on the Padman comic strip for the magazine PlayStation Games created by
-the professional cartoon artist Andreas 'ENTE' Endres, who is also the man who
-made many of the maps included with the game in 1998. The current version runs
-on an enhanced version of the ioquake3 engine, which is based on the Quake III
-Arena engine. Most of the maps in the game are lilliput style, and have a
-commercial-quality level of graphic complexity. Because it was originally a
-mod for Quake III Arena, most of the gameplay is similar. However, there is no
-Capture the Flag mode in World of Padman. World of Padman fully supports bots
-with a variety of skill levels in both online and offline play for all of the
-game types included. A single-player mode has not yet been implemented.
-Players can also record audio and video as they play. The game fully supports
-modifications, and custom maps can be created.
+available in both English and German. Originally it was a modification for
+the Quake III Arena titled PadMod, created in the year 2004.
-WWW: http://www.worldofpadman.com/
+After the source code for the Quake III Arena was released, the game became
+standalone. The idea is based on the Padman comic strip for the magazine
+PlayStation Games, created by the professional cartoon artist Andreas "ENTE"
+Endres, who is also the man who made many of the maps included with the game
+in 1998.
+
+The current version runs on an enhanced version of the ioquake3 engine, which
+is based on the Quake III Arena engine. Most of the maps in the game are
+lilliput style, and have a commercial-quality level of graphic complexity.
+
+Because it was originally a mod for Quake III Arena, most of the gameplay is
+similar. However, there is no Capture the Flag mode in World of Padman.
+World of Padman fully supports bots with a variety of skill levels in both
+online and offline play for all of the game types included. A single-player
+mode has not yet been implemented. Players can also record audio and video
+as they play. The game fully supports modifications, and custom maps can be
+created.
+
+WWW: http://www.worldofpadman.com/
diff --git a/games/worldofpadman/pkg-message b/games/worldofpadman/pkg-message
index 581f11640146..8d68c3292add 100644
--- a/games/worldofpadman/pkg-message
+++ b/games/worldofpadman/pkg-message
@@ -1,10 +1,10 @@
==============================================================================
If you have sound problems with SDL try setting the variable "s_sdlSpeed" to
-"44100". It will be saved to the configuration file.
+"44100". It will be saved to the configuration file.
-If you have sound problems with OpenAL recompile without it. Also the OPENAL
-option causes the program to omit restoring gamma and mouse sensivity after
-exitting.
+If you have sound problems with OpenAL recompile without it. Also the OPENAL
+option causes the program to omit restoring gamma and mouse sensitivity after
+exiting.
==============================================================================