aboutsummaryrefslogtreecommitdiff
path: root/games/wxlauncher
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-12-11 23:05:50 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-12-11 23:05:50 +0000
commita4e301175c9a2d07ccd912ad59b5a50320845318 (patch)
tree5581f1874982634b5a4c7381b4ec5898bf0ade8d /games/wxlauncher
parentae037399df85fef0e4ff388dcf3e039be44ca168 (diff)
downloadports-a4e301175c9a2d07ccd912ad59b5a50320845318.tar.gz
ports-a4e301175c9a2d07ccd912ad59b5a50320845318.zip
wxLauncher is a multi-platform launcher for the Freespace 2 Source Code Project.
wxLauncher aims to give one unified answer to members of the Freespace 2 Open community looking for an easy way to control fs2_open on various platforms and to those looking for an easy way to find and get updates to their Freespace 2 MODs and TCs. WWW: http://github.com/wxLauncher/wxlauncher PR: 195013 Submitted by: lightside@gmx.com
Notes
Notes: svn path=/head/; revision=374553
Diffstat (limited to 'games/wxlauncher')
-rw-r--r--games/wxlauncher/Makefile64
-rw-r--r--games/wxlauncher/distinfo2
-rw-r--r--games/wxlauncher/pkg-descr8
3 files changed, 74 insertions, 0 deletions
diff --git a/games/wxlauncher/Makefile b/games/wxlauncher/Makefile
new file mode 100644
index 000000000000..23b197e5b3e6
--- /dev/null
+++ b/games/wxlauncher/Makefile
@@ -0,0 +1,64 @@
+# Created by: lightside <lightside@gmx.com>
+# $FreeBSD$
+
+PORTNAME= wxlauncher
+PORTVERSION= 0.9.4
+CATEGORIES= games
+
+MAINTAINER= lightside@gmx.com
+COMMENT= Multi-platform launcher for the Freespace 2 Source Code Project
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/GPLv2.txt
+
+BUILD_DEPENDS= markdown_py:${PORTSDIR}/textproc/py-markdown \
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3
+
+USE_GITHUB= yes
+GH_ACCOUNT= wxLauncher
+GH_PROJECT= ${PORTNAME}
+GH_COMMIT= d251770
+GH_TAGNAME= ${GH_COMMIT}
+
+USES= cmake:outsource openal python:2:build
+USE_SDL= sdl
+USE_WX= 2.8
+WX_UNICODE= yes
+CMAKE_ARGS+= -DRESOURCES_PATH:STRING="${DATADIR}"
+
+PORTDATA= *
+PORTDOCS= Authors.txt License.txt ReadMe*.txt Thanks.txt
+
+PLIST_FILES= bin/${PORTNAME} \
+ share/pixmaps/${PORTNAME}.png
+
+DESKTOP_ENTRIES="wxLauncher" "${COMMENT}" \
+ "${PORTNAME}" "${PORTNAME}" \
+ "Game;" false
+
+OPTIONS_DEFINE= DOCS JOYSTICK
+OPTIONS_DEFAULT= JOYSTICK
+JOYSTICK_DESC= Build with joystick support
+JOYSTICK_CMAKE_ON= -DUSE_JOYSTICK:BOOL=ON
+JOYSTICK_CMAKE_OFF= -DUSE_JOYSTICK:BOOL=OFF
+
+.include <bsd.port.options.mk>
+
+post-patch: .SILENT
+# The GetPlatformDefaultConfigFilePath function used as extern inside of
+# ${WRKSRC}/code/apis/PlatformProfileManagerShared.cpp file
+ ${REINPLACE_CMD} -e 's|^inline wxFileName|extern wxFileName|' \
+ ${WRKSRC}/code/apis/FileProfileManager.cpp
+# Change version_strings.cpp.in file, based on GH_TAGNAME, without using hg
+ ${REINPLACE_CMD} -e '/find_program(HG_EXECUTABLE/d ; \
+ /version_strings.cpp will be generated/d' \
+ ${WRKSRC}/CMakeLists.txt
+ ${REINPLACE_CMD} -e 's|123456789abc+ unknown custom tip|${GH_TAGNAME}|' \
+ ${WRKSRC}/code/global/version_strings.cpp.in
+
+pre-install:
+ ${INSTALL_DATA} ${WRKSRC}/onlinehelp/images/header.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.png
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDOCS}" ${STAGEDIR}${DOCSDIR})
+
+.include <bsd.port.mk>
diff --git a/games/wxlauncher/distinfo b/games/wxlauncher/distinfo
new file mode 100644
index 000000000000..b1ccb991a3a2
--- /dev/null
+++ b/games/wxlauncher/distinfo
@@ -0,0 +1,2 @@
+SHA256 (wxlauncher-0.9.4.tar.gz) = c4f94bcc7bb84d694b0cd2a97a6dc37013ae32c9df8cb4d8377d1f55a12ea102
+SIZE (wxlauncher-0.9.4.tar.gz) = 892760
diff --git a/games/wxlauncher/pkg-descr b/games/wxlauncher/pkg-descr
new file mode 100644
index 000000000000..d7ff9aaef98e
--- /dev/null
+++ b/games/wxlauncher/pkg-descr
@@ -0,0 +1,8 @@
+wxLauncher is a multi-platform launcher for the Freespace 2 Source Code Project.
+
+wxLauncher aims to give one unified answer to members of the Freespace 2 Open
+community looking for an easy way to control fs2_open on various platforms and
+to those looking for an easy way to find and get updates to their Freespace 2
+MODs and TCs.
+
+WWW: http://github.com/wxLauncher/wxlauncher